Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 окт 2021, 23:27

Параметры процедуры

Автор aleks_p99, 01 дек 2016, 14:24

0 Пользователей и 1 гость просматривают эту тему.

aleks_p99

Здравствуйте! Процедура имеет параметр "Текст", который содержит некое значение. хочу присвоить значение этого параметра переменой "Часы", в ниже приведенном коде не получается. как можно присвоить значение и в чем ошибка у меня?

&НаКлиенте
Процедура ТабличнаяЧастьВремя1ОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
   Часы = Объект.Часы;
   Дни = Объект.Дни;
   Если Часы <> Текст Тогда
      Часы = Текст;
   Иначе Часы = Часы + Текст;
   КонецЕсли;
КонецПроцедуры

SGIRG

А где вы в итоге пытаетесь увидеть результат выполнения вашего кода?
Судя по написанному в переменную "Часы" присвоится значение из переменной "Текст".
Обратите внимание: только в переменную, а не в реквизит объекта!

Таким образом, возможно, необходимо было сделать следующим образом:
&НаКлиенте
Процедура ТабличнаяЧастьВремя1ОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
   //Часы = Объект.Часы;
   Дни = Объект.Дни;
   Если Объект.Часы <> Текст Тогда
      Объект.Часы = Текст;
   Иначе
      Объект.Часы = Объект.Часы + Текст;
   КонецЕсли;
КонецПроцедуры
Нажимайте "Спасибо", так приятнее))

aleks_p99

Цитата: SGIRG от 01 дек 2016, 14:46
А где вы в итоге пытаетесь увидеть результат выполнения вашего кода?
Судя по написанному в переменную "Часы" присвоится значение из переменной "Текст".
Обратите внимание: только в переменную, а не в реквизит объекта!

Таким образом, возможно, необходимо было сделать следующим образом:
&НаКлиенте
Процедура ТабличнаяЧастьВремя1ОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
   //Часы = Объект.Часы;
   Дни = Объект.Дни;
   Если Объект.Часы <> Текст Тогда
      Объект.Часы = Текст;
   Иначе
      Объект.Часы = Объект.Часы + Текст;
   КонецЕсли;
КонецПроцедуры

Точно:mellow: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск