Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Июн 2021, 08:14
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Параметры процедуры  (Прочитано 1136 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн aleks_p99

  • *
  • Регистрация: 2016-06-08
  • Сообщений: 29
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Здравствуйте! Процедура имеет параметр "Текст", который содержит некое значение. хочу присвоить значение этого параметра переменой "Часы", в ниже приведенном коде не получается. как можно присвоить значение и в чем ошибка у меня?

&НаКлиенте
Процедура ТабличнаяЧастьВремя1ОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
   Часы = Объект.Часы;
   Дни = Объект.Дни;
   Если Часы <> Текст Тогда
      Часы = Текст;
   Иначе Часы = Часы + Текст;
   КонецЕсли;
КонецПроцедуры


Оффлайн SGIRG

  • ***
  • Регистрация: 2014-03-26
  • Сообщений: 114
  • РЕПУТАЦИЯ: 33
  • КПД: 29%
А где вы в итоге пытаетесь увидеть результат выполнения вашего кода?
Судя по написанному в переменную "Часы" присвоится значение из переменной "Текст".
Обратите внимание: только в переменную, а не в реквизит объекта!

Таким образом, возможно, необходимо было сделать следующим образом:
&НаКлиенте
Процедура ТабличнаяЧастьВремя1ОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
   //Часы = Объект.Часы;
   Дни = Объект.Дни;
   Если Объект.Часы <> Текст Тогда
      Объект.Часы = Текст;
   Иначе
      Объект.Часы = Объект.Часы + Текст;
   КонецЕсли;
КонецПроцедуры
Нажимайте "Спасибо", так приятнее))

Оффлайн aleks_p99

  • *
  • Регистрация: 2016-06-08
  • Сообщений: 29
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
А где вы в итоге пытаетесь увидеть результат выполнения вашего кода?
Судя по написанному в переменную "Часы" присвоится значение из переменной "Текст".
Обратите внимание: только в переменную, а не в реквизит объекта!

Таким образом, возможно, необходимо было сделать следующим образом:
&НаКлиенте
Процедура ТабличнаяЧастьВремя1ОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
   //Часы = Объект.Часы;
   Дни = Объект.Дни;
   Если Объект.Часы <> Текст Тогда
      Объект.Часы = Текст;
   Иначе
      Объект.Часы = Объект.Часы + Текст;
   КонецЕсли;
КонецПроцедуры
Точно:mellow: Спасибо!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
62 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
27 Сообщений
KATERINA 861
23 Сообщений
neek666
22 Сообщений
SSC
15 Сообщений
alexandr_ll
15 Сообщений
Алексей_1985_06
11 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 184
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск