Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 08:45

Перебор таблицу значений

Автор aleks_p99, 30 ноя 2016, 12:30

0 Пользователей и 1 гость просматривают эту тему.

aleks_p99

Здравствуйте! Пытаюсь перебрать колонки таблицу значений, выдает следующую ошибку: Тип не определен (ТаблицаЗначений). Вообще, нужно получить значение следующих колонок: Время1, Время2... Время31
Код:
&НаКлиенте
Процедура ТабличнаяЧастьПриИзменении(Элемент)
   
   Таб = Новый ТаблицаЗначений;
   Таб.Колонки.Добавить("Сотрудник");
   Для День = 1 По 31 Цикл
      Время = ЭтаФорма.Элементы("" + День).Имя;
   Таб.Колонки.Добавить(Время);
   КонецЦикла;
   Для Каждого Колонка Из таб.Колонки Цикл
      Сообщить(Колонка.Имя);
   КонецЦикла
   
КонецПроцедуры

ilyay

Объект "таблица значений" на клиенте не существует, см. справку.
Можно сделать массив структур.

aleks_p99

А сразу Табличную часть перебрать можно7

ilyay

Цитата: aleks_p99 от 30 ноя 2016, 13:34
А сразу Табличную часть перебрать можно7
Объекты такого типа платформой переводятся в тип, существующий на клиенте. Можно на клиенте пройтись по табличной части объекта, но будут доступны только реквизиты, которые могут существовать на клиенте, и еще не будут доступны методы у значений реквизитов. Вы не по самой табличной части пройдете, а по ее представлению на клиенте. С таблицей значений тоже так можно сделать. Создайте ее в реквизитах формы и увидите, что тип в круглых скобках, то есть это не настоящий тип, а представление для клиента.

aleks_p99

Цитата: ilyay от 30 ноя 2016, 13:48
Цитата: aleks_p99 от 30 ноя 2016, 13:34
А сразу Табличную часть перебрать можно7
Объекты такого типа платформой переводятся в тип, существующий на клиенте. Можно на клиенте пройтись по табличной части объекта, но будут доступны только реквизиты, которые могут существовать на клиенте, и еще не будут доступны методы у значений реквизитов. Вы не по самой табличной части пройдете, а по ее представлению на клиенте. С таблицей значений тоже так можно сделать. Создайте ее в реквизитах формы и увидите, что тип в круглых скобках, то есть это не настоящий тип, а представление для клиента.
Спасибо, попробую

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск