Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
18 сен 2021, 01:02

Изменение цвета строки сотрудника при подборе в табеле учета рабочего времени 1С ЗУП 2.5

Автор ksander-fars, 28 ноя 2016, 03:27

0 Пользователей и 1 гость просматривают эту тему.

ksander-fars

Здравствуйте.

При подборе сотрудника в табель учета рабочего времени надпись в справочнике становится серой, то есть при подборе следующего сотрудника можно определить уже подобранных... Сама задача, как изменить цвет надписи или цвет строки в целом.

Процедура подбора в документе табель учета рабочего времени:

Процедура КоманднаяПанельОтработанноеВремяПодбор(Кнопка)

ПроцедурыУправленияПерсоналом.ОткрытьФормуВыбораСотрудникаОрганизации(ЭлементыФормы.ОтработанноеВремя, Ссылка, Ложь, Дата, мГоловнаяОрганизация, ТабельУчетаРабочегоВремениОрганизацииПереопределяемый.РежимПодбораСотрудников(), , ОтработанноеВремя.ВыгрузитьКолонку("Сотрудник"));

КонецПроцедуры


Ссылается на общий модуль ПроцедурыУправленияПерсоналом.ОткрытьФормуВыбораСотрудникаОрганизации:


Процедура ОткрытьФормуВыбораСотрудникаОрганизации(Владелец, Ключ, ЗакрыватьПриВыборе, ДатаСреза, ГоловнаяОрганизация = Неопределено, Режим = 0,

СтандартнаяОбработка = Неопределено, ТекущееЗначение = Неопределено, НеВыбиратьГруппы = Истина, ВыборФизлица = Ложь, ПараметрыПодбора = Неопределено, ПараметрыОтбора = Неопределено) Экспорт

СтандартнаяОбработка = Ложь;

Форма = Справочники.СотрудникиОрганизаций.ПолучитьФормуВыбора(, Владелец, Ключ);

Форма.ДатаСреза = ДатаСреза;
Если НеВыбиратьГруппы Тогда
Форма.ПараметрВыборГруппИЭлементов = ИспользованиеГруппИЭлементов.Элементы;
Иначе
Форма.ПараметрВыборГруппИЭлементов = ИспользованиеГруппИЭлементов.ГруппыИЭлементы;
КонецЕсли;
Форма.РежимВыбора = Истина;
Форма.ЗакрыватьПриВыборе = ЗакрыватьПриВыборе;
Форма.ВыборФизлица = ВыборФизлица;
Форма.мПараметрыПодбора = ПараметрыПодбора;

Если ТекущееЗначение <> Неопределено Тогда
Если ТипЗнч(ТекущееЗначение) = Тип("СправочникСсылка.СотрудникиОрганизаций") Тогда
Форма.ПараметрТекущаяСтрока = ТекущееЗначение;

ИначеЕсли ТипЗнч(ТекущееЗначение) = Тип("СправочникСсылка.ФизическиеЛица") Тогда
Форма.ПараметрТекущаяСтрока = ОсновнойСотрудникФизлица(ТекущееЗначение, ГоловнаяОрганизация);

ИначеЕсли ТипЗнч(ТекущееЗначение) = Тип("Массив") Тогда
Форма.мМассивВыбранныхЗначений = ТекущееЗначение;

Иначе
ОбщегоНазначенияЗК.СообщитьОбОшибке("Неверный тип параметра: " + ТипЗнч(ТекущееЗначение));

КонецЕсли;
КонецЕсли;

//установим отборы
Если ЗначениеЗаполнено(ГоловнаяОрганизация) Тогда
Форма.Отбор.Организация.Установить(ГоловнаяОрганизация);
Форма.Отбор.Организация.Использование = ЗначениеЗаполнено(ГоловнаяОрганизация);
КонецЕсли;

Форма.Отбор.ВидДоговора.ВидСравнения = ВидСравнения.ВСписке;
Форма.Отбор.ВидДоговора.Использование = Истина;
Форма.Отбор.ВидДоговора.Значение = ПроцедурыУправленияПерсоналомПереопределяемый.СписокДоговоровФормыВыбораСотрудника(Режим);

Если НЕ ПараметрыОтбора = Неопределено Тогда

Для каждого ЭлементОтбора Из ПараметрыОтбора Цикл

Если Форма.Отбор.Найти(ЭлементОтбора.Ключ) = Неопределено Тогда
Продолжить;
КонецЕсли;

ЗаполнитьЗначенияСвойств(Форма.Отбор[ЭлементОтбора.Ключ], ЭлементОтбора.Значение);

Если ЭлементОтбора.Значение.Свойство("НастройкаОтбора") Тогда
ТабличноеПоле = Форма.ЭлементыФормы.СправочникСписок;
ТабличноеПоле.НастройкаОтбора[ЭлементОтбора.Ключ].Доступность =  ЭлементОтбора.Значение.НастройкаОтбора;
КонецЕсли;

КонецЦикла;

КонецЕсли;

Форма.Открыть();
КонецПроцедуры

Куда дальше смотреть и что изменить?

ksander-fars

Вот так выглядит список сотрудников при подборе.

alex0402

Цитата: ksander-fars от 28 ноя 2016, 03:27Форма = Справочники.СотрудникиОрганизаций.ПолучитьФормуВыбора(, Владелец, Ключ);

В форму выбора. там где-то есть оформлениеСтрок. или как-то так. в процедуре при получении данных
Спасибо за Сказать спасибо

ksander-fars

Да действительно в форме списка справочника СотрудникиОрганизации строка Оформление.ЦветТекста   = ЦветаСтиля.ЦветПодобранногоЭлемента; заменил на нужный RGB и всё заработало. Спасибо.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск