Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 окт 2021, 15:46

Подсчет продаж за период

Автор Алекс Витальевич, 25 ноя 2016, 03:37

0 Пользователей и 1 гость просматривают эту тему.

Алекс Витальевич

Здравствуйте,форумчане! Так как в 1С еще не полностью разобрался,прошу помощи. Конфигурация комплексная, 4.5. Необходимо во множественном фильтре выбрать некие позиции,выбрать склад, вытащить код, наименование, количество проданных единиц товара за каждый месяц (это может быть как 2, так и 5 месяцев, а может и вообще год), вывести в колонках продажи помесячно в таблицу и просуммировать продажи по каждому товару в еще одну колонку. Со множественным фильтром разобрался, не знаю, каким образом сделать вывод колонок на каждый месяц. Делал подобное с группировкой "День" следующим образом:

Таб.ВывестиСекцию("Шапка|Лев");
    С=ВыбКонПериода-ВыбНачПериода;
    День = ВыбНачПериода;
    Для е=1 по С+1 Цикл
        Таб.ПрисоединитьСекцию("Шапка|День");
        День=День+1;
    КонецЦикла;

а затем методом "Присоединить секцию" добавлял колонки. Как подобное провернуть с группировкой "День"? И откуда достать код номенклатуры, если сам товар дергаю из отчета ккм?
P.S. И еще вопрос,если нужно брать не последовательный период нескольких месяцев, а, допустим, три (март,июнь,сентябрь), как тогда нужно переделать запрос?

Алекс Витальевич

Цитата: Алекс Витальевич от 25 ноя 2016, 03:37Как подобное провернуть с группировкой "День"?
Прошу прощения,с группировкой "Месяц"

Алекс Витальевич


alex0402

Цитата: Алекс Витальевич от 25 ноя 2016, 03:37И откуда достать код номенклатуры

Номенклатура.Код
Спасибо за Сказать спасибо

alexandr_ll

Цитата: Алекс Витальевич от 25 ноя 2016, 04:29
Цитата: Алекс Витальевич от 25 ноя 2016, 03:37Как подобное провернуть с группировкой "День"?
Прошу прощения,с группировкой "Месяц"
Есть конструкция "ДобавитьМесяц", либо в запросе использовать группировку "Месяц"

Алекс Витальевич

ЦитироватьЕсть конструкция "ДобавитьМесяц", либо в запросе использовать группировку "Месяц"
группировку "Месяц" я и так использую..с днем то было все просто,ВыбКонПериода-ВыбНачПериода = количество дней, а вот с месяцами как? В каждом месяце ведь то 30,то 31 день...

alex0402

Использовать функции ДатаГод,ДатаМесяц,ДатаЧисло,ДобавитьМесяц.
Спасибо за Сказать спасибо

Алекс Витальевич

Вроде получилось, но на выходе таблицы получилось так, что он выводит не названия месяцев, а какую-то фигню...хотя в ТЗ выводится первыми числами месяцев
Таб.ВывестиСекцию("Заголовок|Лев");
    С=ДатаМесяц(ВыбКонПериода)-ДатаМесяц(ВыбНачПериода);
    Месяц = ВыбНачПериода;
    Для е=1 по С+1 Цикл
        Таб.ПрисоединитьСекцию("Заголовок|Мес");
        Месяц=Месяц+ДобавитьМесяц(ВыбНачПериода,1);
    КонецЦикла;

    Для N = 1 По ТабВыгр.КоличествоСтрок() Цикл
    //Ном = ТЗ.ПолучитьСтрокуПоНомеру(N);
        //Код             = ТабВыгр.ПолучитьЗначение(N,"Код");
        Номенклатура    = ТабВыгр.ПолучитьЗначение(N,"Товар");
        Месяц            = ТабВыгр.ПолучитьЗначение(N,"Месяц");
        Количество         = ТабВыгр.ПолучитьЗначение(N,"КоличествоСумма");

        Если ПустоеЗначение(Месяц)=1 тогда
            продолжить
            иначе
            Если Ном <> Номенклатура тогда
                Таб.ВывестиСекцию("Сформировать|Лев");
                Таб.ПрисоединитьСекцию("Сформировать|Мес");
                Ном = Номенклатура;
               иначе
                Таб.ПрисоединитьСекцию("Сформировать|Мес");
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
     // Подготовка к заполнению выходных форм данными запроса
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");

alex0402

Смотреть в отладчике или Сообщить() что на самом деле происходит при  печати шапки...
Спасибо за Сказать спасибо

Алекс Витальевич

И почему-то запрос у меня в ТЗ не выгружает код товара,хотя в запросе я его указываю

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск