Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2021, 17:11
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Неправильно формируются движения в регистре сведений  (Прочитано 1219 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Зингер

  • *
  • Регистрация: 2016-11-07
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Регистр сведений (ГрафикРаботы)- Непериодический, Подчинение регистратору.
В модуле:
Процедура ОбработкаПроведения(Отказ, Режим)
ДеньГрафика=ДатаНачала;
Движения.ГрафикРаботы.Записывать = Истина;
Пока ДеньГрафика<=ДатаОкончания Цикл
// регистр ГрафикРаботы
Движение = Движения.ГрафикРаботы.Добавить();
Движение.Дата = Дата;
Если ДеньНедели(ДеньГрафика)<6 Тогда
Движение.РабочийДень = 1;
Иначе
Движение.РабочийДень=0;
КонецЕсли;
ДеньГрафика=ДеньГрафика+24*3600;
//Движения.Записать();
КонецЦикла;
КонецПроцедуры
При выполнении выскакивает ошибка:
Цитировать
Запись с такими ключевыми полями существует!:ГрафикРаботы:24.11.2016 0:00:00(Регистр сведений: график работы; номер строки:2)

Если убрать комментарий в коде, то в регистр записывается только одна строка с датой документа. Подскажите пож-та, в чем дело.


Оффлайн Kironten

  • *****
  • Регистрация: 2013-08-12
  • Сообщений: 906
  • РЕПУТАЦИЯ: 187
  • КПД: 21%
  • Профессия: Ученик 1С
Движение.Дата = Дата;

Значение измерения не меняете.

Оффлайн Зингер

  • *
  • Регистрация: 2016-11-07
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Движение.Дата = Дата;

Значение измерения не меняете.

Точно! Спасибо!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
LexaK
68 Сообщений
antoneus antoneus
33 Сообщений
Ивашка
27 Сообщений
neek666
26 Сообщений
KATERINA 861
19 Сообщений
Алексей_1985_06
15 Сообщений
SSC
15 Сообщений
alexandr_ll
14 Сообщений
BuhRust
8 Сообщений

* Кто онлайн

  • Точка Гостей: 519
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск