Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 сен 2021, 05:11

НАЙТИ ПО НАИМЕНОВАНИЮ. Не работает метод справочника. (Начинающий программист)

Автор Димыч, 23 ноя 2016, 22:11

0 Пользователей и 1 гость просматривают эту тему.

Димыч

Вечер добрый всем, уважаемые. Я начинающий, обучаюсь самостоятельно. Вопрос пишу первый раз. Буду рад любой помощи. Заранее благодарю.

ВХОДНЫЕ ДАННЫЕ:
1) Имеется справочник АВТОМОБИЛИ с реквизитами НАИМЕНОВАНИЕ и ГОСНОМЕР.
2) Написана обработка: при запуске необходимо ввести строку поиска автомобиля по наименованию. В зависимости от результата выдается сообщение либо "НЕТ ТАКОГО А/М" либо ГОСНОМЕР найденного авто.

ПРОБЛЕМА:
При вводе любого значения (даже имеющегося в справочнике) обработка выдает "НЕТ ТАКОГО А/М".
Что не так?

   Перем Переменная;
   Поиск=Справочники.Автомобили.НайтиПоНаименованию(ВвестиСтроку(Переменная,"Введите строку поиска"),Истина);
   Если Поиск.Пустая()=Истина Тогда
      Сообщить("Нет такого а/м");
   Иначе
      Сообщить(Поиск.Наименование);
   КонецЕсли;
   




cska-fanat-kz

Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

sertak

Цитата: Димыч от 23 ноя 2016, 22:11
    Перем Переменная;
    Поиск=Справочники.Автомобили.НайтиПоНаименованию(ВвестиСтроку(Переменная,"Введите строку поиска"),Истина);
    Если Поиск.Пустая()=Истина Тогда
        Сообщить("Нет такого а/м");
    Иначе
        Сообщить(Поиск.Наименование);
    КонецЕсли;

Если ВвестиСтроку(Переменная,"Введите строку поиска") Тогда
    Поиск=Справочники.Автомобили.НайтиПоНаименованию(Переменная,Истина);
    ...
КонецЕсли;

Димыч

Благодарю. Разобрался. Предварительно создал переменную, в которую поместил введенное значение. Все работает.

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск