Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 сен 2021, 17:57

Как получать по умолчанию определенные значения реквизитов справочника при создании элемента

Автор ktu78, 21 ноя 2016, 18:14

0 Пользователей и 1 гость просматривают эту тему.

ktu78

Добрый день. коллеги. Вопрос по 1с 77
Хочу, чтоб при создании элемента справочника ТМЦ в его реквизитах "Единица измерения" и "Вид ТМЦ" по умолчанию стояли значения.
Для этого в модуле формы элемента создал обработчик "ПриОткрытии"

Процедура ПриОткрытии()
   СпрЕИ = СоздатьОбъект("Справочник.ЕдиницаИзмерения");
   ЕдиницаИзмерения = СпрЕИ.НайтиПоНаименованию("Шт.");
   ВидТМЦ = Перечисление.ВидТМЦ.Товар;
    //ВидТМЦ ЕдиницаИзмерения - реквизиы справочника
КонецПроцедуры

Ошибок не выдает, но нет заполнения по умолчанию. Подсобите пожалуйста. Заранее благодарен

Mitay_D

не та процедура
вот как надо

Процедура ВводНового(Копирование)

Если Копирование = 1 Тогда
Возврат;
КонецЕсли; 
СпрЕИ = СоздатьОбъект("Справочник.ЕдиницаИзмерения");
СпрЕИ .НайтиПоНаименованию("Шт.");
ЕдиницаИзмерения = СпрЕИ.ТекущийЭлемент();
ВидТМЦ = Перечисление.ВидТМЦ.Товар;


КонецПроцедуры //

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск