Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2021, 17:42
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Вычислить сумму чеков ККМ в списке с отбором  (Прочитано 1459 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Максим_

  • *
  • Регистрация: 2016-11-14
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Очень далек от программирования 1С, но встала (как казалось) простая задача - в УТ 10.3 (8.1) Вывести количество у сумму розничных чеков, нашел похожий код, но доподогнать его к соей задаче не могу...
Помогите..

Процедура ПоказатьСуммуИтого()      
    Сумма=0;
    СуммаЧеков=0;   
     //Задача - посчитать кол-во проведенных ЧекиККМ и общую сумму чеков ККМ, которые отобраны отбором
     //ТаблицаРегистра - табличное поле формы
     ТаблицаРегистра=ЭлементыФормы.Список;
    //Т - данные элемента формы ТаблицаРегистра, имеют тип, например "РегистрНакопленияНаборЗаписей.ЗатратыБухгалтерскийУчет"
     Т=Неопределено;
    Выполнить("РегистрыСведений.ЧекиККМ="+ТаблицаРегистра.Данные);
    //Список строк, которые считаем
     Строки=Новый Массив();
    //Перебираем все строки источника данных
     Для Каждого Стр ИЗ Т Цикл   
        //Пробуем у табличного поля поставить в качестве текущей строки текущую строку источника данных
         //Такое присваивание работает как ни странно даже для типа  РегистрНакопленияЗапись.ЗатратыБухгалтерскийУчет
         //Т.е. даже для записей из набора записей работает
         ТаблицаРегистра.ТекущаяСтрока=Стр;
         //Если строка попадает в отбор, то текущая строка устанавливается, иначе остается прежней
         Если ТаблицаРегистра.ТекущаяСтрока=Стр Тогда
            Строки.Добавить(Стр); //Здесь логика алгоритма - то, что в отборе, нужно посчитать
         КонецЕсли;
    КонецЦикла;
    //Перебираем
   Для Каждого Стр ИЗ Строки Цикл
         СуммаЧеков=СуммаЧеков+1
     КонецЦикла;
   
   ЭлементыФормы.СуммаИтого.Заголовок=СуммаЧеков; 
   
КонецПроцедуры   


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • *****
  • Регистрация: 2012-08-15
  • Сообщений: 7151
  • РЕПУТАЦИЯ: 845
  • КПД: 12%
    • Skype: MuI_I_Ika
  • Профессия: Программист 1С

Оффлайн Максим_

  • *
  • Регистрация: 2016-11-14
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Например, в этой строке ошибка , но что именно тут написать, ума не приложу
Выполнить("РегистрыСведений.ЧекиККМ="+ТаблицаРегистра.Данные);


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • *****
  • Регистрация: 2012-08-15
  • Сообщений: 7151
  • РЕПУТАЦИЯ: 845
  • КПД: 12%
    • Skype: MuI_I_Ika
  • Профессия: Программист 1С
Попробуйте вот так:

Выполнить("РегистрыСведений.ЧекиККМ=СокрЛП("""+ТаблицаРегистра.Данные+""")");


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
LexaK
68 Сообщений
antoneus antoneus
33 Сообщений
Ивашка
27 Сообщений
neek666
26 Сообщений
KATERINA 861
19 Сообщений
Алексей_1985_06
15 Сообщений
SSC
15 Сообщений
alexandr_ll
14 Сообщений
MiThO
8 Сообщений

* Кто онлайн

  • Точка Гостей: 431
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск