Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 06:19

Вычислить сумму чеков ККМ в списке с отбором

Автор Максим_, 14 ноя 2016, 18:56

0 Пользователей и 1 гость просматривают эту тему.

Максим_

Очень далек от программирования 1С, но встала (как казалось) простая задача - в УТ 10.3 (8.1) Вывести количество у сумму розничных чеков, нашел похожий код, но доподогнать его к соей задаче не могу...
Помогите..

Процедура ПоказатьСуммуИтого()      
    Сумма=0;
    СуммаЧеков=0;   
     //Задача - посчитать кол-во проведенных ЧекиККМ и общую сумму чеков ККМ, которые отобраны отбором
     //ТаблицаРегистра - табличное поле формы
     ТаблицаРегистра=ЭлементыФормы.Список;
    //Т - данные элемента формы ТаблицаРегистра, имеют тип, например "РегистрНакопленияНаборЗаписей.ЗатратыБухгалтерскийУчет"
     Т=Неопределено;
    Выполнить("РегистрыСведений.ЧекиККМ="+ТаблицаРегистра.Данные);
    //Список строк, которые считаем
     Строки=Новый Массив();
    //Перебираем все строки источника данных
     Для Каждого Стр ИЗ Т Цикл   
        //Пробуем у табличного поля поставить в качестве текущей строки текущую строку источника данных
         //Такое присваивание работает как ни странно даже для типа  РегистрНакопленияЗапись.ЗатратыБухгалтерскийУчет
         //Т.е. даже для записей из набора записей работает
         ТаблицаРегистра.ТекущаяСтрока=Стр;
         //Если строка попадает в отбор, то текущая строка устанавливается, иначе остается прежней
         Если ТаблицаРегистра.ТекущаяСтрока=Стр Тогда
            Строки.Добавить(Стр); //Здесь логика алгоритма - то, что в отборе, нужно посчитать
         КонецЕсли;
    КонецЦикла;
    //Перебираем
   Для Каждого Стр ИЗ Строки Цикл
         СуммаЧеков=СуммаЧеков+1
     КонецЦикла;
   
   ЭлементыФормы.СуммаИтого.Заголовок=СуммаЧеков; 
   
КонецПроцедуры   

MuI_I_Ika


Максим_

Например, в этой строке ошибка , но что именно тут написать, ума не приложу
Выполнить("РегистрыСведений.ЧекиККМ="+ТаблицаРегистра.Данные);


MuI_I_Ika

Попробуйте вот так:

Выполнить("РегистрыСведений.ЧекиККМ=СокрЛП("""+ТаблицаРегистра.Данные+""")");

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск