Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2021, 16:33
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Открыть файл или папку программно  (Прочитано 17374 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Оффлайн Ручей

  • *
  • Регистрация: 2016-10-18
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Вопрос по версии 8.3
Пишу в теме версии 7, т.к. не нашёл куда написать.

Как программно открыть файл или папку для просмотра, имя к которому(ой) храниться в переменной.
Нашёл такой пример, но в 8.3 не работает. Пишет: "Использование синхронных методов на клиенте запрещено"
&НаКлиенте
Процедура ОткрФайлЗаказа(Команда)
текСтрока = Элементы.Список.ТекущаяСтрока;
ИмяФайла = ФайлНаСервер(текСтрока);
    ЗапуститьПриложение(ИмяФайла);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ФайлНаСервер(Спр);
Возврат Спр.ФайлЗаказа;

КонецФункции



Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • *****
  • Регистрация: 2012-08-15
  • Сообщений: 7151
  • РЕПУТАЦИЯ: 845
  • КПД: 12%
    • Skype: MuI_I_Ika
  • Профессия: Программист 1С
Либо разрешите синхронные методы в конфигурации либо используйте методы типа НачатьЗапускПриложения

Оффлайн Fedor_Safonchik

  • *
  • Регистрация: 2016-06-16
  • Сообщений: 48
  • РЕПУТАЦИЯ: 8
  • КПД: 17%
  • Профессия: Ученик 1С
Пользуйтесь)   
ЗапуститьПриложение("D:\катол\подкаталог\и так далее");

Оффлайн Ручей

  • *
  • Регистрация: 2016-10-18
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Либо разрешите синхронные методы в конфигурации либо используйте методы типа НачатьЗапускПриложения
Почему-то не работало у меня НачатьЗапускПриложения. Может что то не то делал. Этот метод работает.
&НаКлиенте
Процедура ОткрФайлЗаказа(Команда)
текСтрока = Элементы.Список.ТекущаяСтрока;
ИмяФайла = ЗначениеФайлЗаказа(текСтрока);
Оповещение = Новый ОписаниеОповещения("ЗапускПриложения", ЭтотОбъект);
    НачатьЗапускПриложения(Оповещение,ИмяФайла);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ЗначениеФайлЗаказа(Спр);
Возврат Спр.ФайлЗаказа;

КонецФункции

&НаКлиенте
Процедура ЗапускПриложения(КодВозврата, ДополнительныйПараметр) Экспорт
       
КонецПроцедуры


Онлайн LexaK

  • *****
  • Регистрация: 2012-05-16
  • Сообщений: 2570
  • РЕПУТАЦИЯ: 824
  • КПД: 32%
  • Профессия: Программист 1С
а что пишет?
какая ошибка?

протестировал у себя, файл открывается на ура!
ИмяФайла = "D:\1111.jpg";
Оповещение = Новый ОписаниеОповещения("ОповещениеК", ЭтотОбъект);
НачатьЗапускПриложения(Оповещение,ИмяФайла);
Помогло? - Нажми СПАСИБО (под аватаром) !!!
                       :)

Оффлайн Ручей

  • *
  • Регистрация: 2016-10-18
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
а что пишет?
какая ошибка?

протестировал у себя, файл открывается на ура!
ИмяФайла = "D:\1111.jpg";
Оповещение = Новый ОписаниеОповещения("ОповещениеК", ЭтотОбъект);
НачатьЗапускПриложения(Оповещение,ИмяФайла);
Сейчас всё работает.
До этого пробовал использовать НачатьЗапускПриложения и не работало. Возможно раньше в коде была ошибка.


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
LexaK
68 Сообщений
antoneus antoneus
33 Сообщений
Ивашка
27 Сообщений
neek666
26 Сообщений
KATERINA 861
19 Сообщений
SSC
15 Сообщений
Алексей_1985_06
15 Сообщений
alexandr_ll
14 Сообщений
BuhRust
8 Сообщений

* Кто онлайн

  • Точка Гостей: 548
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск