Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 05:11

Открыть файл или папку программно

Автор Ручей, 12 ноя 2016, 14:59

0 Пользователей и 1 гость просматривают эту тему.

Ручей

Вопрос по версии 8.3
Пишу в теме версии 7, т.к. не нашёл куда написать.

Как программно открыть файл или папку для просмотра, имя к которому(ой) храниться в переменной.
Нашёл такой пример, но в 8.3 не работает. Пишет: "Использование синхронных методов на клиенте запрещено"

&НаКлиенте
Процедура ОткрФайлЗаказа(Команда)
текСтрока = Элементы.Список.ТекущаяСтрока;
ИмяФайла = ФайлНаСервер(текСтрока);
    ЗапуститьПриложение(ИмяФайла);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ФайлНаСервер(Спр);
Возврат Спр.ФайлЗаказа;

КонецФункции


MuI_I_Ika

Либо разрешите синхронные методы в конфигурации либо используйте методы типа НачатьЗапускПриложения

Fedor_Safonchik

Пользуйтесь)   

ЗапуститьПриложение("D:\катол\подкаталог\и так далее");

Ручей

Цитата: MuI_I_Ika от 15 ноя 2016, 11:17
Либо разрешите синхронные методы в конфигурации либо используйте методы типа НачатьЗапускПриложения
Почему-то не работало у меня НачатьЗапускПриложения. Может что то не то делал. Этот метод работает.

&НаКлиенте
Процедура ОткрФайлЗаказа(Команда)
текСтрока = Элементы.Список.ТекущаяСтрока;
ИмяФайла = ЗначениеФайлЗаказа(текСтрока);
Оповещение = Новый ОписаниеОповещения("ЗапускПриложения", ЭтотОбъект);
    НачатьЗапускПриложения(Оповещение,ИмяФайла);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ЗначениеФайлЗаказа(Спр);
Возврат Спр.ФайлЗаказа;

КонецФункции

&НаКлиенте
Процедура ЗапускПриложения(КодВозврата, ДополнительныйПараметр) Экспорт
       
КонецПроцедуры


LexaK

а что пишет?
какая ошибка?

протестировал у себя, файл открывается на ура!

ИмяФайла = "D:\1111.jpg";
Оповещение = Новый ОписаниеОповещения("ОповещениеК", ЭтотОбъект);
НачатьЗапускПриложения(Оповещение,ИмяФайла);
ответ Понравился? (в смысле пригодился?)

Ручей

Цитата: LexaK от 15 ноя 2016, 16:07
а что пишет?
какая ошибка?

протестировал у себя, файл открывается на ура!

ИмяФайла = "D:\1111.jpg";
Оповещение = Новый ОписаниеОповещения("ОповещениеК", ЭтотОбъект);
НачатьЗапускПриложения(Оповещение,ИмяФайла);

Сейчас всё работает.
До этого пробовал использовать НачатьЗапускПриложения и не работало. Возможно раньше в коде была ошибка.

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск