Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Июн 2021, 23:55
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Перечисления НДС не получается перевести в числовой формат  (Прочитано 2114 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ksru

  • *
  • Регистрация: 2016-11-03
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Как можно сделать чтоб НДС считалось если оно заданно в перечислениях?
Если можно то скиньте пример.



Оффлайн LexaK

  • *****
  • Регистрация: 2012-05-16
  • Сообщений: 2564
  • РЕПУТАЦИЯ: 820
  • КПД: 32%
  • Профессия: Программист 1С
вот пример получения ставки(%) НДС из БП30.
Функция ПолучитьСтавкуНДС(СтавкаНДС, ПрименяютсяСтавки4и2 = Ложь) Экспорт

Если СтавкаНДС = Перечисления.СтавкиНДС.НДС20 ИЛИ СтавкаНДС = Перечисления.СтавкиНДС.НДС20_120 Тогда
Возврат 20;
ИначеЕсли СтавкаНДС = Перечисления.СтавкиНДС.НДС10 ИЛИ СтавкаНДС = Перечисления.СтавкиНДС.НДС10_110 Тогда
Ставка = ?(ПрименяютсяСтавки4и2, 2, 10);
Возврат Ставка;
ИначеЕсли СтавкаНДС = Перечисления.СтавкиНДС.НДС18 ИЛИ СтавкаНДС = Перечисления.СтавкиНДС.НДС18_118 Тогда
Ставка = ?(ПрименяютсяСтавки4и2, 4, 18);
Возврат Ставка;
КонецЕсли;

Возврат 0;

КонецФункции

Помогло? - Нажми СПАСИБО (под аватаром) !!!
                       :)

Оффлайн ksru

  • *
  • Регистрация: 2016-11-03
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
будет работать?

Функция ПолучитьСтавкуНДС(СтавкаНДС) Экспорт

СтрокаТабличнойЧасти=Элементы.ЗаказанныйТовар.ТекущиеДанные;
Если СтрокаТабличнойЧасти.НДС = Перечисления.НДС.Процент18 Тогда
СтрокаТабличнойЧасти.НДС=18;

ИначеЕсли СтавкаНДС = Перечисления.НДС.Процент10 Тогда
СтрокаТабличнойЧасти.НДС= 10;
ИначеЕсли СтавкаНДС = Перечисления.НДС.БезНДС Тогда
СтрокаТабличнойЧасти.НДС= 0;
Иначе
СтрокаТабличнойЧасти.НДС= 0;
КонецЕсли;
КонецФункции

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • *****
  • Регистрация: 2010-11-06
  • Сообщений: 5748
  • РЕПУТАЦИЯ: 1105
  • КПД: 19%
  • Красная армия всех сильней!
    • Skype: cska-fanat-kz81
  • Профессия: Разработчик 1С
будет работать?

Функция ПолучитьСтавкуНДС(СтавкаНДС) Экспорт

СтрокаТабличнойЧасти=Элементы.ЗаказанныйТовар.ТекущиеДанные;
Если СтрокаТабличнойЧасти.НДС = Перечисления.НДС.Процент18 Тогда
СтрокаТабличнойЧасти.НДС=18;

ИначеЕсли СтавкаНДС = Перечисления.НДС.Процент10 Тогда
СтрокаТабличнойЧасти.НДС= 10;
ИначеЕсли СтавкаНДС = Перечисления.НДС.БезНДС Тогда
СтрокаТабличнойЧасти.НДС= 0;
Иначе
СтрокаТабличнойЧасти.НДС= 0;
КонецЕсли;
КонецФункции

не то, не тем и не туда :^454^:
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн LexaK

  • *****
  • Регистрация: 2012-05-16
  • Сообщений: 2564
  • РЕПУТАЦИЯ: 820
  • КПД: 32%
  • Профессия: Программист 1С
там где у вас в документе расчитывается/пересчитывается сумма,
при изменении Количества, цены и т.д.

как пример, который надо допилить.
&НаКлиенте
Процедура ТоварыКоличествоПриИзменении(Элемент)

    СтрокаТабличнойЧасти=Элементы.ЗаказанныйТовар.ТекущиеДанные;
    СтрокаТабличнойЧасти.СуммаНДС = СтрокаТабличнойЧасти.Количество
        * СтрокаТабличнойЧасти.Цена
        * ПолучитьСтавкуНДС(СтрокаТабличнойЧасти.СтавкаНДС); //обращение к описанной выше функции

КонецПроцедуры

Помогло? - Нажми СПАСИБО (под аватаром) !!!
                       :)


Теги:
 

При выплате гранта НДС не возникает

Автор newsРаздел Новости

Ответов: 0
Просмотров: 818
Последний ответ 20 Мая 2016, 12:35
от news
Иностранные интернет-торговцы должны будут платить НДС

Автор newsРаздел Новости

Ответов: 0
Просмотров: 728
Последний ответ 22 Авг 2016, 22:06
от news
Определение 3-летнего срока для вычета НДС по приобретенным товарам

Автор newsРаздел Новости

Ответов: 0
Просмотров: 551
Последний ответ 05 Окт 2015, 10:41
от news
Утратив право на ПСН, можно получить освобождение от НДС

Автор newsРаздел Новости

Ответов: 0
Просмотров: 617
Последний ответ 02 Ноя 2015, 22:56
от news
Про код операции, который нужно указывать при реализации имущества банкротов в декларации по НДС

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1028
Последний ответ 29 Апр 2015, 10:14
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
62 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
27 Сообщений
KATERINA 861
23 Сообщений
neek666
23 Сообщений
alexandr_ll
15 Сообщений
SSC
15 Сообщений
Алексей_1985_06
11 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 198
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Инструменты

* Дополнительно

Поиск