Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 июн 2021, 01:41

Модуль объекта не обнаружен в модуле менеждера

Автор JOG, 10 ноя 2016, 10:13

0 Пользователей и 1 гость просматривают эту тему.

JOG

Здравствуйте!

Есть документ Касса, с табличной частью РасходПриход.

При заполнении ТЧ как на скрине, в результате получается следующая печатная форма:

Вопрос: Как удалить пустые строки из печатной формы документа?

Уже много страниц в инете прочитал и пробовал вариации кода, но 1с выдаёт ошибку:
"Метод Объекта не обнаружен(НайтиСтроки)" при таком коде:

ВыборкаРасходПриход = Выборка.РасходПриход.Выбрать();
Пока ВыборкаРасходПриход.Следующий() Цикл
Приход.Параметры.Заполнить(ВыборкаРасходПриход);
Отбор=Новый Структура;
Отбор.Вставить("ПриходНаименование",Неопределено);
Отбор.Вставить("СуммаПриход",Неопределено);

Массив=ВыборкаРасходПриход.НайтиСтроки(Отбор);

Для х=0 по Массив.ВГраница() Цикл
  ВыборкаРасходПриход.Удалить(Массив[х]);
КонецЦикла;
ТабДок.Вывести(Приход, Выборка.Уровень());
КонецЦикла;

Или такая ошибка: "Метод объекта не обнаружен (Удалить)" при таком коде:

ВсегоСтрок = ВыборкаРасходПриход.Количество();
Для Стр = 1 по ВсегоСтрок Цикл
Строка = ВыборкаРасходПриход[ВсегоСтрок - Стр];
Если ПустаяСтрока(Строка) Тогда
ВыборкаРасходПриход.Удалить(Строка);
КонецЕсли;
КонецЦикла;


Всё это происходит в модуле менеджера "Процедура Печать(ТабДок, Ссылка) Экспорт".
Помогите советом, а то встрял и ни туда ни сюда..

LexaK

при печати не надо ни чего удалять, просто поставьте проверку
Если Наименование заполнено то выводите строку, если не заполнено эта строка будет пропущена
вот пример, из вашего кода


ВыборкаРасходПриход = Выборка.РасходПриход.Выбрать();   
Пока ВыборкаРасходПриход.Следующий() Цикл
Если ЗначениеЗаполнено(ВыборкаРасходПриход.ПриходНаименование) Тогда
//есть данные, выводим
        Приход.Параметры.Заполнить(ВыборкаРасходПриход);
        ТабДок.Вывести(Приход, Выборка.Уровень());
КонецЕсли;
КонецЦикла;

Помогло? - Нажми СПАСИБО (под аватаром) !!!
                       :)

JOG


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск