Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 сен 2021, 05:29

условное форматирование в обычных формах

Автор ktu78, 08 ноя 2016, 15:07

0 Пользователей и 1 гость просматривают эту тему.

ktu78

Добрый день. Мне нужно при выводе плана счетов в обычную форму списка чтоб счета верхних уровней (2,20) были выделены другим цветом, чем остальные (У них параметр Запретить использовать в проводках - Ложь).
В управляемых формах легко - есть динамический список, там в свойствах есть Условное форматирование, а как делается в обычных формах, хотя бы на примере формы списка плана счетов. Спасибо!

cska-fanat-kz

а в типовом решении посмотреть не судьба?
Процедура СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

Колонка  = ОформлениеСтроки.Ячейки;
Субконто = ДанныеСтроки.ВидыСубконто;

Если Субконто.Количество() >= 1 Тогда
Колонка.Субконто1.УстановитьТекст(?(Субконто[0].ТолькоОбороты, "(об) ", "") + Субконто[0].ВидСубконто);
КонецЕсли;

Если Субконто.Количество() >= 2 Тогда
Колонка.Субконто2.УстановитьТекст(?(Субконто[1].ТолькоОбороты, "(об) ", "") + Субконто[1].ВидСубконто);
КонецЕсли;

Если Субконто.Количество() = 3 Тогда
Колонка.Субконто3.УстановитьТекст(?(Субконто[2].ТолькоОбороты, "(об) ", "") + Субконто[2].ВидСубконто);
КонецЕсли;

Если ДанныеСтроки.ЗапретитьИспользоватьВПроводках Тогда
ОформлениеСтроки.ЦветФона = WebЦвета.СветлоЖелтый;
КонецЕсли;

Вид = ДанныеСтроки.Вид;
Если Вид = ВидСчета.Активный  Тогда
Колонка.Вид.УстановитьТекст("А");
ИначеЕсли Вид = ВидСчета.Пассивный  Тогда
Колонка.Вид.УстановитьТекст("П");
Иначе
Колонка.Вид.УстановитьТекст("АП");
КонецЕсли;

КонецПроцедуры
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск