Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Июн 2021, 08:28
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Помогите пожалуйста, ТЧ Документа вывести во внешнюю печатную форму,выводить выводит но множит по строкам  (Прочитано 1502 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Комарова Ольга

  • *
  • Регистрация: 2016-11-05
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
 Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
               |   БСО_Поступление.СоставБСО.(
               |      Ссылка,
               |      НомерСтроки,
               |      БСО,
               |      СерияБСО,
               |      НомерНачальный,
               |      НомерКонечный,
               |      Количество,
               |      Маска
               |   ) КАК Материалы
               |ИЗ
               |   Документ.БСО_Поступление КАК БСО_Поступление
               |ГДЕ
               |   БСО_Поступление.Ссылка = &Ссылка";
Запрос.УстановитьПараметр("Ссылка",СсылкаНаОбъект);
Запрос.УстановитьПараметр("ТекущаяДата",ТекущаяДата());

Выборка = Запрос.Выполнить().Выбрать();
//Выборка.Следующий();
Пока Выборка.Следующий() Цикл
ТаблицаТЧ = Выборка.Материалы.Выгрузить();

Для Каждого СтрокаТЧ Из ТаблицаТЧ Цикл
      ОбластьСоставБСО.Параметры.Заполнить(СтрокаТЧ);
 КонецЦикла;      
       ТабличныйДок.Вывести(ОбластьСоставБСО);
      
   
КонецЦикла;


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • *****
  • Регистрация: 2010-11-06
  • Сообщений: 5748
  • РЕПУТАЦИЯ: 1105
  • КПД: 19%
  • Красная армия всех сильней!
    • Skype: cska-fanat-kz81
  • Профессия: Разработчик 1С
по этому фрагменту мало понятно как остальная таблица формируется...
по идее должно быть не...
Для Каждого СтрокаТЧ Из ТаблицаТЧ Цикл
      ОбластьСоставБСО.Параметры.Заполнить(СтрокаТЧ);
 КонецЦикла;     
       ТабличныйДок.Вывести(ОбластьСоставБСО);

а

Для Каждого СтрокаТЧ Из ТаблицаТЧ Цикл
    ОбластьСоставБСО = Макет.ПолучитьОбласть("ОбластьСоставБСО");
      ОбластьСоставБСО.Параметры.Заполнить(СтрокаТЧ);
       ТабличныйДок.Вывести(ОбластьСоставБСО);
 КонецЦикла;     

а то у вас из всех строк выводится только одна - последняя...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Комарова Ольга

  • *
  • Регистрация: 2016-11-05
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
Извините,что запутала
Да,вы правы, у меня два варианта формирования, либо формируються все строчки из табличной части
Для Каждого СтрокаТЧ Из ТаблицаТЧ Цикл
    ОбластьСоставБСО = Макет.ПолучитьОбласть("ОбластьСоставБСО");
      ОбластьСоставБСО.Параметры.Заполнить(СтрокаТЧ);
       ТабличныйДок.Вывести(ОбластьСоставБСО);
 КонецЦикла;
Либо одна последняя
Для Каждого СтрокаТЧ Из ТаблицаТЧ Цикл
      ОбластьСоставБСО.Параметры.Заполнить(СтрокаТЧ);
 КонецЦикла;     
       ТабличныйДок.Вывести(ОбластьСоставБСО);
Мне хотелось бы что бы выводил строку в соотвествии с номером строки,


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
62 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
27 Сообщений
KATERINA 861
23 Сообщений
neek666
22 Сообщений
SSC
15 Сообщений
alexandr_ll
15 Сообщений
Алексей_1985_06
11 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 171
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск