Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 11:32

Помогите пожалуйста, ТЧ Документа вывести во внешнюю печатную форму,выводить выводит но множит по строкам

Автор Комарова Ольга, 05 ноя 2016, 12:47

0 Пользователей и 1 гость просматривают эту тему.

Комарова Ольга

 Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
               |   БСО_Поступление.СоставБСО.(
               |      Ссылка,
               |      НомерСтроки,
               |      БСО,
               |      СерияБСО,
               |      НомерНачальный,
               |      НомерКонечный,
               |      Количество,
               |      Маска
               |   ) КАК Материалы
               |ИЗ
               |   Документ.БСО_Поступление КАК БСО_Поступление
               |ГДЕ
               |   БСО_Поступление.Ссылка = &Ссылка";
Запрос.УстановитьПараметр("Ссылка",СсылкаНаОбъект);
Запрос.УстановитьПараметр("ТекущаяДата",ТекущаяДата());

Выборка = Запрос.Выполнить().Выбрать();
//Выборка.Следующий();
Пока Выборка.Следующий() Цикл
ТаблицаТЧ = Выборка.Материалы.Выгрузить();

Для Каждого СтрокаТЧ Из ТаблицаТЧ Цикл
      ОбластьСоставБСО.Параметры.Заполнить(СтрокаТЧ);
КонецЦикла;      
       ТабличныйДок.Вывести(ОбластьСоставБСО);
      
   
КонецЦикла;

cska-fanat-kz

по этому фрагменту мало понятно как остальная таблица формируется...
по идее должно быть не...
Для Каждого СтрокаТЧ Из ТаблицаТЧ Цикл
      ОбластьСоставБСО.Параметры.Заполнить(СтрокаТЧ);
КонецЦикла;     
       ТабличныйДок.Вывести(ОбластьСоставБСО);

а

Для Каждого СтрокаТЧ Из ТаблицаТЧ Цикл
    ОбластьСоставБСО = Макет.ПолучитьОбласть("ОбластьСоставБСО");
      ОбластьСоставБСО.Параметры.Заполнить(СтрокаТЧ);
       ТабличныйДок.Вывести(ОбластьСоставБСО);
КонецЦикла;     

а то у вас из всех строк выводится только одна - последняя...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Комарова Ольга

Извините,что запутала
Да,вы правы, у меня два варианта формирования, либо формируються все строчки из табличной части
Для Каждого СтрокаТЧ Из ТаблицаТЧ Цикл
    ОбластьСоставБСО = Макет.ПолучитьОбласть("ОбластьСоставБСО");
      ОбластьСоставБСО.Параметры.Заполнить(СтрокаТЧ);
       ТабличныйДок.Вывести(ОбластьСоставБСО);
КонецЦикла;
Либо одна последняя
Для Каждого СтрокаТЧ Из ТаблицаТЧ Цикл
      ОбластьСоставБСО.Параметры.Заполнить(СтрокаТЧ);
КонецЦикла;     
       ТабличныйДок.Вывести(ОбластьСоставБСО);
Мне хотелось бы что бы выводил строку в соотвествии с номером строки,

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск