Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2021, 16:34
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Перенести реквизит ТЧ источника в реквизит приемника.  (Прочитано 1842 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн VladimirMelnychenko

  • *
  • Регистрация: 2016-08-29
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Профессия: Программист 1С
Добрый день.

Прошу помочь с решением одной проблемы.
Необходимо перенести платежные поручения (входящие/исходящие) из базы БУ в УНФ. Столкнулся с одной проблемой, в базе УНФ есть реквизит "СтатьяДДС" и в БУ есть данный реквизит, но вот проблема в том что в БУ данный реквизит ("СтатьяДДС") присутствует еще и в табличной части "Расшифровка платежа", а в УНФ он один на весь документ. Нужно заполнить реквизит УНФ значением данного реквизита в первой строке табличной части "Расшифровка платежа".
Написал в модуле ПКО при выгрузке (код ниже), выдает ошибку "Значение не является значением объектного типа (Статья)", скажите пожалуйста как можно решить данную проблему?

Если Источник.СтатьяДвиженияДенежныхСредств.Пустая() = Истина Тогда
   
    Приемник.Статья = Источник.РасшифровкаПлатежа[0].СтатьяДвиженияДенежныхСредств;
   
КонецЕсли;


Оффлайн alexandr_ll

  • *****
  • Регистрация: 2016-08-23
  • Сообщений: 1529
  • РЕПУТАЦИЯ: 223
  • КПД: 15%
  • Профессия: Программист 1С

Оффлайн VladimirMelnychenko

  • *
  • Регистрация: 2016-08-29
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Профессия: Программист 1С
Приемник: ДокументСсылка.ПоступлениеНаСчет
Добавлено: 04 Ноя 2016, 17:26

Если Источник.СтатьяДвиженияДенежныхСредств.Пустая() Тогда
   
    Значение = Источник.РасшифровкаПлатежа[0].СтатьяДвиженияДенежныхСредств;
   
КонецЕсли;

Так работает.

Последний раз редактировалось: VladimirMelnychenko; 04 Ноя 2016, 17:26. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • *****
  • Регистрация: 2010-11-06
  • Сообщений: 5748
  • РЕПУТАЦИЯ: 1105
  • КПД: 19%
  • Красная армия всех сильней!
    • Skype: cska-fanat-kz81
  • Профессия: Разработчик 1С
Если Источник.СтатьяДвиженияДенежныхСредств.Пустая() Тогда
   
    Если Источник.РасшифровкаПлатежа.Количество() > 0 Тогда
        Значение = Источник.РасшифровкаПлатежа[0].СтатьяДвиженияДенежныхСредств;
    КонецЕсли;
   
Иначе

    Значение = Источник.СтатьяДвиженияДенежныхСредств;

КонецЕсли;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Алгоритм загрузки изображений из excel по ссылке URL в реквизит основное изображение

Автор nikioioioРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1803
Последний ответ 23 Мар 2016, 05:43
от nikioioio
1С 8.3 - Как присвоить стандартному реквизиту "Наименование" одного справочника, ссылку на реквизит другого справочника?

Автор АлирзаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 3812
Последний ответ 27 Мая 2021, 15:12
от antoneus
Как выгрузить реквизит документа в XML файл

Автор ЕвгенийЗерноРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1144
Последний ответ 13 Июл 2018, 16:18
от ЕвгенийЗерно
Периодический реквизит справочника

Автор EvgenOrelРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 12470
Последний ответ 21 Фев 2013, 20:12
от sadovod
вес, новый реквизит затирается при записи

Автор margoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 118
Последний ответ 11 Ноя 2020, 10:27
от margo

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
LexaK
68 Сообщений
antoneus antoneus
33 Сообщений
Ивашка
27 Сообщений
neek666
26 Сообщений
KATERINA 861
19 Сообщений
SSC
15 Сообщений
Алексей_1985_06
15 Сообщений
alexandr_ll
14 Сообщений
BuhRust
8 Сообщений

* Кто онлайн

  • Точка Гостей: 569
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск