Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 июн 2021, 12:44

Поправки в чек ККМ

Автор Sheriff, 04 ноя 2016, 13:15

0 Пользователей и 1 гость просматривают эту тему.

Sheriff

Всем привет!
Есть конфигурация Управление Торговлей 10. Есть внешняя обработка для Фискального регистратора. И всё работает отлично, но, захотелось добавить данные по дисконтным картам и тут возникли проблемы.
В модуле этой обработки, есть такие строки:
Функция ЗакрытьЧек(Объект, СуммаНал, СуммаБезнал) Экспорт

   Результат = мНетОшибки;

   Если Не мЧекОткрыт Тогда
      Объект.ОписаниеОшибки = "Чек не был открыт";
      Результат = мОшибкаНеизвестно;
   Иначе
      Если мФискальныйЧек Тогда
         Макет = ПолучитьМакет("Макет");
         ОбластьЛиния1 = Макет.ПолучитьОбласть("Линия1");
         ОбластьИтого = Макет.ПолучитьОбласть("Итого");
         ОбластьСтрока2 = Макет.ПолучитьОбласть("Строка2");
         
         //ОбластьДК = Макет.ПолучитьОбласть("ДК");
         
         мТабДок.Вывести(ОбластьЛиния1);
         
         ОбластьИтого.Параметры.Сумма = мИтогЧека;
         мТабДок.Вывести(ОбластьИтого);
         
         if СуммаНал > мИтогЧека then
            ОбластьСтрока2.Параметры.Текст = "СДАЧА";
            ОбластьСтрока2.Параметры.Сумма = СуммаНал - мИтогЧека;
            мТабДок.Вывести(ОбластьСтрока2);
         endif;
         
         //Если значениезаполнено(док) Тогда
         //   Если значениезаполнено(док.дисконтнаяКарта) Тогда
         //      мТабДок.Вывести(ОбластьЛиния1);
         //      ОбластьДК.Параметры.КодКарты = Док.ДисконтнаяКарта.КодКарты;
         //      ОбластьДК.Параметры.СуммаНакоплений = ДисконтныеКарты.ПолучитьСуммуНакоплений(Док.ДисконтнаяКарта);
         //      мТабДок.Вывести(ОбластьДК);
         //   КонецЕсли;
         //КонецЕсли;

         
         ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
            мТабДок.Вывести(ОбластьПодвал);

         
         НапечататьДокумент();
      КонецЕсли;
      мЧекОткрыт = Ложь;
   КонецЕсли;

   Возврат Результат;

КонецФункции // ЗакрытьЧек()

Я удалил комментарий, но выходит ошибка, что переменная "док" не найдена.
Что нужно исправить, чтобы у меня в чеке выходил код карты клиента?
Кроме как в этом модуле и функции закрыть чек, слово КодКарты нигде не встречается.

Теги:
Рейтинг@Mail.ru Rambler's Top100

Поиск