Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
17 сен 2021, 15:49

Запрос с условием

Автор Игорь123, 01 ноя 2016, 17:23

0 Пользователей и 1 гость просматривают эту тему.

Игорь123

Помогите пожалуйста, на форме есть реквизит где надо выбрать номенклатуру и кнопка при нажатии на которую будет выводиться текущая цена выбранной номенклатуры.

&НаКлиенте
Процедура ВывестиСообщение(Команда)
ОчиститьСообщения() ;
С();
КонецПроцедуры

&НаСервере
Процедура С()
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|      ЦеныНоменклатурыСрезПоследних.Номенклатура КАК Номенклатура,
|      ЦеныНоменклатурыСрезПоследних.Цена КАК Цена
|ИЗ
|      РегистрСведений.ЦеныНоменклатуры.СрезПоследних КАК ЦеныНоменклатурыСрезПоследних";
Выборка=Запрос.Выполнить().Выбрать();
      Если ЗначениеЗаполнено(Объект.Номенклатура) 
Тогда
Пока Выборка.Следующий() цикл      Сообщить("Текущая цена номенклатуры " + Выборка.Номенклатура + " = " + Выборка.Цена + " р.");
КонецЦикла;
иначе
Сообщить("Выберите номенклатуру");
КонецЕсли;
КонецПроцедуры

Kironten

Ну нет отборов по регистру.
А в чем вопрос то, мы сами должны догадаться?

Игорь123

Вопрос в том что надо чтобы сообщалась цена выбранной в реквизите номенклатуры.

Андрей Сисюкин

тут есть 2 момента.
1. нужно сделать отбор в запросе, что бы была выборка только по одной номенклатуре.
2. Выводить сообщения нужно всё-таки на клиенте, а не на сервере.  т.е. возвращай цену с сервера на клиент и там уже сообщай.

Ну, на крайний случай делай:
Сооб = Новый СообщениеПользователю;
Сооб.Текст = "бла-бла-бла";
Сообщ.Сообщить();

Просто вот это: Сообщить() - ну никак не работает на сервере.


LexaK


Андрей Сисюкин,
ЦитироватьПросто вот это: Сообщить() - ну никак не работает на сервере.

э-э-э, а у Андрей Сисюкин, вас какая платформа?

уже давно так

Глобальный контекст (Global context)
Сообщить (Message)
Синтаксис:

Сообщить(<ТекстСообщения>, <Статус>)
Параметры:

<ТекстСообщения> (обязательный)

Тип: Строка.
Текст сообщения.
<Статус> (необязательный)

Тип: СтатусСообщения.
Статус сообщения. Определяет вид пиктограммы.
В режиме управляемого приложения параметр игнорируется.
Значение по умолчанию: Обычное.
Описание:

Выводит текст сообщения в окно сообщений. Если в момент вызова окно сообщений отсутствует, то будет открыто новое окно сообщений. Сообщение, в зависимости от его смысловой нагрузки, можно пометить одной из пиктограмм, входящих в предопределенный набор.

Доступность:
Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение(клиент), мобильное приложение(сервер).

ДОСТУПНОСТЬ - СЕРВЕР !!!  :befhbt:
ответ Понравился? (в смысле пригодился?)

ilyay

Цитата: LexaK от 02 ноя 2016, 09:49
уже давно так

Глобальный контекст (Global context)
Сообщить (Message)

Уже давно вместо Сообщить() надо использовать объект СообщениеПользователю.

LexaK

ilyay,
ЦитироватьУже давно вместо Сообщить() надо использовать объект СообщениеПользователю.

предыдущий автор пытался ввести всех в заблуждение что:
ЦитироватьПросто вот это: Сообщить() - ну никак не работает на сервере.

о чем я и поправил.
а уж что использовать: Сообщить() или СообщениеПользователю() кому как нравится.
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск