Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 04:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Есть Справочник. В нем есть группа. Как в этой группе создать еще группу?  (Прочитано 2568 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн СсылкаНаОбъект

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-09
  • Сайт: 
  • Профессия: Программист 8.1
Вот мой код:

Процедура ЭКСЕЛЬ() Экспорт
Перем КодТовара;
Перем НаименованиеТовара;
xlLastCell=11;
Эксель = ПолучитьCOMОбъект("", "Excel.Application");
Книга = Эксель.WorkBooks.Open("C:\Users\А-Систем\Documents\NS11-01-27.xls");
Лист = Книга.WorkSheets(1);
ActiveCell = Эксель.ActiveCell.SpecialCells(xlLastCell);
RowCount = ActiveCell.Row;
ColumnCount = ActiveCell.Column;

Нули = "";

Для Строка = 1 ПО 200 Цикл  //RowCount
   Если Строка = 14 Тогда Продолжить; КонецЕсли;
   //
   Товар = Справочники.Номенклатура.СоздатьЭлемент();
   //
   КодТовара = СокрЛП(Лист.Cells(Строка,2).Value);
   НаименованиеТовара = СокрЛП(Лист.Cells(Строка,3).Value);
   Проверка = СокрЛП(Лист.Cells(Строка,4).Value);            //доп. поле
   Проверка2 = СокрЛП(Лист.Cells(Строка,8).Value);           //доп. поле
   //
   Если СтрДлина(НаименованиеТовара) <> 0 И КодТовара = "" И Проверка = "" И Проверка2 = "" Тогда
      НовГр = Справочники.Номенклатура.СоздатьГруппу();
      НовГр.Наименование = НаименованиеТовара;                   //создание группы в справочнике
      НовГр.Записать();   
      СсылкаНаНовГр = НовГр.Ссылка;
      //Сообщить("Создана новая группа.");
      Продолжить;
   КонецЕсли;
   //
   Если Проверка = "" Тогда
      //Сообщить("Это не товар.");                            //проверка на пустоту поля
      Проверка = "";
      Продолжить;
   КонецЕсли;
   //
   Если Проверка2 = "" Тогда
      //Сообщить("Это не товар.");                            //проверка на пустоту поля
      Проверка = "";
      Продолжить;
   КонецЕсли;
   
   ДлинаКода = СтрДлина(КодТовара);
   Если ДлинаКода < 11 Тогда
      Для А = 1 ПО 11-ДлинаКода Цикл      
         Нули = Нули + "0";
      КонецЦикла;   
   КодТовара = Формат(Нули + КодТовара, "ЧГ=0");
   Нули = "";
   КонецЕсли;   
   //
   Спр = Справочники.Номенклатура.НайтиПоКоду(КодТовара);
   Если Спр.Пустая() = Ложь Тогда
      Сообщить(КодТовара + " " + НаименованиеТовара + ". Такой товар уже есть.");
      Спр = "";
      Продолжить;
   КонецЕсли;
   //
   Спр2 = Справочники.НоменклатурныеГруппы.НайтиПоКоду(КодТовара);
   Если Спр2.Пустая() = Ложь Тогда
      Сообщить(КодТовара + " " + НаименованиеТовара + ". У группы такой же код. Товар не будет добавлен.");
      Спр2 = "";
      Продолжить;
   КонецЕсли;
   //
   Спр3 = Справочники.Номенклатура.НайтиПоНаименованию(НаименованиеТовара);
   Если Спр3.Пустая() = Ложь Тогда
      Сообщить(КодТовара + " " + НаименованиеТовара + ". Такой товар уже есть.");
      Спр3 = "";
      Продолжить;
   КонецЕсли;
   //
   Товар.Родитель = СсылкаНаНовГр;
   Товар.Код = Формат(КодТовара, "ЧГ=0");
   Товар.Наименование = НаименованиеТовара;
   Товар.БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду("796");
   Товар.Записать();
   //Сообщить("Товар добавлен.")

КонецЦикла;   
//Сообщить(RowCount);
Эксель.Application.Quit();
Эксель=0;
КонецПроцедуры


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
у группы есть тот же самый реквизит Родитель что и у элемента.

Добавление Группы2 в Группу1:
Группа2.Родитель = Группа1;

И стоило ради этого всю эту "портянку" приводить? ;)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Создать com соединение [com соединение]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 479
Последний ответ 30 Май 2017, 16:52
от MuI_I_Ika
справочник "Главы по БК"

Автор IaterРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3945
Последний ответ 21 Май 2015, 13:56
от pavl_vs
ЗУП 3.0 справочник "Должности"

Автор denis_ivanovРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1450
Последний ответ 08 Апр 2016, 21:19
от denis_ivanov
Справочник "Ресурсные спецификации"

Автор MroРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 688
Последний ответ 17 Авг 2016, 16:13
от SGIRG
Справочник "Сотрудники" можно просматривать

Автор Alex56Раздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 3328
Последний ответ 03 Фев 2014, 11:50
от Alex56

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 169
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal