Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 июн 2021, 11:08

Полное наименование типа в 1С 8.2

Автор danish, 27 окт 2016, 11:34

0 Пользователей и 1 гость просматривают эту тему.

danish

Иногда возникает необходимость получить тип объекта в 1С 8.2 полностью, в виде "Справочник.<Вид>" или "Документ.<Вид>". Для этого существует метод объекта "Метаданные" НайтиПоТипу(Тип). Пример:

Для Каждого План из Метаданные.ПланыСчетов Цикл
ИмяПланаСчетов = План.Имя;
Сообщить("План счетов: "+ ИмяПланаСчетов);
Выборка = ПланыСчетов[ИмяПланаСчетов].Выбрать();
Пока Выборка.Следующий()Цикл
ИмяСчета = Выборка.Наименование;
КодСчета = Выборка.Код;
Сообщить("Счет № "+КодСчета+", "+ИмяСчета);
Для Каждого Субконто из Выборка.ВидыСубконто Цикл
ВидСубконто = Субконто.ВидСубконто;
Сообщить("Субконто: вид - "+ВидСубконто);
Для Каждого Тип из ВидСубконто.ТипЗначения.Типы() Цикл
ПолныйТип = Метаданные.НайтиПоТипу(Тип);
Сообщить("Тип: "+ПолныйТип.ПолноеИмя());
КонецЦикла;
КонецЦикла;
КонецЦикла;
КонецЦикла;


Или:
Для Каждого Рекв из Метаданные.Документы[ИмяДокумента].Реквизиты Цикл
Для Каждого Тип из Рекв.Тип.Типы() Цикл
Объект = Метаданные.НайтиПоТипу(Тип);
Если Объект <> Неопределено Тогда
Сообщить("Реквизит: "+Рекв.Имя+", тип: "+Объект.ПолноеИмя());
КонецЕсли;
КонецЦикла;
        КонецЦикла;

Рейтинг@Mail.ru Rambler's Top100

Поиск