Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 12:38

Перенести значение с клиента на сервер

Автор Vasya Povar, 24 окт 2016, 17:40

0 Пользователей и 1 гость просматривают эту тему.

Vasya Povar

&НаКлиенте
Процедура НалоговыйДокументПриИзменении(Элемент)
ПараметрыФормы = Новый Структура("Ключ", ПолучитьОрганизацию(Объект.НалоговыйДокумент));
ФормаПодчиненногоОбъекта = ПолучитьФорму("Справочник.Организации.Форма.ФормаОрганизации", ПараметрыФормы);
АдрессОрганизации =ФормаПодчиненногоОбъекта.ЮрАдресОрганизации;

//Уникальный = Новый УникальныйИдентификатор();
//Адресс  = ПоместитьВоВременноеХранилище(АдрессОрганизации);
НалоговыйДокументПриИзмененииНаСервере();
КонецПроцедуры
&НаСервереБезКонтекста
Функция ПолучитьОрганизацию(Док)
    Возврат Док.Организация;
КонецФункции



Нужно на сервере получить значение АдрессОрганизации . Пробовал помещать во временное хранилище, но ошибка переменная не определина (Адресс)

cast

&НаКлиенте
Процедура КонтрагентПриИзменении(Элемент)
   Отбор =Новый Структура("Ключ", Объект.Контрагент);   
   Форма=ПолучитьФорму("Справочник.Контрагенты.Форма.ФормаЭлемента", Отбор);
   Объект.Менеджер = Форма.Объект.Менеджер;
КонецПроцедуры
Это без сервера, своё поставь

Vasya Povar

Цитата: cast от 24 окт 2016, 17:44
&НаКлиенте
Процедура КонтрагентПриИзменении(Элемент)
   Отбор =Новый Структура("Ключ", Объект.Контрагент);   
   Форма=ПолучитьФорму("Справочник.Контрагенты.Форма.ФормаЭлемента", Отбор);
   Объект.Менеджер = Форма.Объект.Менеджер;
КонецПроцедуры
Это без сервера, своё поставь

Да у меня там все верно работает. Мне дальше необходимо получить значение переменной АдрессОрганизации только уже на сервере!

ilyay

Или сделайте реквизит с таким именем или передавайте параметр в вызываемую серверную процедуру. Но в вашем случае лучше пойти первым путем :-)

Vasya Povar

Спасибо, проблему решил первым способом)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск