Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
08 Дек 2016, 03:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1С 8.2: Удаление настроек печати пользователя  (Прочитано 217 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AIFrame

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 6
  • КПД: 7%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Ученик 1С
Суть проблемы:
Если НЕ ТабДокумент.ПроверитьВывод(МассивВыводимыхОбластей) Тогда
Выполнение этой строки приводит к ошибке, т.к. сохраненные настройки печати ссылаются на удаленный или недоступный для пользователя принтер.
Ситуация возникла при изменении (замене) принтера, на который печатает пользователь.
В нашем случае перестали выводится все формы Торг12, для которых в ТабЧасть подгружалась настройка "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_ТОРГ12"

Решение простое:

Процедура КнопкаВыполнитьНажатие(Кнопка)
Если НЕ ЗначениеЗаполнено(Пользователь) Тогда
Предупреждение("Ошибка! Не выбран пользователь!");
КонецЕсли;
Если НЕ ЗначениеЗаполнено(ИмяПараметров) Тогда
Предупреждение("Ошибка! Не заполнены параметры печати!");
КонецЕсли;

КлючОбъекта = "Общее/НастройкиПечатиТабличногоДокумента/ПАРАМЕТРЫ_ПЕЧАТИ_"+ИмяПараметров;
ИмяПользователя = Пользователь.Код;
ХранилищеСистемныхНастроек.удалить(КлючОбъекта,,ИмяПользователя);
Предупреждение("ОК");
КонецПроцедуры

Процедура ПриОткрытии()
ИмяПараметров = "РеализацияТоваровУслуг_ТОРГ12";
Пользователь = ПараметрыСеанса.ТекущийПользователь;
КонецПроцедуры


Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6032
  • РЕПУТАЦИЯ: 707
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Обработки - это раздел для готовых разработок, переношу в конфигурирование

Оффлайн AIFrame

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 6
  • КПД: 7%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Ученик 1С
Обработки - это раздел для готовых разработок, переношу в конфигурирование
Этого как бы готовое решение этой проблемы
Оно работает.


Теги:
 

Удаление помеченных объектов ("Не удалось записать "Контактная информация"")

Автор SnakeyРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 5017
Последний ответ 08 Янв 2015, 09:15
от Sanario
Удаление папки "Темп"

Автор TATIZРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 968
Последний ответ 11 Мар 2015, 13:45
от дфтын
Отсутствие документов помеченных на удаление в обработке удаления помеченных

Автор ak47Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2075
Последний ответ 06 Июн 2013, 11:47
от Совёнок
Не могу найти "Удаление помеченных объектов"

Автор LeviathanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 1918
Последний ответ 14 Янв 2016, 06:03
от cska-fanat-kz
Синтаксическая ошибка "ИЗ" <<?>>ИЗ при печати счета ут 10.3

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3015
Последний ответ 02 Дек 2013, 14:42
от romanprogrammist

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
80 Сообщений
cska-fanat-kz cska-fanat-kz
68 Сообщений
Kironten
47 Сообщений
alex0402
46 Сообщений
LexaK
34 Сообщений
alexandr_ll
34 Сообщений
djkeysi
24 Сообщений
Андрей1966
24 Сообщений
sertak sertak
23 Сообщений
BuhRust
22 Сообщений

* Кто онлайн

  • Точка Гостей: 159
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal