Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Июн 2017, 18:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1С 8.2: Удаление настроек печати пользователя  (Прочитано 732 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AIFrame

  • ***
  • Сообщений: 112
  • РЕПУТАЦИЯ: 7
  • КПД: 6%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Ученик 1С
Суть проблемы:
Если НЕ ТабДокумент.ПроверитьВывод(МассивВыводимыхОбластей) Тогда
Выполнение этой строки приводит к ошибке, т.к. сохраненные настройки печати ссылаются на удаленный или недоступный для пользователя принтер.
Ситуация возникла при изменении (замене) принтера, на который печатает пользователь.
В нашем случае перестали выводится все формы Торг12, для которых в ТабЧасть подгружалась настройка "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_ТОРГ12"

Решение простое:

Процедура КнопкаВыполнитьНажатие(Кнопка)
Если НЕ ЗначениеЗаполнено(Пользователь) Тогда
Предупреждение("Ошибка! Не выбран пользователь!");
КонецЕсли;
Если НЕ ЗначениеЗаполнено(ИмяПараметров) Тогда
Предупреждение("Ошибка! Не заполнены параметры печати!");
КонецЕсли;

КлючОбъекта = "Общее/НастройкиПечатиТабличногоДокумента/ПАРАМЕТРЫ_ПЕЧАТИ_"+ИмяПараметров;
ИмяПользователя = Пользователь.Код;
ХранилищеСистемныхНастроек.удалить(КлючОбъекта,,ИмяПользователя);
Предупреждение("ОК");
КонецПроцедуры

Процедура ПриОткрытии()
ИмяПараметров = "РеализацияТоваровУслуг_ТОРГ12";
Пользователь = ПараметрыСеанса.ТекущийПользователь;
КонецПроцедуры



Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6359
  • РЕПУТАЦИЯ: 750
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Обработки - это раздел для готовых разработок, переношу в конфигурирование

Оффлайн AIFrame

  • ***
  • Сообщений: 112
  • РЕПУТАЦИЯ: 7
  • КПД: 6%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Ученик 1С
Обработки - это раздел для готовых разработок, переношу в конфигурирование
Этого как бы готовое решение этой проблемы
Оно работает.


Теги:
 

Удаление помеченных объектов ("Не удалось записать "Контактная информация"")

Автор SnakeyРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 6038
Последний ответ 08 Янв 2015, 09:15
от Sanario
Удаление папки "Темп"

Автор TATIZРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1395
Последний ответ 11 Мар 2015, 13:45
от дфтын
Отсутствие документов помеченных на удаление в обработке удаления помеченных

Автор ak47Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2334
Последний ответ 06 Июн 2013, 11:47
от Совёнок
Не могу найти "Удаление помеченных объектов"

Автор LeviathanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 3850
Последний ответ 14 Янв 2016, 06:03
от cska-fanat-kz
Синтаксическая ошибка "ИЗ" <<?>>ИЗ при печати счета ут 10.3

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3514
Последний ответ 02 Дек 2013, 14:42
от romanprogrammist

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
124 Сообщений
alex0402
117 Сообщений
oleg-x
114 Сообщений
дфтын дфтын
80 Сообщений
wise wise
58 Сообщений
MuI_I_Ika MuI_I_Ika
43 Сообщений
Dethmontt Dethmontt
33 Сообщений
magnifico61
30 Сообщений
ilyay ilyay
29 Сообщений
Амал
28 Сообщений

* Кто онлайн

  • Точка Гостей: 455
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal