Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Фев 2017, 16:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1С 8.2: Удаление настроек печати пользователя  (Прочитано 377 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AIFrame

  • ***
  • Сообщений: 101
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Ученик 1С
Суть проблемы:
Если НЕ ТабДокумент.ПроверитьВывод(МассивВыводимыхОбластей) Тогда
Выполнение этой строки приводит к ошибке, т.к. сохраненные настройки печати ссылаются на удаленный или недоступный для пользователя принтер.
Ситуация возникла при изменении (замене) принтера, на который печатает пользователь.
В нашем случае перестали выводится все формы Торг12, для которых в ТабЧасть подгружалась настройка "ПАРАМЕТРЫ_ПЕЧАТИ_РеализацияТоваровУслуг_ТОРГ12"

Решение простое:

Процедура КнопкаВыполнитьНажатие(Кнопка)
Если НЕ ЗначениеЗаполнено(Пользователь) Тогда
Предупреждение("Ошибка! Не выбран пользователь!");
КонецЕсли;
Если НЕ ЗначениеЗаполнено(ИмяПараметров) Тогда
Предупреждение("Ошибка! Не заполнены параметры печати!");
КонецЕсли;

КлючОбъекта = "Общее/НастройкиПечатиТабличногоДокумента/ПАРАМЕТРЫ_ПЕЧАТИ_"+ИмяПараметров;
ИмяПользователя = Пользователь.Код;
ХранилищеСистемныхНастроек.удалить(КлючОбъекта,,ИмяПользователя);
Предупреждение("ОК");
КонецПроцедуры

Процедура ПриОткрытии()
ИмяПараметров = "РеализацияТоваровУслуг_ТОРГ12";
Пользователь = ПараметрыСеанса.ТекущийПользователь;
КонецПроцедуры


Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6181
  • РЕПУТАЦИЯ: 722
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Обработки - это раздел для готовых разработок, переношу в конфигурирование

Оффлайн AIFrame

  • ***
  • Сообщений: 101
  • РЕПУТАЦИЯ: 7
  • КПД: 7%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Ученик 1С
Обработки - это раздел для готовых разработок, переношу в конфигурирование
Этого как бы готовое решение этой проблемы
Оно работает.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
MuI_I_Ika MuI_I_Ika
83 Сообщений
alex0402
72 Сообщений
LexaK
44 Сообщений
Kironten
32 Сообщений
BuhRust
20 Сообщений
TytovV
20 Сообщений
depb
18 Сообщений
Tyts
17 Сообщений
pavl_vs
17 Сообщений

* Кто онлайн

  • Точка Гостей: 318
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal