Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
08 Дек 2016, 03:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: вывести макет в управляемую форму  (Прочитано 333 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alexshape

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-10-02
  • Сайт: 
  • Профессия: Программист 1С
подскажите в чем моя ошибка? хочу вывести в поле ТабДок типа табличный документ, макет того же отчета С готовой "шапкой"



Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 40
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Функция Воз(Область)
Что возвращает?
Ответ: НИЧЕГО.
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн alexshape

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-10-02
  • Сайт: 
  • Профессия: Программист 1С
Исправил, но почему он мне возвращает Строку Табличный документ, а не саму область?

&НаКлиенте
Процедура Сформировать(Команда)
 
ЭтаФорма.Элементы.ТабДок.ТекущаяОбласть.Текст = продажиОтчет.Воз();
КонецПроцедуры


&НаСервере
Функция Воз() Экспорт
МакетОТЧ = Отчеты.Продажи.ПолучитьМакет("Макет");
//ФормаОТЧ = Отчеты.Продажи.ПолучитьФорму("Отчет.Продажи.Форма.ФормаОтчета");
 Область = МакетОТЧ.ПолучитьОбласть("Шапка");
Возврат Область;
КонецФункции
 

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ***
  • Сообщений: 173
  • РЕПУТАЦИЯ: 24
  • КПД: 14%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Должно было быть, наверное, так:
    Об = РеквизитФормыВЗначение("Отчет");
    МакетОТЧ = Об.ПолучитьМакет("Макет");
    Возврат МакетОТЧ.ПолучитьОбласть(Область);

Оффлайн alexshape

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-10-02
  • Сайт: 
  • Профессия: Программист 1С
Должно было быть, наверное, так:
    Об = РеквизитФормыВЗначение("Отчет");
    МакетОТЧ = Об.ПолучитьМакет("Макет");
    Возврат МакетОТЧ.ПолучитьОбласть(Область);

Ругается {ОбщийМодуль.продажиОтчет.Модуль(20,38)}: Переменная не определена (Область)
    Возврат МакетОТЧ.ПолучитьОбласть(<<?>>Область); (Проверка: Сервер)
{ОбщийМодуль.продажиОтчет.Модуль(18,7)}: Процедура или функция с указанным именем не определена (РеквизитФормыВЗначение)
   Об = <<?>>РеквизитФормыВЗначение("Отчет"); (Проверка: Сервер)

Добавлено: 18 Окт 2016, 11:33

Немного разобрался но одно все равно не решается:


Получаю макет в виде табличного документа на сервере
&НаСервере
Функция Воз() Экспорт
МакетОТЧ = Отчеты.Продажи.ПолучитьМакет("Макет");
//ФормаОТЧ = Отчеты.Продажи.ПолучитьФорму("Отчет.Продажи.Форма.ФормаОтчета");
Возврат (МакетОТЧ);
КонецФункции

потом на клиенте Выделяю областьТабШапка (в отладчике все норм в области ТабШапка есть данные
А вот при передаче в ЭтаФорма.Элементы.ТабДок.ТекущаяОбласть передается пустая таблица

&НаКлиенте
Процедура Сформировать(Команда)

таб = продажиОтчет.Воз();
ТАбШапка = таб.Области.Шапка;
ЭтаФорма.Элементы.ТабДок.ТекущаяОбласть = ТАбШапка;
КонецПроцедуры

Последний раз редактировалось: alexshape; 18 Окт 2016, 11:33. Причина: Объединение сообщений

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ***
  • Сообщений: 173
  • РЕПУТАЦИЯ: 24
  • КПД: 14%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Ваши действия:
1. Получаете макет на сервере
МакетОТЧ = Отчеты.Продажи.ПолучитьМакет("Макет");
2. На сервере получаете область шапки
ТабДокШапка = МакетОТЧ.ПолучитьОбласть("Шапка");
3. Выводите результат в ваш табличный документ (можно на клиенте):
Способ 1:
ТабДок = ТабДокШапка;
Способ 2:
ТабДок = Новый ТабличныйДокумент; // если возможен повторный вывод в реквизит, надо его чистить, иначе не надо
ТабДок.Вывести(ТабДокШапка);

Оффлайн alexshape

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-10-02
  • Сайт: 
  • Профессия: Программист 1С
ТабДок.Вывести(ТабДокШапка);

говорит что на клиенте нельзя выполнять только на сервере, а вообще можно ли просто взять и вставить одну таблицу в другую, или нужно через цикл перебирать каждое значения?

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ***
  • Сообщений: 173
  • РЕПУТАЦИЯ: 24
  • КПД: 14%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Нет такого метода, видимо потому что для областей строк колонки могут задаваться по разному.


Теги:
 

Передача параметров из ячейки поля табличного документа в форму создания нового документа 1с 8.3

Автор Анна БахановичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 1304
Последний ответ 18 Фев 2016, 12:50
от Анна Баханович
Как программно открыть форму и закрыть с записью, чтобы отработал метод перед записью

Автор con2rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 778
Последний ответ 06 Июн 2016, 11:54
от vitasw
Функция "Изменить Форму" Сохранения данных пользователя

Автор NILРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 323
Последний ответ 05 Авг 2016, 08:31
от NIL
Как добавить вывод ДоговораКонтрагента в печатную форму "Счет на оплату"

Автор ValentusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 9761
Последний ответ 09 Июн 2010, 15:25
от Karamelkina
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1700
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
80 Сообщений
cska-fanat-kz cska-fanat-kz
68 Сообщений
Kironten
47 Сообщений
alex0402
46 Сообщений
LexaK
34 Сообщений
alexandr_ll
34 Сообщений
djkeysi
24 Сообщений
Андрей1966
24 Сообщений
sertak sertak
23 Сообщений
BuhRust
22 Сообщений

* Кто онлайн

  • Точка Гостей: 160
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal