Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Сен 2017, 17:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: вывести макет в управляемую форму  (Прочитано 1216 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alexshape

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-10-02
  • Сайт: 
  • Профессия: Программист 1С
подскажите в чем моя ошибка? хочу вывести в поле ТабДок типа табличный документ, макет того же отчета С готовой "шапкой"



Оффлайн Luzer1C

  • ****
  • Сообщений: 411
  • РЕПУТАЦИЯ: 41
  • КПД: 10%
  • Регистрация: 2014-02-17
  • Сайт: 
  • Профессия: Программист 1С
Функция Воз(Область)
Что возвращает?
Ответ: НИЧЕГО.
Помочь мне очень сложно. Но можно.
Помогаю просто так...
Матёрый разработчик УПП + Бит Финанс

Оффлайн alexshape

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-10-02
  • Сайт: 
  • Профессия: Программист 1С
Исправил, но почему он мне возвращает Строку Табличный документ, а не саму область?

&НаКлиенте
Процедура Сформировать(Команда)
 
ЭтаФорма.Элементы.ТабДок.ТекущаяОбласть.Текст = продажиОтчет.Воз();
КонецПроцедуры


&НаСервере
Функция Воз() Экспорт
МакетОТЧ = Отчеты.Продажи.ПолучитьМакет("Макет");
//ФормаОТЧ = Отчеты.Продажи.ПолучитьФорму("Отчет.Продажи.Форма.ФормаОтчета");
 Область = МакетОТЧ.ПолучитьОбласть("Шапка");
Возврат Область;
КонецФункции
 

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ****
  • Сообщений: 367
  • РЕПУТАЦИЯ: 69
  • КПД: 19%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Должно было быть, наверное, так:
    Об = РеквизитФормыВЗначение("Отчет");
    МакетОТЧ = Об.ПолучитьМакет("Макет");
    Возврат МакетОТЧ.ПолучитьОбласть(Область);

Оффлайн alexshape

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-10-02
  • Сайт: 
  • Профессия: Программист 1С
Должно было быть, наверное, так:
    Об = РеквизитФормыВЗначение("Отчет");
    МакетОТЧ = Об.ПолучитьМакет("Макет");
    Возврат МакетОТЧ.ПолучитьОбласть(Область);

Ругается {ОбщийМодуль.продажиОтчет.Модуль(20,38)}: Переменная не определена (Область)
    Возврат МакетОТЧ.ПолучитьОбласть(<<?>>Область); (Проверка: Сервер)
{ОбщийМодуль.продажиОтчет.Модуль(18,7)}: Процедура или функция с указанным именем не определена (РеквизитФормыВЗначение)
   Об = <<?>>РеквизитФормыВЗначение("Отчет"); (Проверка: Сервер)

Добавлено: 18 Окт 2016, 11:33

Немного разобрался но одно все равно не решается:


Получаю макет в виде табличного документа на сервере
&НаСервере
Функция Воз() Экспорт
МакетОТЧ = Отчеты.Продажи.ПолучитьМакет("Макет");
//ФормаОТЧ = Отчеты.Продажи.ПолучитьФорму("Отчет.Продажи.Форма.ФормаОтчета");
Возврат (МакетОТЧ);
КонецФункции

потом на клиенте Выделяю областьТабШапка (в отладчике все норм в области ТабШапка есть данные
А вот при передаче в ЭтаФорма.Элементы.ТабДок.ТекущаяОбласть передается пустая таблица

&НаКлиенте
Процедура Сформировать(Команда)

таб = продажиОтчет.Воз();
ТАбШапка = таб.Области.Шапка;
ЭтаФорма.Элементы.ТабДок.ТекущаяОбласть = ТАбШапка;
КонецПроцедуры

Последний раз редактировалось: alexshape; 18 Окт 2016, 11:33. Причина: Объединение сообщений

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ****
  • Сообщений: 367
  • РЕПУТАЦИЯ: 69
  • КПД: 19%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Ваши действия:
1. Получаете макет на сервере
МакетОТЧ = Отчеты.Продажи.ПолучитьМакет("Макет");
2. На сервере получаете область шапки
ТабДокШапка = МакетОТЧ.ПолучитьОбласть("Шапка");
3. Выводите результат в ваш табличный документ (можно на клиенте):
Способ 1:
ТабДок = ТабДокШапка;
Способ 2:
ТабДок = Новый ТабличныйДокумент; // если возможен повторный вывод в реквизит, надо его чистить, иначе не надо
ТабДок.Вывести(ТабДокШапка);

Оффлайн alexshape

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-10-02
  • Сайт: 
  • Профессия: Программист 1С
ТабДок.Вывести(ТабДокШапка);

говорит что на клиенте нельзя выполнять только на сервере, а вообще можно ли просто взять и вставить одну таблицу в другую, или нужно через цикл перебирать каждое значения?

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ****
  • Сообщений: 367
  • РЕПУТАЦИЯ: 69
  • КПД: 19%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Нет такого метода, видимо потому что для областей строк колонки могут задаваться по разному.


Теги:
 

Как открыть программно открыть форму контрагента?

Автор VzonderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1033
Последний ответ 18 Янв 2017, 12:32
от sertak
Печать штрих кодов на форму печати выводятся 3 штрих кода на принтер выходит только 2.

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 383
Последний ответ 15 Май 2017, 08:59
от ZSS
Передача параметров из ячейки поля табличного документа в форму создания нового документа 1с 8.3

Автор Анна БахановичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 2681
Последний ответ 18 Фев 2016, 12:50
от Анна Баханович
Как программно открыть форму и закрыть с записью, чтобы отработал метод перед записью

Автор con2rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2347
Последний ответ 13 Июн 2017, 12:17
от Whisper
Версия 8.3, при добавлении поля в форму списка не устанавливается вид поля - выпадающий список пустой

Автор Developer.KZРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 178
Последний ответ 22 Июн 2017, 10:50
от Developer.KZ

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
165 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
88 Сообщений
alex0402
87 Сообщений
Golickoff Golickoff
32 Сообщений
ilyay ilyay
30 Сообщений
Kironten
29 Сообщений
AsadRoman
26 Сообщений
AIFrame
26 Сообщений
BuhRust
26 Сообщений
Варвар
20 Сообщений

* Кто онлайн

  • Точка Гостей: 755
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal