Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 июн 2021, 08:59

Обработка изменений ТЧ и перезаполнение

Автор Constantus, 15 окт 2016, 19:07

0 Пользователей и 1 гость просматривают эту тему.

Constantus

Приветствую, форумчане!
УТ 10.3.14.1, 1с8.2, обычное

Пытаюсь сделать аналог обработки "ОбработкаТабличнойЧастиТовары"

Имеется самописный документ "ВозвратТоваровПоОрганизациям".
Имеется самописная обработка "ОбработкаПодборВозврата". Обработка отрабатывает все необходимые изменения. В обработке, реквизит "ДокументОбъект" стоит как ссылка на указанный документ.

На форме открываю обработку: (срабатывает нормально)

Процедура КоманднаяПанельТоварыДействие10(Кнопка)

ИзменениеТабличнойЧастиТовары      = Обработки.ОбработкаПодборВозврата.Создать();
ФормаИзменениеТабличнойЧастиТовары = ИзменениеТабличнойЧастиТовары.ПолучитьФорму(,ЭтаФорма);

ФормаИзменениеТабличнойЧастиТовары.ДокументОбъект             = ЭтотОбъект;
ФормаИзменениеТабличнойЧастиТовары.мФормаДокумента            = ЭтаФорма;

ФормаИзменениеТабличнойЧастиТовары.Кому = Организация;
ФормаИзменениеТабличнойЧастиТовары.ОтКого = ОрганизацияПолучателя;

ФормаИзменениеТабличнойЧастиТовары.Склад = СкладКонтрагента;
ФормаИзменениеТабличнойЧастиТовары.СкладНа = СкладОрдер;

ФормаИзменениеТабличнойЧастиТовары.Открыть();//ОткрытьМодально();

КонецПроцедуры


ТЧ в основной форме и ТЧ обработки - полные аналоги, т.е. все реквизиты совпадают один-к-одному.

Пытаюсь завершить операцию изменений:

Процедура КнопкаВыполнитьНажатие(Кнопка)

Сообщить(ДокументОбъект); // Не сообщает

   ДокументОбъект.Товары.Очистить(); // Не срабатывает


ДокументОбъект[мИмяТабличнойЧастиДокумента].Очистить(); //Не срабатывает

мФормаДокумента.Товары.Очистить();  //Работает

ДокументОбъект.Товары.Очистить();
    Для Каждого СтрокаТаб из Товары Цикл
        Если СтрокаТаб.ДаНет Тогда
НоваяСтрока = ДокументОбъект.Товары.Добавить();
//НоваяСтрока.Количество= 5;
    ЗаполнитьЗначенияСвойств(НоваяСтрока,СтрокаТаб);
        КонецЕсли;     
    КонецЦикла;
   

мФормаДокумента.ДоговорСПоставщиком = ДолговорПоставок; //Работает

    ЭтаФорма.Закрыть();



КонецПроцедуры

Никаких изменений не происходит. См ремарки против каждой строки.
Складывается впечатление, что "ДокументОбъект" либо не сохранился, либо стал пустым, либо я не правильно к нему обращаюсь.
Попытался сделать аналогично типовой обработки, но результатов также нет.

Подскажите, как правильно сделать данную обработку???


Rasty

передавать объект документа в реквизит формы? сомнительно, передавайте ссылку в реквизит, а уже в обработке получайте объект и его обрабатывайте
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)

Теги:

Похожие темы (5)

71458

Ответов: 2
Просмотров: 807

6898

Ответов: 14
Просмотров: 5381

31912

Ответов: 4
Просмотров: 2697

27905

Ответов: 1
Просмотров: 2647

Рейтинг@Mail.ru Rambler's Top100

Поиск