Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Ноя 2017, 23:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обработка изменений ТЧ и перезаполнение  (Прочитано 490 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Constantus

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-02
  • Сайт: 
Приветствую, форумчане!
УТ 10.3.14.1, 1с8.2, обычное

Пытаюсь сделать аналог обработки "ОбработкаТабличнойЧастиТовары"

Имеется самописный документ "ВозвратТоваровПоОрганизациям".
Имеется самописная обработка "ОбработкаПодборВозврата". Обработка отрабатывает все необходимые изменения. В обработке, реквизит "ДокументОбъект" стоит как ссылка на указанный документ.

На форме открываю обработку: (срабатывает нормально)

Процедура КоманднаяПанельТоварыДействие10(Кнопка)

ИзменениеТабличнойЧастиТовары      = Обработки.ОбработкаПодборВозврата.Создать();
ФормаИзменениеТабличнойЧастиТовары = ИзменениеТабличнойЧастиТовары.ПолучитьФорму(,ЭтаФорма);

ФормаИзменениеТабличнойЧастиТовары.ДокументОбъект             = ЭтотОбъект;
ФормаИзменениеТабличнойЧастиТовары.мФормаДокумента            = ЭтаФорма;

ФормаИзменениеТабличнойЧастиТовары.Кому = Организация;
ФормаИзменениеТабличнойЧастиТовары.ОтКого = ОрганизацияПолучателя;

ФормаИзменениеТабличнойЧастиТовары.Склад = СкладКонтрагента;
ФормаИзменениеТабличнойЧастиТовары.СкладНа = СкладОрдер;

ФормаИзменениеТабличнойЧастиТовары.Открыть();//ОткрытьМодально();

КонецПроцедуры

ТЧ в основной форме и ТЧ обработки - полные аналоги, т.е. все реквизиты совпадают один-к-одному.

Пытаюсь завершить операцию изменений:

Процедура КнопкаВыполнитьНажатие(Кнопка)

Сообщить(ДокументОбъект); // Не сообщает

   ДокументОбъект.Товары.Очистить(); // Не срабатывает
 

  ДокументОбъект[мИмяТабличнойЧастиДокумента].Очистить(); //Не срабатывает

мФормаДокумента.Товары.Очистить();  //Работает

ДокументОбъект.Товары.Очистить();
    Для Каждого СтрокаТаб из Товары Цикл
        Если СтрокаТаб.ДаНет Тогда
НоваяСтрока = ДокументОбъект.Товары.Добавить();
//НоваяСтрока.Количество= 5;
    ЗаполнитьЗначенияСвойств(НоваяСтрока,СтрокаТаб);
        КонецЕсли;     
    КонецЦикла;
   

мФормаДокумента.ДоговорСПоставщиком = ДолговорПоставок; //Работает

    ЭтаФорма.Закрыть();



КонецПроцедуры
Никаких изменений не происходит. См ремарки против каждой строки.
Складывается впечатление, что "ДокументОбъект" либо не сохранился, либо стал пустым, либо я не правильно к нему обращаюсь.
Попытался сделать аналогично типовой обработки, но результатов также нет.

Подскажите, как правильно сделать данную обработку???



Оффлайн Rasty

  • *****
  • Сообщений: 988
  • РЕПУТАЦИЯ: 139
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
передавать объект документа в реквизит формы? сомнительно, передавайте ссылку в реквизит, а уже в обработке получайте объект и его обрабатывайте
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
169 Сообщений
MuI_I_Ika MuI_I_Ika
87 Сообщений
oleg-x
71 Сообщений
ilyay ilyay
68 Сообщений
alex0402
62 Сообщений
Dmitry Qwe Dmitry Qwe
32 Сообщений
Golickoff Golickoff
24 Сообщений
Sy4a
24 Сообщений
Dima Dddd Dima Dddd
20 Сообщений
andron81_81
17 Сообщений

* Кто онлайн

  • Точка Гостей: 215
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal