Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Апр 2017, 16:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обработка изменений ТЧ и перезаполнение  (Прочитано 313 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Constantus

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-06-02
  • Сайт: 
Приветствую, форумчане!
УТ 10.3.14.1, 1с8.2, обычное

Пытаюсь сделать аналог обработки "ОбработкаТабличнойЧастиТовары"

Имеется самописный документ "ВозвратТоваровПоОрганизациям".
Имеется самописная обработка "ОбработкаПодборВозврата". Обработка отрабатывает все необходимые изменения. В обработке, реквизит "ДокументОбъект" стоит как ссылка на указанный документ.

На форме открываю обработку: (срабатывает нормально)

Процедура КоманднаяПанельТоварыДействие10(Кнопка)

ИзменениеТабличнойЧастиТовары      = Обработки.ОбработкаПодборВозврата.Создать();
ФормаИзменениеТабличнойЧастиТовары = ИзменениеТабличнойЧастиТовары.ПолучитьФорму(,ЭтаФорма);

ФормаИзменениеТабличнойЧастиТовары.ДокументОбъект             = ЭтотОбъект;
ФормаИзменениеТабличнойЧастиТовары.мФормаДокумента            = ЭтаФорма;

ФормаИзменениеТабличнойЧастиТовары.Кому = Организация;
ФормаИзменениеТабличнойЧастиТовары.ОтКого = ОрганизацияПолучателя;

ФормаИзменениеТабличнойЧастиТовары.Склад = СкладКонтрагента;
ФормаИзменениеТабличнойЧастиТовары.СкладНа = СкладОрдер;

ФормаИзменениеТабличнойЧастиТовары.Открыть();//ОткрытьМодально();

КонецПроцедуры

ТЧ в основной форме и ТЧ обработки - полные аналоги, т.е. все реквизиты совпадают один-к-одному.

Пытаюсь завершить операцию изменений:

Процедура КнопкаВыполнитьНажатие(Кнопка)

Сообщить(ДокументОбъект); // Не сообщает

   ДокументОбъект.Товары.Очистить(); // Не срабатывает
 

  ДокументОбъект[мИмяТабличнойЧастиДокумента].Очистить(); //Не срабатывает

мФормаДокумента.Товары.Очистить();  //Работает

ДокументОбъект.Товары.Очистить();
    Для Каждого СтрокаТаб из Товары Цикл
        Если СтрокаТаб.ДаНет Тогда
НоваяСтрока = ДокументОбъект.Товары.Добавить();
//НоваяСтрока.Количество= 5;
    ЗаполнитьЗначенияСвойств(НоваяСтрока,СтрокаТаб);
        КонецЕсли;     
    КонецЦикла;
   

мФормаДокумента.ДоговорСПоставщиком = ДолговорПоставок; //Работает

    ЭтаФорма.Закрыть();



КонецПроцедуры
Никаких изменений не происходит. См ремарки против каждой строки.
Складывается впечатление, что "ДокументОбъект" либо не сохранился, либо стал пустым, либо я не правильно к нему обращаюсь.
Попытался сделать аналогично типовой обработки, но результатов также нет.

Подскажите, как правильно сделать данную обработку???



Оффлайн Rasty

  • *****
  • Сообщений: 976
  • РЕПУТАЦИЯ: 137
  • КПД: 14%
  • Регистрация: 2015-03-25
    • Skype: alex1cbit
  • Сайт: 
  • Профессия: Программист 1С
передавать объект документа в реквизит формы? сомнительно, передавайте ссылку в реквизит, а уже в обработке получайте объект и его обрабатывайте
Помогли - Скажи спасибо! Решил сам - поделись решением!
:)


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
130 Сообщений
Dethmontt Dethmontt
79 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
74 Сообщений
ilyay ilyay
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
LexaK
30 Сообщений
Igmok
23 Сообщений
Сергей Федоров Сергей Федоров
22 Сообщений
BuhRust
22 Сообщений
magnifico61
19 Сообщений

* Кто онлайн

  • Точка Гостей: 273
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal