Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
09 Дек 2016, 14:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получить номер сеанса текущего пользователя  (Прочитано 283 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lelik

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-22
  • Сайт: 
Подскажите как сделать это на тонком клиенте?

// код в модуле управляемого приложения
#Область ОбработчикиСобытий
Процедура ПриНачалеРаботыСистемы()
    УстановитьКраткийЗаголовокПриложения("НОМЕР СЕАНСА: " + Строка(НомерСеансаИнформационнойБазы()));   
КонецПроцедуры
#КонецОбласти

На толстом клиенте работает, но в при сохранении конфигурации ругается на функцию НомерСеансаИнформационнойБазы() - функция не определена (Проверка: Тонкий клиент)
.

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ***
  • Сообщений: 173
  • РЕПУТАЦИЯ: 24
  • КПД: 14%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
В справке написано:
Цитировать
Доступность:
Сервер, толстый клиент, внешнее соединение

Вызывайте серверную функцию и получайте значение там.

Оффлайн lelik

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-22
  • Сайт: 
В модуле упр. приложения создал процедуру ПриНачалеРаботыСистемы()
#Область ОбработчикиСобытий
Процедура ПриНачалеРаботыСистемы()
ПоказатьГлавныйЗаголовокФормы();
КонецПроцедуры
#КонецОбласти
Сделал общий модуль. В нем прописал процедуру.
Процедура ПоказатьГлавныйЗаголовокФормы() Экспорт
 //код процедуры
КонецПроцедуры
При сохранении получаю:
{МодульУправляемогоПриложения(16,2)}: Процедура или функция с указанным именем не определена (ПоказатьГлавныйЗаголовокФормы)

Не ужели так сложно привести пример.
Добавлено: 15 Окт 2016, 20:57

Сделал. Тему закрываю.

Последний раз редактировалось: lelik; 15 Окт 2016, 20:57. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5740
  • РЕПУТАЦИЯ: 1094
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Сделал. Тему закрываю.

"Не ужели так сложно привести..." решение
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 144
Последний ответ 02 Дек 2016, 12:58
от Jalib
Получить полный HTTP код с сервера, Именно полный!

Автор Shining ninjaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1651
Последний ответ 12 Авг 2011, 15:23
от Shining ninja
Как получить значения элементов формы "ПриИзменении"?

Автор OptyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 3365
Последний ответ 07 Май 2015, 14:38
от Opty
Как получить цену товара контрагента и количество реализованного товара

Автор kbukaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1020
Последний ответ 08 Сен 2015, 15:46
от Klyacksa
Не удалось получить свойство "length" ссылки

Автор MuI_I_IkaРаздел Ошибки 1С:Предприятия

Ответов: 0
Просмотров: 45
Последний ответ 24 Ноя 2016, 10:28
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

Программист 1С от HR-PT
[08 Дек 2016, 14:23]


Программист 1с 8 от dima_d
[06 Дек 2016, 15:25]

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
77 Сообщений
cska-fanat-kz cska-fanat-kz
62 Сообщений
Kironten
56 Сообщений
alex0402
52 Сообщений
alexandr_ll
37 Сообщений
LexaK
34 Сообщений
sertak sertak
26 Сообщений
Андрей1966
24 Сообщений
djkeysi
24 Сообщений
BuhRust
23 Сообщений

* Кто онлайн

  • Точка Гостей: 708
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal