Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2021, 16:29
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Получить номер сеанса текущего пользователя  (Прочитано 6005 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lelik

  • *
  • Регистрация: 2016-08-22
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
Подскажите как сделать это на тонком клиенте?

// код в модуле управляемого приложения
#Область ОбработчикиСобытий
Процедура ПриНачалеРаботыСистемы()
    УстановитьКраткийЗаголовокПриложения("НОМЕР СЕАНСА: " + Строка(НомерСеансаИнформационнойБазы()));   
КонецПроцедуры
#КонецОбласти

На толстом клиенте работает, но в при сохранении конфигурации ругается на функцию НомерСеансаИнформационнойБазы() - функция не определена (Проверка: Тонкий клиент)
.


Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • *****
  • Регистрация: 2011-06-09
  • Сообщений: 562
  • РЕПУТАЦИЯ: 104
  • КПД: 19%
  • Профессия: Разработчик 1С
В справке написано:
Цитировать
Доступность:
Сервер, толстый клиент, внешнее соединение

Вызывайте серверную функцию и получайте значение там.

Оффлайн lelik

  • *
  • Регистрация: 2016-08-22
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
В модуле упр. приложения создал процедуру ПриНачалеРаботыСистемы()
#Область ОбработчикиСобытий
Процедура ПриНачалеРаботыСистемы()
ПоказатьГлавныйЗаголовокФормы();
КонецПроцедуры
#КонецОбласти
Сделал общий модуль. В нем прописал процедуру.
Процедура ПоказатьГлавныйЗаголовокФормы() Экспорт
 //код процедуры
КонецПроцедуры
При сохранении получаю:
{МодульУправляемогоПриложения(16,2)}: Процедура или функция с указанным именем не определена (ПоказатьГлавныйЗаголовокФормы)

Не ужели так сложно привести пример.
Добавлено: 15 Окт 2016, 20:57

Сделал. Тему закрываю.

Последний раз редактировалось: lelik; 15 Окт 2016, 20:57. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • *****
  • Регистрация: 2010-11-06
  • Сообщений: 5748
  • РЕПУТАЦИЯ: 1105
  • КПД: 19%
  • Красная армия всех сильней!
    • Skype: cska-fanat-kz81
  • Профессия: Разработчик 1С
Сделал. Тему закрываю.

"Не ужели так сложно привести..." решение
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

как получить значение реквизита

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6135
Последний ответ 29 Мая 2015, 17:42
от mashencev_anton
Как получить значение поля дополнительной формы

Автор CristalРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1752
Последний ответ 25 Апр 2012, 23:18
от Dethmontt
Получить данные из Регистра сведений (переодический)

Автор Kostik2013Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3154
Последний ответ 02 Апр 2013, 19:10
от Kostik2013
Получить ссылку на элемент справочника

Автор Q37Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1059
Последний ответ 09 Авг 2018, 19:01
от Q37
Как получить ссылку на док из поля Результат типового отчета?

Автор drbrРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 279
Последний ответ 11 Апр 2019, 16:22
от drbr

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

LexaK
68 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
antoneus antoneus
33 Сообщений
Ивашка
27 Сообщений
neek666
26 Сообщений
KATERINA 861
19 Сообщений
Алексей_1985_06
15 Сообщений
SSC
15 Сообщений
alexandr_ll
14 Сообщений
BuhRust
8 Сообщений

* Кто онлайн

  • Точка Гостей: 536
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск