Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Сен 2017, 17:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получить номер сеанса текущего пользователя  (Прочитано 1108 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lelik

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-22
  • Сайт: 
Подскажите как сделать это на тонком клиенте?

// код в модуле управляемого приложения
#Область ОбработчикиСобытий
Процедура ПриНачалеРаботыСистемы()
    УстановитьКраткийЗаголовокПриложения("НОМЕР СЕАНСА: " + Строка(НомерСеансаИнформационнойБазы()));   
КонецПроцедуры
#КонецОбласти

На толстом клиенте работает, но в при сохранении конфигурации ругается на функцию НомерСеансаИнформационнойБазы() - функция не определена (Проверка: Тонкий клиент)
.


Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ****
  • Сообщений: 367
  • РЕПУТАЦИЯ: 69
  • КПД: 19%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
В справке написано:
Цитировать
Доступность:
Сервер, толстый клиент, внешнее соединение

Вызывайте серверную функцию и получайте значение там.

Оффлайн lelik

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-22
  • Сайт: 
В модуле упр. приложения создал процедуру ПриНачалеРаботыСистемы()
#Область ОбработчикиСобытий
Процедура ПриНачалеРаботыСистемы()
ПоказатьГлавныйЗаголовокФормы();
КонецПроцедуры
#КонецОбласти
Сделал общий модуль. В нем прописал процедуру.
Процедура ПоказатьГлавныйЗаголовокФормы() Экспорт
 //код процедуры
КонецПроцедуры
При сохранении получаю:
{МодульУправляемогоПриложения(16,2)}: Процедура или функция с указанным именем не определена (ПоказатьГлавныйЗаголовокФормы)

Не ужели так сложно привести пример.
Добавлено: 15 Окт 2016, 20:57

Сделал. Тему закрываю.

Последний раз редактировалось: lelik; 15 Окт 2016, 20:57. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Сделал. Тему закрываю.

"Не ужели так сложно привести..." решение
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 938
Последний ответ 02 Дек 2016, 12:58
от Jalib
Получить полный HTTP код с сервера, Именно полный!

Автор Shining ninjaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2040
Последний ответ 12 Авг 2011, 15:23
от Shining ninja
Как получить значения элементов формы "ПриИзменении"?

Автор OptyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 6840
Последний ответ 07 Май 2015, 14:38
от Opty
Как получить цену товара контрагента и количество реализованного товара

Автор kbukaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1501
Последний ответ 08 Сен 2015, 15:46
от Klyacksa
Не удалось получить свойство "length" ссылки

Автор MuI_I_IkaРаздел Ошибки 1С:Предприятия

Ответов: 0
Просмотров: 736
Последний ответ 24 Ноя 2016, 10:28
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
165 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
88 Сообщений
alex0402
87 Сообщений
Golickoff Golickoff
32 Сообщений
ilyay ilyay
30 Сообщений
Kironten
29 Сообщений
AsadRoman
26 Сообщений
BuhRust
26 Сообщений
AIFrame
26 Сообщений
Варвар
20 Сообщений

* Кто онлайн

  • Точка Гостей: 756
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal