Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 сен 2021, 07:41

Помогите с сохранением печатной формы в .docx

Автор Fedor_Safonchik, 12 окт 2016, 10:11

0 Пользователей и 1 гость просматривают эту тему.

Fedor_Safonchik

Вот код проверки вывода данной области:

//формируем промежуточный ТД
табДокКИ.Вывести(ОбластьКонтактыТехническихСлужбЗначения);

КонецЦикла;

//проверяем вывод КИ
Если НЕ ТабличныйДокумент.ПроверитьВывод(табДокКИ) Тогда
//выводим разделитель
ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
//при необходимости выводим заголовок таблицы
//ТабличныйДокумент.Вывести(ЗаголовокТаблицы);
КонецЕсли;


В .docx сохраняется как во вложении, помогите, что возможно сделать для исправления, может кто-то сталкивался

cska-fanat-kz

разве в ПроверитьВывод() помещают ТабДок?
не область?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Fedor_Safonchik

Цитата: cska-fanat-kz от 13 окт 2016, 14:59
разве в ПроверитьВывод() помещают ТабДок?
не область?

Я делаю промежуточный табличный документ и проверяю его вывод, если выводится - тогда помещаю его в основной таб. док, если нет - тогда разделитель и потом уже промежуточный таб. док,

Сейчас попробую переписать , спасибо большое !
Добавлено: 13 окт 2016, 16:26


Цитировать
Сейчас попробую переписать , спасибо большое !

Если НЕ ТабличныйДокумент.ПроверитьВывод(ОбластьКонтактыТехническихСлужбШапка) ИЛИ НЕ ТабличныйДокумент.ПроверитьВывод(ОбластьКонтактыТехническихСлужбЗначения) Тогда
ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;


Написал вот так, но все равно результат такой-же, щас попробую установить отступ от нижнего края не 10мм. (который стандартный), а больше и тестировать буду)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск