Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Сен 2017, 13:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с сохранением печатной формы в .docx  (Прочитано 335 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Fedor_Safonchik

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 8
  • КПД: 17%
  • Регистрация: 2016-06-16
  • Сайт: 
  • Профессия: Ученик 1С
Вот код проверки вывода данной области:
		//формируем промежуточный ТД
табДокКИ.Вывести(ОбластьКонтактыТехническихСлужбЗначения);

КонецЦикла;

//проверяем вывод КИ
Если НЕ ТабличныйДокумент.ПроверитьВывод(табДокКИ) Тогда
//выводим разделитель
ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
//при необходимости выводим заголовок таблицы
//ТабличныйДокумент.Вывести(ЗаголовокТаблицы);
КонецЕсли;

В .docx сохраняется как во вложении, помогите, что возможно сделать для исправления, может кто-то сталкивался


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
разве в ПроверитьВывод() помещают ТабДок?
не область?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Fedor_Safonchik

  • *
  • Сообщений: 48
  • РЕПУТАЦИЯ: 8
  • КПД: 17%
  • Регистрация: 2016-06-16
  • Сайт: 
  • Профессия: Ученик 1С
разве в ПроверитьВывод() помещают ТабДок?
не область?

Я делаю промежуточный табличный документ и проверяю его вывод, если выводится - тогда помещаю его в основной таб. док, если нет - тогда разделитель и потом уже промежуточный таб. док,

Сейчас попробую переписать , спасибо большое !
Добавлено: 13 Окт 2016, 16:26

Цитировать
Сейчас попробую переписать , спасибо большое !

	Если НЕ ТабличныйДокумент.ПроверитьВывод(ОбластьКонтактыТехническихСлужбШапка) ИЛИ НЕ ТабличныйДокумент.ПроверитьВывод(ОбластьКонтактыТехническихСлужбЗначения) Тогда
ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

Написал вот так, но все равно результат такой-же, щас попробую установить отступ от нижнего края не 10мм. (который стандартный), а больше и тестировать буду)

Последний раз редактировалось: Fedor_Safonchik; 13 Окт 2016, 16:26. Причина: Объединение сообщений


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4124
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5385
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5716
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3958
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1865
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
165 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
88 Сообщений
alex0402
87 Сообщений
Golickoff Golickoff
32 Сообщений
ilyay ilyay
30 Сообщений
Kironten
29 Сообщений
AsadRoman
26 Сообщений
BuhRust
26 Сообщений
AIFrame
26 Сообщений
Варвар
20 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal