Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2016, 16:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не получается вывести картинку товара в поле картинки  (Прочитано 122 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн vlad_

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-10-10
  • Сайт: 
  • Профессия: Ученик 1С
В справочнике есть табличная часть "товары"..  в ней реквизит номенклатура. кроме того в таб части реквизит "ХранилищеИзображения" с типом ХранилищеЗначения.. Ещё на форме поле "АдресКартинки" с типом поле картинки и кнопка "Добавить изображение".. При нажатии на кнопку для активной строки номенклатуры должна происходить загрузка картинки. при активизации любой строки из ТЧ картинка должна выводиться в поле "АдресКартинки"..  у меня загружается но при смене строки пропадает с поля..  в чём ошибка???  помогите пожалуйста..


Оффлайн vlad_

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-10-10
  • Сайт: 
  • Профессия: Ученик 1С
// процедура нажатие на кнопку "Добавить изображение"
//
&НаКлиенте
Процедура ДобавитьИзображение(Команда)

ТекСтрока = Элементы.Товары.ТекущиеДанные;

Если ТекСтрока = Неопределено Тогда
Возврат;
КонецЕсли;

Режим = РежимДиалогаВыбораФайла.Открытие;
ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
ДиалогОткрытияФайла.ПолноеИмяФайла = "";
Фильтр = "Изображения(*.bmp,*.jpg,*.png,*.jpeg)|*.bmp;*.jpg;*.png;*.jpeg";
ДиалогОткрытияФайла.Фильтр = Фильтр;
ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
ДиалогОткрытияФайла.Заголовок = "Выберите файл для загрузки";

Если Не ДиалогОткрытияФайла.Выбрать() Тогда

Возврат;

КонецЕсли;

ПолноеИмяФайла = ДиалогОткрытияФайла.ПолноеИмяФайла;

АдресКартинки = ПоместитьВоВременноеХранилище(Новый ДвоичныеДанные(ПолноеИмяФайла), ЭтотОбъект.УникальныйИдентификатор);

ДобавитьИзображениеНаСервере(ТекСтрока.НомерСтроки - 1, АдресКартинки);   

КонецПроцедуры

&НаСервере
Процедура ДобавитьИзображениеНаСервере(ИдСтроки,  АдресКартинки);   


ТекОбъект = РеквизитФормыВЗначение("Объект");
текСтрока = ТекОбъект.Товары[ИдСтроки];

ДвоичныеДанные = ПолучитьИзВременногоХранилища(АдресКартинки);
текСтрока.ХранилищеИзображения = Новый ХранилищеЗначения(ДвоичныеДанные, Новый СжатиеДанных(9));


ЗначениеВРеквизитФормы(ТекОбъект, "Объект");

КонецПроцедуры


//процедура при создании формы на сервере
//
&НаСервере                                                         
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

ТекСтрока = Элементы.Товары.ТекущаяСтрока;


ТекОбъект = РеквизитФормыВЗначение("Объект");
АдресКартинки = ПолучитьНавигационнуюСсылку(ТекОбъект.Ссылка, "Товары.ХранилищеИзображения", ТекСтрока);

КонецПроцедуры

//Отображение картинки при переходе по строкам
//
&НаКлиенте
Процедура ТоварыПриАктивизацииСтроки(Элемент)

ТекСтрока = Элемент.ТекущиеДанные;
Если ТекСтрока = Неопределено Тогда
Возврат;
КонецЕсли;

АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "Товары.ХранилищеИзображения", ТекСтрока.НомерСтроки-1);

ТоварыПриАктивизацииСтрокиНаСервере(ТекСтрока.НомерСтроки-1);

КонецПроцедуры

&НаСервере
Процедура ТоварыПриАктивизацииСтрокиНаСервере(ИдСтроки)

ТекОбъект = РеквизитФормыВЗначение("Объект");
АдресКартинки = ПолучитьНавигационнуюСсылку(ТекОбъект, "Товары.ХранилищеИзображения", ИдСтроки);

КонецПроцедуры

Добавлено: 11 Окт 2016, 18:01


Последний раз редактировалось: vlad_; 11 Окт 2016, 18:01. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
72 Сообщений
alex0402
57 Сообщений
cska-fanat-kz cska-fanat-kz
50 Сообщений
Kironten
49 Сообщений
LexaK
32 Сообщений
alexandr_ll
30 Сообщений
sertak sertak
26 Сообщений
djkeysi
24 Сообщений
BuhRust
23 Сообщений
Андрей1966
21 Сообщений

* Кто онлайн

  • Точка Гостей: 242
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal