Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
08 Дек 2016, 03:06
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не могу свернуть поля ТЧ в печатной форме  (Прочитано 258 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Vasya Povar

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-10-10
  • Сайт: 
Фрагмент кода
Запрос2.Текст =  "ВЫБРАТЬ
                 | РеализацияТМЦТовары.НомерСтроки,
                 | РеализацияТМЦТовары.Номенклатура,
                 | РеализацияТМЦТовары.Количество КАК Кво,
                 | РеализацияТМЦТовары.Цена,
                 | РеализацияТМЦТовары.Сумма КАК Сумма,
                 | РеализацияТМЦТовары.СуммаНДС КАК СуммаНДС,
                 | РеализацияТМЦТовары.ЦенаБезНДС КАК ЦенаБезНДС,
                 | РеализацияТМЦТовары.СуммаБезНДС КАК СуммаБезНДС,
                 | РеализацияТМЦТовары.ЕдиницаИзмерения КАК Ед
                 |ИЗ
                 | Документ.РеализацияТМЦ.Товары КАК РеализацияТМЦТовары
                 |ГДЕ
                 | РеализацияТМЦТовары.Ссылка В(&Ссылка)" ;

       Запрос2.Параметры.Вставить("Ссылка",Ссылка);
ВыборкаУслуги = Запрос2.Выполнить().Выбрать();
//ВыборкаУслуги = Выборка.Услуги.Выбрать();
Пока ВыборкаУслуги.Следующий() Цикл
СтрокаТЧ.Параметры.НомерСтрока = ВыборкаУслуги.НомерСтроки;
СтрокаТЧ.Параметры.НаименованиеТМЦ = ВыборкаУслуги.Номенклатура;
   СтрокаТЧ.Параметры.Ед = ВыборкаУслуги.Ед;
    СтрокаТЧ.Параметры.Количество = ВыборкаУслуги.Кво;
СтрокаТЧ.Параметры.Цена = ВыборкаУслуги.Цена-(ВыборкаУслуги.СуммаНДС/ВыборкаУслуги.Кво);
  СтрокаТЧ.Параметры.Сумма = ВыборкаУслуги.Сумма;   
  Если ВыборкаУслуги.Цена=0 Тогда
  СтрокаТЧ.Параметры.Цена = "0.00";
  КонецЕсли;
  Если  ВыборкаУслуги.Сумма=0 Тогда
  СтрокаТЧ.Параметры.Сумма = "0.00" ;
  КонецЕсли;
выб = Запрос2.Выполнить().Выгрузить();
    выб.Свернуть("Номенклатура,Цена,Ед,НомерСтроки,СуммаНДС","Кво,Сумма");
    ТабДок.Вывести(СтрокаТЧ);

КонецЦикла;

          //**************************
        СуммаБезНДС = 0;
СуммаНДС    = 0;
        СуммаВсего  = 0;

ВыборкаУслуги = Запрос2.Выполнить().Выбрать();
Пока ВыборкаУслуги.Следующий() Цикл
           
            СуммаВсего = СуммаВсего + ВыборкаУслуги.Сумма    ;
            СуммаНДС    = СуммаНДС    +  ВыборкаУслуги.СуммаНДС;
            СуммаБезНДС  = СуммаБезНДС  + ВыборкаУслуги.Сумма-ВыборкаУслуги.СуммаНДС;
           
КонецЦикла;
        Подвал.Параметры.СуммаБезНДС = СуммаБезНДС;
        Подвал.Параметры.СуммаНДС    = СуммаНДС   ;
        Подвал.Параметры.СуммаВсего  = СуммаВсего ;
         Валюта = Выборка.Валюта;

      СуммаПрописью  = ОбщегоНазначенияБПВызовСервера.СформироватьСуммуПрописью(СуммаВсего,Валюта);
     Подвал.Параметры.Заполнить(Выборка);
Если ВыборкаУслуги.СуммаНДС = 0 Тогда
Подвал.Параметры.СуммаНДС = "0.00" ;
КонецЕсли;
Если ВыборкаУслуги.Сумма = 0 Тогда
Подвал.Параметры.СуммаБезНДС = "0.00";
КонецЕсли;
Если СуммаВсего = 0 Тогда
Подвал.Параметры.СуммаВсего = "0.00";
КонецЕсли;
        Подвал.Параметры.СуммаПрописью = СуммаПрописью;
        ТабДок.Вывести(Подвал,Выборка.Уровень());

ВставлятьРазделительСтраниц = Истина;

КонецЦикла;

Необходимо чтобы при печати не выводило поля с одинаковой ценой и номенклатурой, а соединяло вместе и суммировало по полю Количество и Сумма.
При выполнении ошибок нет,но не свернуло поля. Помогите плз.


Оффлайн cast

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 4
  • КПД: 9%
  • Регистрация: 2015-05-09
  • Сайт: 
У тебя в запросе нет группировки. В конструкторе запросов на закладке группиротвка

Оффлайн Vasya Povar

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-10-10
  • Сайт: 
У тебя в запросе нет группировки. В конструкторе запросов на закладке группиротвка

А так, чтобы методом свернуть никак?

Оффлайн LexaK

  • *****
  • Сообщений: 1037
  • РЕПУТАЦИЯ: 273
  • КПД: 26%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
если вы написали запрос к базе, старайтесь в этом (одном) запросе получить и как надо обработать данные, с которыми вы потом что-то будете делать.
поэтому в вашем варианте надо в запросе получить и свернуть данные для печати.

вот примерный вариант (просто взял ваш запрос, на примере 3-х полей показал как сворачивать, если что-то еще доделаете сами)
Запрос2.Текст =  "ВЫБРАТЬ
                     |    РеализацияТМЦТовары.Номенклатура,
                     |    РеализацияТМЦТовары.Цена,
                     |    Сумма(РеализацияТМЦТовары.Количество) КАК Кво,
                     |    Сумма(РеализацияТМЦТовары.Сумма) КАК Сумма
                     |ИЗ
                     |    Документ.РеализацияТМЦ.Товары КАК РеализацияТМЦТовары
                     |ГДЕ
                     |    РеализацияТМЦТовары.Ссылка В(&Ссылка)
                     |сгруппировать
                     |    РеализацияТМЦТовары.Номенклатура,
                     |    РеализацияТМЦТовары.Цена";
       

ну и конечно-же можно сворачивать данные не только в запросе а еще и таблице значений.

Читайте СП (синтаксис помощник)

ТаблицаЗначений (ValueTable)
Свернуть (GroupBy)
Синтаксис:

Свернуть(<КолонкиГруппировок>, <КолонкиСуммирования>)
Параметры:

<КолонкиГруппировок> (обязательный)

Тип: Строка.
Имена колонок, разделенные запятыми, по которым необходимо группировать строки таблицы значений.
<КолонкиСуммирования> (необязательный)

Тип: Строка.
Имена колонок, разделенные запятыми, по которым необходимо суммировать значения в строках таблицы значений.

 
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Fedor_Safonchik

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 4
  • КПД: 12%
  • Регистрация: 2016-06-16
  • Сайт: 
  • Профессия: Ученик 1С
   ТаблицаНоменклатуры = Объект.ВашаТаблица.Выгрузить();
      ТаблицаНоменклатуры .Свернуть("Номенклатура, Цена", "Количество, Сумма");
      Объект.ВашаТаблица.Очистить();
   Объект.ВашаТаблица.Загрузить(ТаблицаНоменклатуры );

Счастья Вам, но подход через листики к тычинкам

Оффлайн Vasya Povar

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-10-10
  • Сайт: 
Всем Спасибо, вопрос решил.


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 154
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 879
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 882
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Модуль к форме "Настройка заполнения"

Автор oyufedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2807
Последний ответ 17 Янв 2014, 16:35
от oyufed
Отображение HTML-макета в форме с HTML-полем.

Автор spikee666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1886
Последний ответ 21 Авг 2014, 17:51
от spikee666

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
80 Сообщений
cska-fanat-kz cska-fanat-kz
68 Сообщений
Kironten
47 Сообщений
alex0402
46 Сообщений
alexandr_ll
34 Сообщений
LexaK
34 Сообщений
djkeysi
24 Сообщений
Андрей1966
24 Сообщений
sertak sertak
23 Сообщений
BuhRust
22 Сообщений

* Кто онлайн

  • Точка Гостей: 156
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal