Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Ноя 2017, 02:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: подменю печать на форме документа  (Прочитано 827 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dimid

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-26
  • Сайт: 
  • Профессия: Ученик 1С
создал внешнюю обработку печатной формы для документа Форма110. привязал к документу (доп внешние печатные формы). и столкнулся с такой проблемой. при открытии документа на командной панели отсутствует кнопка печать. Полез смотреть как в других доках, там кнопка присутствует. Делал по аналогии их кода. все равно кнопка отсутствует. код в форму документа "Форма110" добавлял такой:

Перем мДеревоМакетов;
// Хранит элемент управления подменю печати
Перем мПодменюПечати;

// Хранит элемент управления кнопку печать по умолчанию
Перем мПечатьПоУмолчанию;

Процедура УстановитьКнопкиПечати()
   
   мДеревоМакетов = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(Ссылка, неопределено, Новый Действие("ОсновныеДействияФормыПечать"), Новый Действие("ОсновныеДействияФормыУстановитьПечатьПоУмолчанию"));
   
   УниверсальныеМеханизмы.УстановитьПодменюПечати    (мПодменюПечати, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов.Строки.Количество() > 0);
   УниверсальныеМеханизмы.УстановитьПечатьПоУмолчанию(мПечатьПоУмолчанию, ЭлементыФормы.ОсновныеДействияФормы, мДеревоМакетов, Метаданные().Имя,Новый Действие("ОсновныеДействияФормыПечатьПоУмолчанию"));
   
   Если Не мПодменюПечати = Неопределено Тогда
      УниверсальныеМеханизмы.СформироватьПодменю(мДеревоМакетов, мПодменюПечати,Истина,Истина);
   КонецЕсли;    
   

КонецПроцедуры
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)

   // Установка кнопок печати
   УстановитьКнопкиПечати();
   
   
   
КонецПроцедуры // ПередОткрытием()
Процедура ОсновныеДействияФормыПечатьПоУмолчанию(Кнопка)
   УниверсальныеМеханизмы.ПечатьПоДополнительнойКнопке(мДеревоМакетов, ЭтотОбъект, ЭтаФорма, Кнопка.Текст);
   
КонецПроцедуры
Процедура ОсновныеДействияФормыПечать(Кнопка)
   УниверсальныеМеханизмы.ПечатьПоДополнительнойКнопке(мДеревоМакетов, ЭтотОбъект, ЭтаФорма, Кнопка.Текст);
   
КонецПроцедуры
Процедура ОсновныеДействияФормыУстановитьПечатьПоУмолчанию(Кнопка)
   
   Если УниверсальныеМеханизмы.НазначитьКнопкуПечатиПоУмолчанию(мДеревоМакетов, Метаданные().Имя) Тогда
      
      УстановитьКнопкиПечати();
      
   КонецЕсли;
   
   
КонецПроцедуры



Оффлайн Летящий в даль

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 12
  • КПД: 21%
  • 1с - это диагенез :D
  • Регистрация: 2016-05-16
  • Сайт: 
  • Профессия: Программист 1С
Форму документа покажите, может быть вы не разместили ваще эту кнопку?

Оффлайн dimid

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-26
  • Сайт: 
  • Профессия: Ученик 1С
Форму документа покажите, может быть вы не разместили ваще эту кнопку?
Процедура устанавливает подменю "Печать" и кнопку "Печать по умолчанию" при необходимости. На форме (по примеру которой вставлял код)кнопки нет.


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4423
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15717
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4135
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 573
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7674
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
138 Сообщений
MuI_I_Ika MuI_I_Ika
96 Сообщений
oleg-x
66 Сообщений
alex0402
60 Сообщений
ilyay ilyay
51 Сообщений
Dmitry Qwe Dmitry Qwe
33 Сообщений
Sy4a
22 Сообщений
Dima Dddd Dima Dddd
21 Сообщений
BuhRust
20 Сообщений
Kironten
12 Сообщений

* Кто онлайн

  • Точка Гостей: 165
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal