Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2016, 12:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Чтение xml  (Прочитано 192 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dimid

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-26
  • Сайт: 
  • Профессия: Ученик 1С
вот кусок из кода: &НаСервере
Процедура ОткрытьФайлНаСервере()
   ЧтениеXML = Новый ЧтениеXML;
ЧтениеXML.ОткрытьФайл("D:\for_xml\scheta1.xml");
РезультатРазборки = Новый Массив;
Пока ЧтениеXML.Прочитать() Цикл
   Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента и ЧтениеXML.Имя = "Счет_на_оплату_покупателю" Тогда
      Прервать;
   КонецЕсли;
КонецЦикла;
СтекУзлов = Новый Массив;
ТекущийПуть = "";
Пока ЧтениеXML.Прочитать() Цикл
   Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента тогда
      СтекУзлов.Добавить(ЧтениеXML.Имя);
      ТекущийПуть = МассивВСтроку (СтекУзлов);
      Если ЧтениеXML.Имя = "Счет" и ТекущийПуть = "Счет" тогда
         ДокументСчет = Новый Структура ("Дата", "Номер", "Организация","Контрагент", "Договор", "счетКасса", "Товар");
         ИначеЕсли ЧтениеXML.Имя = "Товар" и ТекущийПуть = "Счет\Товар" тогда
         СтруктураТовар = новый Структура ("Номенклатура", "Количество", "Ед.изм.", "К.", "Цена", "Руч.ск", "Сумма", "СтавкаНДС", "СуммаНДС", "ЗаказПокупател");
      КонецЕсли;
............
выдает ошибку "Процедура или функция с указанным именем не определена (МассивВСтроку)"
подскажите почему??


Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн dimid

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-26
  • Сайт: 
  • Профессия: Ученик 1С
Re: Чтение xml
« Ответ #1: 30 Сен 2016, 13:36 »
вот кусок из кода: &НаСервере
Процедура ОткрытьФайлНаСервере()
   ЧтениеXML = Новый ЧтениеXML;
ЧтениеXML.ОткрытьФайл("D:\for_xml\scheta1.xml");
РезультатРазборки = Новый Массив;
Пока ЧтениеXML.Прочитать() Цикл
   Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента и ЧтениеXML.Имя = "Счет_на_оплату_покупателю" Тогда
      Прервать;
   КонецЕсли;
КонецЦикла;
СтекУзлов = Новый Массив;
ТекущийПуть = "";
Пока ЧтениеXML.Прочитать() Цикл
   Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента тогда
      СтекУзлов.Добавить(ЧтениеXML.Имя);
      ТекущийПуть = МассивВСтроку (СтекУзлов);
      Если ЧтениеXML.Имя = "Счет" и ТекущийПуть = "Счет" тогда
         ДокументСчет = Новый Структура ("Дата", "Номер", "Организация","Контрагент", "Договор", "счетКасса", "Товар");
         ИначеЕсли ЧтениеXML.Имя = "Товар" и ТекущийПуть = "Счет\Товар" тогда
         СтруктураТовар = новый Структура ("Номенклатура", "Количество", "Ед.изм.", "К.", "Цена", "Руч.ск", "Сумма", "СтавкаНДС", "СуммаНДС", "ЗаказПокупател");
      КонецЕсли;
............
выдает ошибку "Процедура или функция с указанным именем не определена (МассивВСтроку)"
подскажите почему??
все, разобрался. заменил на "ЗначениеВСтрокуВнутр"

Оффлайн dimid

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-26
  • Сайт: 
  • Профессия: Ученик 1С
Re: Чтение xml
« Ответ #2: 03 Окт 2016, 08:21 »
вот еще вопрос:
СтекУзлов = Новый Массив;
ТекущийПуть = "";
Пока ЧтениеXML.Прочитать() Цикл
   Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента тогда
      СтекУзлов.Добавить(ЧтениеXML.Имя);
      ТекущийПуть = ЗначениеВСтрокуВнутр (СтекУзлов);
      Если ЧтениеXML.Имя = "Счет" и ТекущийПуть = "Счет" тогда
         ДокументСчет = Новый Структура ("Дата", "Номер", "Организация","Контрагент", "Договор", "счетКасса", "Товар");
         ИначеЕсли ЧтениеXML.Имя = "Товар" и ТекущийПуть = "Счет\Товар" тогда
         СтруктураТовар = новый Структура ("Номенклатура", "Количество", "Ед.изм.", "К.", "Цена", "Руч.ск", "Сумма", "СтавкаНДС", "СуммаНДС", "ЗаказПокупател");
      КонецЕсли;

Дальше "Счет" не идет. Т.Е. "счет\Товар" почему-то не читает. В чем ошибка-то??
Добавлено: 03 Окт 2016, 09:00

вот еще вопрос:
СтекУзлов = Новый Массив;
ТекущийПуть = "";
Пока ЧтениеXML.Прочитать() Цикл
   Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента тогда
      СтекУзлов.Добавить(ЧтениеXML.Имя);
      ТекущийПуть = ЗначениеВСтрокуВнутр (СтекУзлов);
      Если ЧтениеXML.Имя = "Счет" и ТекущийПуть = "Счет" тогда
         ДокументСчет = Новый Структура ("Дата", "Номер", "Организация","Контрагент", "Договор", "счетКасса", "Товар");
         ИначеЕсли ЧтениеXML.Имя = "Товар" и ТекущийПуть = "Счет\Товар" тогда
         СтруктураТовар = новый Структура ("Номенклатура", "Количество", "Ед.изм.", "К.", "Цена", "Руч.ск", "Сумма", "СтавкаНДС", "СуммаНДС", "ЗаказПокупател");
      КонецЕсли;

Дальше "Счет" не идет. Т.Е. "счет\Товар" почему-то не читает. В чем ошибка-то??
исправлено! но теперь другой вопрос. дата в формате: "02.09.2016 9:24:10" , как правильно прочитать??

Последний раз редактировалось: dimid; 03 Окт 2016, 09:00. Причина: Объединение сообщений


Теги:
 

работа с файлами excel открытие файла xls, чтение данных и запись нового файла xls

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 758
Последний ответ 11 Фев 2016, 12:49
от Rasty
Справочник - как раздать права пользователям на чтение элементов

Автор LuunaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1528
Последний ответ 12 Дек 2012, 13:31
от MuI_I_Ika
Чтение файла ексель и загрузка его в таблицу значений

Автор Igor100500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 335
Последний ответ 07 Окт 2016, 12:06
от Igor100500
Чтение XML в дерево значений. Проблема с прочтением.

Автор delo_irisРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 6599
Последний ответ 14 Авг 2011, 10:31
от delo_iris
Чтение из xml и запись информации в справочники и документы

Автор Ученик_2014Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2535
Последний ответ 10 Фев 2014, 07:13
от sdilshod

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
72 Сообщений
alex0402
57 Сообщений
cska-fanat-kz cska-fanat-kz
50 Сообщений
Kironten
49 Сообщений
LexaK
32 Сообщений
alexandr_ll
30 Сообщений
sertak sertak
26 Сообщений
djkeysi
24 Сообщений
BuhRust
23 Сообщений
Андрей1966
21 Сообщений

* Кто онлайн

  • Точка Гостей: 254
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal