Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 02:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение открытой формы  (Прочитано 4471 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Antonyy

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-08
  • Сайт: 
  • Профессия: Программист 8.1
Подскажите пожалуйста, начал переводить конфигурации 8.1 на управляемые формы, в итоге не могу изменить данный на уже открытой форме документ, но поверх нее открыта другая не основная форма документ, в 8,1 делалось так:
Процедура ОкНажатие(Элемент)
Форм=Ссылка.ПолучитьФорму();
Форм.ЭлементыФормы.Торговля.ДобавитьСтроку();
текстрока=Форм.ЭлементыФормы.Торговля.ТекущаяСтрока;
текстрока.Инструмент=ЭлементыФормы.Инструмент.Значение;
ЭтаФорма.Закрыть();
КонецПроцедуры


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
А если не секрет, зачем вам это нужно. Получать форму, работать с реквизитами именно формы! Ведь так, иначе зачем обращаться через ЭлементыФормы? И ...в итоге ее не открывать....

Оффлайн Antonyy

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-08
  • Сайт: 
  • Профессия: Программист 8.1
Просто пробовал непосредственно менять реквизиты документа, но так как форма документа уже открыта возникает ошибка, закрыть форму нельзя, не удобно для пользователя будет, может конечно есть функция для отбавления данных формы, тогда такой вариант думаю возможен

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Просто пробовал непосредственно менять реквизиты документа, но так как форма документа уже открыта возникает ошибка, закрыть форму нельзя, не удобно для пользователя будет, может конечно есть функция для отбавления данных формы, тогда такой вариант думаю возможен

Для обновления измененных данных документа в уже открытой форме есть метод Прочитать()
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Antonyy

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-08
  • Сайт: 
  • Профессия: Программист 8.1
Попробовал метод прочитать(), почему то не обновляет, хотя, при открытии документа заново документа данные обновились
&НаКлиенте
Процедура ПрочитатьВ(Команда)
   ЭтаФорма.Прочитать();
   ЭтаФорма.Записать();
КонецПроцедуры

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Попробовал метод прочитать(), почему то не обновляет, хотя, при открытии документа заново документа данные обновились
&НаКлиенте
Процедура ПрочитатьВ(Команда)
   ЭтаФорма.Прочитать();
   ЭтаФорма.Записать();
КонецПроцедуры

Тут могут работать "фишки" 8.2 на тему клиент-сервер.
По Прочитать() происходит считывание данных документа из ИБ.
Возможно это на клиенте не делается...
Путнее добавить пока не могу - с 8.2 только начинаю дружить...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 285
Последний ответ 21 Сен 2017, 10:33
от Insider
Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 7577
Последний ответ 16 Авг 2012, 21:50
от Will
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4813
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3408
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4986
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 188
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal