Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2016, 16:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Регистр сведений. Удаление записей.  (Прочитано 322 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Igor100500

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте
Суть в том что нужно удалить все записи регистра который (не используется)УдалитьНалоги
Из-за его записей не получается обновить конфигурацию.
Регистр независимый

&НаСервере
Процедура ОчиститьНаСервере()

Выборка = справочники.УдалитьВиды.Выбрать();
Пока Выборка.Следующий() Цикл
НаборЗаписей = РегистрыСведений.УдалитьВычеты.СоздатьНаборЗаписей();
// НаборЗаписей = РегистрыСведений["УдалитьВычеты"].СоздатьНаборЗаписей();
НаборЗаписей.Отбор.КодДохода.Установить(Выборка.Ссылка);
НаборЗаписей.Записать(Истина);
КонецЦикла

КонецПроцедуры

&НаКлиенте
Процедура Очистить(Команда)
ОчиститьНаСервере();
КонецПроцедуры

ну собственно ничего такого тут нет.
При выполнении обработки возникает ошибка - НаборЗаписей.Записать(Истина)
По причине:
Не удалось записать: "(не используется) УдалитьВычеты"!
И далее
редактирование общих данных запрещено

Ну(права проверил, в регистре под моими правами все разрешено(редактирование и т.д), а по факту ничего не могу изменить)
Ссылок на него нет.
В чем может быть проблема?
1С 8.3 Упр. формы.


Оффлайн alexandr_ll

  • ***
  • Сообщений: 173
  • РЕПУТАЦИЯ: 21
  • КПД: 12%
  • Регистрация: 2016-08-23
  • Сайт: 
  • Профессия: Программист 1С
Как-то странно вы удаляете записи регистра.
Я бы написал так:
    Выборка = РегистрыСведений.УдалитьВычеты.Выбрать();
    Пока Выборка.Следующий() Цикл
        // удаление существующей
        Выборка.ПолучитьМенеджерЗаписи().Удалить();
 
    КонецЦикла;
Посмотрите еще здесь: http://forum.infostart.ru/forum87/topic133216/

Оффлайн ДенисЧ

  • **
  • Сообщений: 63
  • РЕПУТАЦИЯ: 9
  • КПД: 14%
  • Регистрация: 2016-09-14
  • Сайт: 
НаборЗаписей = РегистрыСведений.УдалитьВычеты.СоздатьНаборзаписей();
НаборЗаписей.Записать(Истина);
Добавлено: 28 Сен 2016, 14:11

Как-то странно вы удаляете записи регистра.
Я бы написал так:
    Выборка = РегистрыСведений.УдалитьВычеты.Выбрать();
    Пока Выборка.Следующий() Цикл
        // удаление существующей
        Выборка.ПолучитьМенеджерЗаписи().Удалить();
 
    КонецЦикла;

А вот я бы не делал... Это извращение

Оффлайн Igor100500

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
Как-то странно вы удаляете записи регистра.
Я бы написал так:
    Выборка = РегистрыСведений.УдалитьВычеты.Выбрать();
    Пока Выборка.Следующий() Цикл
        // удаление существующей
        Выборка.ПолучитьМенеджерЗаписи().Удалить();
 
    КонецЦикла;
Посмотрите еще здесь: http://forum.infostart.ru/forum87/topic133216/

А что такое Выборка. ПолучитьМенеджерЗаписи()
там вообще нету такого метода

Оффлайн alexandr_ll

  • ***
  • Сообщений: 173
  • РЕПУТАЦИЯ: 21
  • КПД: 12%
  • Регистрация: 2016-08-23
  • Сайт: 
  • Профессия: Программист 1С
НаборЗаписей = РегистрыСведений.УдалитьВычеты.СоздатьНаборзаписей();
НаборЗаписей.Записать(Истина);
Согласен. так проще. Как-то не пришло в голову!


Добавлено: 28 Сен 2016, 14:27

А что такое Выборка. ПолучитьМенеджерЗаписи()
там вообще нету такого метода

Смотри Синтакс-помощник ПолучитьМенеджерЗаписи

Оффлайн Igor100500

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
НаборЗаписей = РегистрыСведений.УдалитьВычеты.СоздатьНаборзаписей();
НаборЗаписей.Записать(Истина);
Добавлено: 28 Сен 2016, 14:11

Как-то странно вы удаляете записи регистра.
Я бы написал так:
    Выборка = РегистрыСведений.УдалитьВычеты.Выбрать();
    Пока Выборка.Следующий() Цикл
        // удаление существующей
        Выборка.ПолучитьМенеджерЗаписи().Удалить();
 
    КонецЦикла;

А вот я бы не делал... Это извращение
у меня так изначально было)))
Добавлено: 29 Сен 2016, 10:09

вообщем, решил проблему:
&НаСервере 
Процедура ОчиститьНаСервере()

НаборЗаписей = РегистрыСведений[объект.ВведитеИмяРегистра].СоздатьНаборЗаписей();
НаборЗаписей.ОбменДанными.Загрузка=Истина;
НаборЗаписей.Записать(Истина);
КонецПроцедуры

&НаКлиенте
Процедура Очистить(Команда)
ОчиститьНаСервере();
КонецПроцедуры

Последний раз редактировалось: Igor100500; 29 Сен 2016, 10:09. Причина: Объединение сообщений


Теги:
 

Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2657
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4688
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 5282
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Проверка на "новую" запись в рег. сведений

Автор nomer13Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 9730
Последний ответ 11 Янв 2011, 10:04
от nomer13
Регистры накопления, Регистры сведений, Документы, Проведение

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 4988
Последний ответ 17 Янв 2014, 21:52
от kot_oo

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
72 Сообщений
alex0402
57 Сообщений
cska-fanat-kz cska-fanat-kz
50 Сообщений
Kironten
49 Сообщений
LexaK
32 Сообщений
alexandr_ll
30 Сообщений
sertak sertak
26 Сообщений
djkeysi
24 Сообщений
BuhRust
23 Сообщений
Андрей1966
21 Сообщений

* Кто онлайн

  • Точка Гостей: 242
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal