Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2016, 12:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема в конфигурировании 1С:Предприятие 8.1.  (Прочитано 222 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Eugene Obukhov

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-27
  • Сайт: 
Добрый день форумчанам. Проблема, перед которой я встал, скорее всего окажется из разряда пустяковых.
1С:Предприятие 8.1.
Есть необходимость изменить обработку "Печать ценников". Обработка нестандартная, взята из интернета, называется "Печать_ценников_две_цены", здесь она должна быть знакома. Так вот, стоит задача сделать возможным выбор макета, идущего на печать.

В Форму добавлено поле выбора выпадающим списком "ВыборМакета", ссылающееся на созданный реквизит этой формы "ВыборМакета" с типом данных "Произвольный".



В процедуру "При открытии" модуля формы добавлен следующий код:
// Обработчик события "ПриОткрытии" формы.
Процедура ПриОткрытии()
...
...
...
ЭлементыФормы.ВыборМакета.СписокВыбора.Добавить(0, "ОбычныйДвеЦены");
ЭлементыФормы.ВыборМакета.СписокВыбора.Добавить(1, "АкцияДвеЦены");
ЭлементыФормы.ВыборМакета.СписокВыбора.Добавить(2, "БольшойДвеЦены");
ЭлементыФормы.ВыборМакета.СписокВыбора.Добавить(3, "БольшойАкцияДвеЦены");
ЭлементыФормы.ВыборМакета.Значение=0;


КонецПроцедуры // ПриОткрытии()


Модуль объекта не менялся, в нем есть следующие строки:

Функция ПечатьЦенника() Экспорт
...
...
...
ТабДокумент                     = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Ценник";
Макет                           = ПолучитьМакет("Ценник");
ОбластьЦенника                  = Макет.ПолучитьОбласть("Строка|Столбец");

Я так понимаю, что нужно всего лишь изменить аргумент для ПолучитьМакет("Ценник") на выбранное в поле выбора на форме значение, но как это сделать не знаю.
Помогите в моем затыке.


Оффлайн Всеволод Коваленко

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 1
  • КПД: 20%
  • Регистрация: 2016-09-07
  • Сайт: 
Наверное
ТабДокумент = Новый ТабличныйДокумент;
Если ЭлементыФормы.ВыборМакета.Значение=0 Тогда
    Макет = ПолучитьМакет("Обычный");
КонецЕсли;
Если ЭлементыФормы.ВыборМакета.Значение=1 Тогда
    Макет = ПолучитьМакет("Акция");
КонецЕсли;
Если ЭлементыФормы.ВыборМакета.Значение=2 Тогда
    Макет = ПолучитьМакет("Большой");
КонецЕсли;
Если ЭлементыФормы.ВыборМакета.Значение=3 Тогда
    Макет = ПолучитьМакет("БольшойАкция");
КонецЕсли;
ОбластьЦенника = Макет.ПолучитьОбласть("Строка|Столбец");
Ну и макетов соответственно добавить.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5740
  • РЕПУТАЦИЯ: 1094
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Всеволод Коваленко,
Если ЭлементыФормы.ВыборМакета.Значение=0 Тогда
"ЭлементыФормы" не видно в модуле объекта

Eugene Obukhov,
надо реквизит ВидМакета сделать реквизитом не формы, а самой обработки.
тогда
    Если ВыборМакета = 0 Тогда
        Макет = ПолучитьМакет("Макет0");
    ИначеЕсли ВыборМакета = 1 Тогда
        Макет = ПолучитьМакет("Макет1");
    ......
    КонецЕсли;

Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ДенисЧ

  • **
  • Сообщений: 63
  • РЕПУТАЦИЯ: 9
  • КПД: 14%
  • Регистрация: 2016-09-14
  • Сайт: 
а почему
ЭлементыФормы.ВыборМакета.СписокВыбора.Добавить(0, "ОбычныйДвеЦены");

а не ЭлементыФормы.ВыборМакета.СписокВыбора.Добавить("ОбычныйДвеЦены");

и потом просто получитьмакет(ЗначениеВыбора) ?

Оффлайн Eugene Obukhov

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-27
  • Сайт: 
Проблема решена следующим образом.
Данные выпадающий список на форме ВыборМакета теперь берет данные из реквизита объекта.

Модуль Формы остался без изменений, приведу код на всякий случай еще раз:
// Обработчик события "ПриОткрытии" формы.
Процедура ПриОткрытии()
...
...
...
    ЭлементыФормы.ВыборМакета.СписокВыбора.Добавить(0, "ОбычныйДвеЦены");
    ЭлементыФормы.ВыборМакета.СписокВыбора.Добавить(1, "АкцияДвеЦены");
    ЭлементыФормы.ВыборМакета.СписокВыбора.Добавить(2, "БольшойДвеЦены");
    ЭлементыФормы.ВыборМакета.СписокВыбора.Добавить(3, "БольшойАкцияДвеЦены");
    ЭлементыФормы.ВыборМакета.Значение=0;
   
КонецПроцедуры // ПриОткрытии()

В модуль объекта добавлен следующий код:
ТабДокумент                     = Новый ТабличныйДокумент;
ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Ценник";
Если ВыборМакета = 0 Тогда
Макет = ПолучитьМакет("ОбычныйДвеЦены")
КонецЕсли;
Если ВыборМакета = 1 Тогда
Макет = ПолучитьМакет("АкцияДвеЦены")
КонецЕсли;
Если ВыборМакета = 2 Тогда
Макет = ПолучитьМакет("БольшойДвеЦены")
КонецЕсли;
Если ВыборМакета = 3 Тогда
Макет = ПолучитьМакет("БольшойАкцияДвеЦены")
КонецЕсли;
ОбластьЦенника                  = Макет.ПолучитьОбласть("Строка|Столбец");

Созданы макеты. Вот. Все работает.
Всем большое спасибо.


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 593
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3683
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1034
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2684
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2835
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
72 Сообщений
alex0402
57 Сообщений
cska-fanat-kz cska-fanat-kz
50 Сообщений
Kironten
49 Сообщений
LexaK
32 Сообщений
alexandr_ll
30 Сообщений
sertak sertak
26 Сообщений
djkeysi
24 Сообщений
BuhRust
23 Сообщений
Андрей1966
21 Сообщений

* Кто онлайн

  • Точка Гостей: 255
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal