Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
08 Дек 2016, 12:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывести данные выделенной строки  (Прочитано 225 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Space_minus

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-17
  • Сайт: 
  • Профессия: Ученик 1С
Здраствуйте подскажите как вывести данные только выделенной строки.
длоя каждой строки есть функция "Для каждой из цикл", а есть такая же же для текущей?
ТчСтуденты = РезультатЗапроса.Ссылка.СписокСтудентов;
ОбластьМакета = Макет.ПолучитьОбласть("ДанныеМедСправка");
 
 Для каждого Строка Из ТчСтуденты Цикл
для
МассивКатегорий = Новый Массив;
А = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_А;
Б = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_B;
С = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_C;
Д = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_D;
БЕ = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_BE;
СЕ = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_CE;
ДЕ = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_DE;
ТМ = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_TM;
ТБ = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_TB;
М = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_M;
А1 = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_A1;
Б1 = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_B1;
С1 = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_C1;
Д1 = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_D1;
С1Е = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_C1E;
Д1Е = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_D1E;
Если А  = Истина Тогда
МассивКатегорий.Добавить("A");
КонецЕсли;
Если  Б  = Истина Тогда
МассивКатегорий.Добавить("B");
КонецЕсли;
Если  С  = Истина Тогда
МассивКатегорий.Добавить("С");
КонецЕсли;
Если  Д  = Истина Тогда
МассивКатегорий.Добавить("D");
КонецЕсли;
Если  БЕ  = Истина Тогда
МассивКатегорий.Добавить("BE");
КонецЕсли;
Если  СЕ  = Истина Тогда
МассивКатегорий.Добавить("СЕ");
КонецЕсли;
Если  ДЕ  = Истина Тогда
МассивКатегорий.Добавить("DE");
КонецЕсли;
Если  СЕ  = Истина Тогда
МассивКатегорий.Добавить("СЕ");
КонецЕсли;
Если  ДЕ  = Истина Тогда
МассивКатегорий.Добавить("DE");
КонецЕсли;
Если  ТМ  = Истина Тогда
МассивКатегорий.Добавить("ТМ");
КонецЕсли;
Если  ТБ  = Истина Тогда
МассивКатегорий.Добавить("TB");
КонецЕсли;
Если  М  = Истина Тогда
МассивКатегорий.Добавить("М");
КонецЕсли;
Если  А1  = Истина Тогда
МассивКатегорий.Добавить("А1");
КонецЕсли;
Если  Б1  = Истина Тогда
МассивКатегорий.Добавить("B1");
КонецЕсли;
Если  С1  = Истина Тогда
МассивКатегорий.Добавить("С1");
КонецЕсли;
Если  Д1  = Истина Тогда
МассивКатегорий.Добавить("D1");
КонецЕсли;
Если  С1Е  = Истина Тогда
МассивКатегорий.Добавить("С1Е");
КонецЕсли;
Если  Д1Е  = Истина Тогда
МассивКатегорий.Добавить("D1Е");
КонецЕсли;
А = "";
Для каждого Стр Из МассивКатегорий Цикл
А = А+", "+Стр;
КонецЦикла;
   Если Не ПустаяСтрока(А) Тогда
   ОбластьМакета.Параметры.МедКатегория = ""+Сред(А,3,СтрДлина(А));
   Иначе
   ОбластьМакета.Параметры.МедКатегория = "";

   КонецЕсли;
    ТабДок.Вывести(ОбластьМакета);



Оффлайн LexaK

  • *****
  • Сообщений: 1037
  • РЕПУТАЦИЯ: 273
  • КПД: 26%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
лкСтрока = Элементы.ВашаТЧ.ТекущиеДанные;

из строчки получаете нужные значения и передаете их в виде параметров в процедуру

ВывестиОтчет(лкСтрока.Студент);
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Space_minus

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-17
  • Сайт: 
  • Профессия: Ученик 1С
лкСтрока = Элементы.ВашаТЧ.ТекущиеДанные;

из строчки получаете нужные значения и передаете их в виде параметров в процедуру

ВывестиОтчет(лкСтрока.Студент);

Расскажи по подробнее, пожалуйста

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ***
  • Сообщений: 173
  • РЕПУТАЦИЯ: 24
  • КПД: 14%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
А = Строка.ФИО_Студента.ФизЛицо.Категория_Мед_Справки_А;
Категорию надо в запросе получать, у вас тут на каждой строке запрос к базе из-за доступа через точку.

На форме получаете ссылку на студента или его ФИО из ТекущиеДанные, как выше написано (смотря что там у вас).
И либо в запрос передаете для отбора, либо внутри цикла сравниваете с полем из результата запроса, и если не совпало, тогда продолжить цикл.


Теги:
 

Как перенести данные из 7.7 типовая УСН 1.3 в 1С 8 типовая бухгалтерия

Автор Александр бухгалтерРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3251
Последний ответ 13 Фев 2010, 07:58
от Александр бухгалтер
"Лишние" данные в зарплате

Автор Мария_ХРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 1798
Последний ответ 05 Апр 2014, 11:11
от Славянка
"Данные по коду не найдены"

Автор elteawРаздел Пользователям "1С - Предприятие 8"

Ответов: 6
Просмотров: 4463
Последний ответ 03 Дек 2015, 13:58
от Timofey Gurubanov
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3615
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz
Переносятся ли данные из программы "1С:Торговля и склад" в

Автор nyukРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3136
Последний ответ 25 Июл 2008, 15:26
от DDD

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
80 Сообщений
cska-fanat-kz cska-fanat-kz
70 Сообщений
Kironten
52 Сообщений
alex0402
47 Сообщений
LexaK
34 Сообщений
alexandr_ll
34 Сообщений
Андрей1966
24 Сообщений
djkeysi
24 Сообщений
sertak sertak
23 Сообщений
BuhRust
22 Сообщений

* Кто онлайн

  • Точка Гостей: 812
  • Точка Скрытых: 0
  • Точка Пользователей: 15
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal