Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
09 Дек 2016, 14:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с группировкой данных  (Прочитано 212 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ditli

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-26
  • Сайт: 
Всем привет!

Помогите пожалуйста с группировкой данных, есть отчет не на скд, в нем детально отображаются данные, необходимо сгруппировать данные по дате, номеру и счету.
Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ЕПСБУДвиженияССубконто.Регистратор,
      |   ЕПСБУДвиженияССубконто.Период,
      |   ЕПСБУДвиженияССубконто.СчетДт,
      |   ЕПСБУДвиженияССубконто.СчетКт,
      //|   ЕПСБУДвиженияССубконто.КВД,
      //|   ЕПСБУДвиженияССубконто.КБКДт,
      |   ЕПСБУДвиженияССубконто.Сумма КАК Сумма,
      |   ЕПСБУДвиженияССубконто.ДатаПервичногоДокумента,
      |   ЕПСБУДвиженияССубконто.НомерПервичногоДокумента,
      |   ЕПСБУДвиженияССубконто.ХарактеристикаДвиженияДт,
      |   ЕПСБУДвиженияССубконто.ХарактеристикаДвиженияКт,
      |   ЕПСБУДвиженияССубконто.СубконтоДт1,
      |   ЕПСБУДвиженияССубконто.СубконтоКт1
      |ИЗ
      |   РегистрБухгалтерии.ЕПСБУ.ДвиженияССубконто(&НачПериода, &КонПериода, , , ) КАК ЕПСБУДвиженияССубконто
      |ГДЕ
      |   ((ЕПСБУДвиженияССубконто.СчетДт = &СчетДт
      |            И ЕПСБУДвиженияССубконто.ХарактеристикаДвиженияДт = &ХарактеристикаДвижения
      |            И ЕПСБУДвиженияССубконто.СубконтоДт1 = &КЭК)
      |         ИЛИ (ЕПСБУДвиженияССубконто.СчетКт = &СчетКт
      |            И ЕПСБУДвиженияССубконто.ХарактеристикаДвиженияКт = &ХарактеристикаДвижения
      |            И ЕПСБУДвиженияССубконто.СубконтоКт1 = &КЭК))";
   
       
      
   Запрос.УстановитьПараметр("КонПериода", КонПериода);
   Запрос.УстановитьПараметр("НачПериода", НачПериода);

   Запрос.УстановитьПараметр("СчетДт", ПланыСчетов.ЕПСБУ.РасходыТекущегоГода);
   Запрос.УстановитьПараметр("СчетКт", ПланыСчетов.ЕПСБУ.РасходыТекущегоГода);
   Запрос.УстановитьПараметр("КЭК", Справочники.КОСГУ.НайтиПоКоду("241"));
   Запрос.УстановитьПараметр("ХарактеристикаДвижения", фКонтрагент);

   Результат = Запрос.Выполнить();
   
   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   ОбластьШапкаТаблицы1 = Макет.ПолучитьОбласть("ШапкаТаблицы1");
   ОбластьОборотыДокумента1 = Макет.ПолучитьОбласть("ОборотыДокумента1");
      ОбластьИтогОборотов1 = Макет.ПолучитьОбласть("ИтогОборотов1");
   ОбластьСверткаОборотов1 = Макет.ПолучитьОбласть("СверткаОборотов1");
   ОбластьСальдоКонечное1 = Макет.ПолучитьОбласть("СальдоКонечное1");
   ОбластьПусто = Макет.ПолучитьОбласть("Пусто");
   ОбластьШапкаТаблицы2 = Макет.ПолучитьОбласть("ШапкаТаблицы2");
   ОбластьОборотыДокумента2 = Макет.ПолучитьОбласть("ОборотыДокумента2");
   ОбластьИтогОборотов2 = Макет.ПолучитьОбласть("ИтогОборотов2");
   ОбластьСверткаОборотов2 = Макет.ПолучитьОбласть("СверткаОборотов2");
   ОбластьСальдоКонечное2 = Макет.ПолучитьОбласть("СальдоКонечное2");
   ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
   

   ТабДок = Новый ТабличныйДокумент;
   ТабДок.ПолеСлева = 10;
   ТабДок.ПолеСправа = 10;   
   ТабДок.АвтоМасштаб=Истина;
   
   ТабДок.Очистить();

   ОбластьЗаголовок.Параметры.Контрагенты=фКонтрагент.НаименованиеПолное;//ВыборкаОбщийИтог.Контрагент;
   ОбластьЗаголовок.Параметры.НачПериода=формат(НачПериода,"ДЛФ=ДД");
   ОбластьЗаголовок.Параметры.КонПериода=формат(КонПериода,"ДЛФ=ДД");
   ТабДок.Вывести(ОбластьЗаголовок);
   ТабДок.Вывести(ОбластьШапкаТаблицы1);
   ТабДок.НачатьАвтогруппировкуСтрок();   
   

   Ном=0;       
   ДтСуммаИтог=0;
   КтСуммаИтог=0;
   
   ВыборкаДетальныеЗаписи = Результат.Выбрать();

   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            
      Ном=Ном+1;   
      
      ОбластьОборотыДокумента1.Параметры.Ном=Ном;
      ОбластьОборотыДокумента1.Параметры.ДатаПервичногоДокумента=СокрЛП (формат(ВыборкаДетальныеЗаписи.Регистратор.Дата,"ДЛФ=Д"));
      ОбластьОборотыДокумента1.Параметры.НомерПервичногоДокумента=СокрЛП (формат(ВыборкаДетальныеЗаписи.Регистратор.Номер));
      ОбластьОборотыДокумента1.Параметры.СчетКт=СокрЛП(ВыборкаДетальныеЗаписи.СчетКт.Код);
      Если ВыборкаДетальныеЗаписи.СчетДт=ПланыСчетов.ЕПСБУ.РасходыТекущегоГода Тогда
         ОбластьОборотыДокумента1.Параметры.ДтСумма=ВыборкаДетальныеЗаписи.Сумма;
         ОбластьОборотыДокумента1.Параметры.КтСумма=0;         
         ДтСуммаИтог=ДтСуммаИтог+ВыборкаДетальныеЗаписи.Сумма;      
      КонецЕсли;
      Если ВыборкаДетальныеЗаписи.СчетКт=ПланыСчетов.ЕПСБУ.РасходыТекущегоГода Тогда
         ОбластьОборотыДокумента1.Параметры.КтСумма=ВыборкаДетальныеЗаписи.Сумма;
         ОбластьОборотыДокумента1.Параметры.ДтСумма=0;
         КтСуммаИтог=КтСуммаИтог+ВыборкаДетальныеЗаписи.Сумма;         
      КонецЕсли;
      
      
      ТабДок.Вывести(ОбластьОборотыДокумента1);
     КонецЦикла;
   ОбластьИтогОборотов1.Параметры.ДтСуммаИтог=формат(ДтСуммаИтог,"ЧЦ=10; ЧДЦ=2");
   ОбластьИтогОборотов1.Параметры.КтСуммаИтог=формат(КтСуммаИтог,"ЧЦ=10; ЧДЦ=2");
   
   ТабДок.Вывести(ОбластьИтогОборотов1);
Перечитала полно всего, но не могу найти ничего дельного:(


Оффлайн alexandr_ll

  • ***
  • Сообщений: 173
  • РЕПУТАЦИЯ: 21
  • КПД: 12%
  • Регистрация: 2016-08-23
  • Сайт: 
  • Профессия: Программист 1С
Выгрузите результаты запроса в таблицу значений и сверните ее по нужным колонкам.

Оффлайн Ditli

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-26
  • Сайт: 
Спасибо за подсказку, сейчас попробую:)
Добавлено: 27 Сен 2016, 09:45

Доброе утро!
Проблему решила, как оказалось все проще:
В запросе добавила сгрупировать по, и все сворачивается как надо:)
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ЕПСБУДвиженияССубконто.Регистратор,
      |   ЕПСБУДвиженияССубконто.Период,
      |   ЕПСБУДвиженияССубконто.СчетДт,
      |   ЕПСБУДвиженияССубконто.СчетКт,
      //|   ЕПСБУДвиженияССубконто.КВД,
      //|   ЕПСБУДвиженияССубконто.КБКДт,
      |   Сумма(ЕПСБУДвиженияССубконто.Сумма) КАК Сумма,
      |   ЕПСБУДвиженияССубконто.Содержание,
      |   ЕПСБУДвиженияССубконто.ХарактеристикаДвиженияДт,
      |   ЕПСБУДвиженияССубконто.ХарактеристикаДвиженияКт,
      |   ЕПСБУДвиженияССубконто.СубконтоДт1,
      |   ЕПСБУДвиженияССубконто.СубконтоКт1
      |ИЗ
      |   РегистрБухгалтерии.ЕПСБУ.ДвиженияССубконто(&НачПериода, &КонПериода, , , ) КАК ЕПСБУДвиженияССубконто
      |ГДЕ
      |   ((ЕПСБУДвиженияССубконто.СчетДт = &СчетДт
      |            И ЕПСБУДвиженияССубконто.ХарактеристикаДвиженияДт = &ХарактеристикаДвижения
      |            )
      |         ИЛИ (ЕПСБУДвиженияССубконто.СчетКт = &СчетКт
      |            И ЕПСБУДвиженияССубконто.ХарактеристикаДвиженияКт = &ХарактеристикаДвижения
      |            ))
      |СГРУППИРОВАТЬ ПО
      |   ЕПСБУДвиженияССубконто.Регистратор,
      |   ЕПСБУДвиженияССубконто.СчетДт,
      |   ЕПСБУДвиженияССубконто.СчетКт,
      |   ЕПСБУДвиженияССубконто.Период,
      |   ЕПСБУДвиженияССубконто.Содержание,
      |   ЕПСБУДвиженияССубконто.СубконтоДт1,
      |   ЕПСБУДвиженияССубконто.СубконтоКт1,
      //|   ЕПСБУДвиженияССубконто.КВД,
      //|   ЕПСБУДвиженияССубконто.КБКДт,
      |   ЕПСБУДвиженияССубконто.ХарактеристикаДвиженияДт,
      |   ЕПСБУДвиженияССубконто.ХарактеристикаДвиженияКт";
   Вдруг кому поможет:)         

Последний раз редактировалось: Ditli; 27 Сен 2016, 09:45. Причина: Объединение сообщений


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1398
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3401
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3666
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1466
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 109
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

Программист 1С от HR-PT
[08 Дек 2016, 14:23]


Программист 1с 8 от dima_d
[06 Дек 2016, 15:25]

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
77 Сообщений
cska-fanat-kz cska-fanat-kz
62 Сообщений
Kironten
56 Сообщений
alex0402
52 Сообщений
alexandr_ll
37 Сообщений
LexaK
34 Сообщений
sertak sertak
26 Сообщений
Андрей1966
24 Сообщений
djkeysi
24 Сообщений
BuhRust
23 Сообщений

* Кто онлайн

  • Точка Гостей: 704
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal