Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Авг 2017, 00:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Внешняя обработка загрузка справочников (xml)  (Прочитано 329 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dimid

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-26
  • Сайт: 
  • Профессия: Ученик 1С
Нужна помощь! 1С 8.3 Турагенство. Внешняя разработка для загрузки файла "Типы питания.xml". (база тестовая. создали новые справочники и вот один из них "типыПитания". Ошибок никаких не выдает. просто никакой реакции.

&НаСервере
Процедура Команда1НаСервере();
мДОМ=новый ПостроительDOM;
чтение=Новый ЧтениеXML ;
чтение.ОткрытьФайл(Объект.ПутьКФайлу);
мДокументДОМ=мДОМ.Прочитать(чтение);
чтение.Закрыть();
мРазыменовательПИ=мДокументДОМ.СоздатьРазыменовательПИ(мДокументДОМ);
мЗапрос="/result/meals";
мХПуть=мДокументДОМ.СоздатьВыражениеXPath(мЗапрос,мРазыменовательПИ);
мРезультат=мХПуть.Вычислить(мДокументДОМ);
мРодитель=мРезультат.ПолучитьСледующий();
первый = Истина;
пока мРодитель<>неопределено цикл


мЗапрос="./*";
    мХПуть2=мДокументДОМ.СоздатьВыражениеXPath(мЗапрос,мРазыменовательПИ);
    мДанные=новый Структура;
    мРезультатЗапроса=мХПуть2.Вычислить(мРодитель);
    мОбход=мРезультатЗапроса.ПолучитьСледующий();
    пока мОбход <>неопределено цикл   

мДанные.Вставить(мОбход.ИмяЭлемента,мОбход.ТекстовоеСодержимое);
мОбход=мРезультатЗапроса.ПолучитьСледующий();
КонецЦикла;

Имя=мДанные.name;
Спр=Справочники.ТА_ТипыПитания.СоздатьЭлемент();
если первый тогда
Спр.name=Имя;
первый = ложь;
КонецЕсли;
Спр.Записать();

мРодитель=мРезультат.ПолучитьСледующий();
КонецЦикла;

        КонецПроцедуры

После точки останова вот в этом месте пишет: 
мРодитель=мРезультат.ПолучитьСледующий();
мРодитель неопределено. и конецПроцедуры.
 


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
132 Сообщений
alex0402
59 Сообщений
AIFrame
52 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
27 Сообщений
pavl_vs
25 Сообщений
Kironten
24 Сообщений
Golickoff Golickoff
18 Сообщений
Александр Лахтин Александр Лахтин
18 Сообщений
xproh
16 Сообщений

* Кто онлайн

  • Точка Гостей: 131
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal