Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
18 сен 2021, 02:46

Получить значение ячейки Табличного поля

Автор nadysaan, 21 сен 2016, 16:34

0 Пользователей и 1 гость просматривают эту тему.

nadysaan

Добрый день. Выгружаю данные табличного поля в ексель. Колонок более 100, но надо выгружать только те у которых видимость = истина.
Как получить значение ячейки, чтобы выгрузить это значение в ексель. ЭлементыФормы.ТабличноеПолеТовары.Значение.[ИмяКолонки] - здесь надо указывать конкретную колонку, а не переменную в которой я сохраняю имя колонки.

   Для Каждого КолонкиТоваров Из ЭлементыФормы.ТабличноеПолеТовары.Колонки Цикл
      Если КолонкиТоваров.Видимость Тогда
         ИмяКолонки = КолонкиТоваров.Имя;
         Лист.Cells(1,НомерКолонки).Value = КолонкиТоваров.ТекстШапки;
         Для i = 2 ПО КоличествоСтрок Цикл
             Лист.Cells(i,НомерКолонки).Value =  ЭлементыФормы.ТабличноеПолеТовары.Значение.[ИмяКолонки]
         КонецЦикла;
           НомерКолонки = НомерКолонки + 1;
      КонецЕсли;
   КонецЦикла;
Спасибо все огромное.

LexaK

 а зачем так? в табличного документа есть отличный метод Записать
который может записывать данные в следующих форматах
ТипФайлаТабличногоДокумента (SpreadsheetDocumentFileType)
Значения

ANSITXT (ANSITXT)
DOCX (DOCX)
HTML (HTML)
HTML3 (HTML3)
HTML4 (HTML4)
HTML5 (HTML5)
MXL (MXL)
MXL7 (MXL7)
ODS (ODS)
PDF (PDF)
TXT (TXT)
XLS (XLS)
XLS95 (XLS95)
XLS97 (XLS97)
XLSX (XLSX)

см. СП
ответ Понравился? (в смысле пригодился?)

nadysaan

мне не надо выгружать все колонки табличного поля, в только те которые выбрал пользователь в настройках

LexaK

Цитироватьмне не надо выгружать все колонки табличного поля, в только те которые выбрал пользователь в настройках

так скопируйте их из одного ТД в другой ТД(ну плевое дело скопировать область(и)) и сохраните новый ТД в Ексель, одной командой!

но уж если очень хочется то попробуйте так
...
Лист.Cells(i,НомерКолонки).Value =  ЭлементыФормы.ТабличноеПолеТовары.область(НомерСтроки,НомерКолонки).Текст;


ответ Понравился? (в смысле пригодился?)

nadysaan

Спасибо, но ЭлементыФормы.ТабличноеПолеТовары.область - метод не обнаружен

LexaK

так это ваш же код, говорю все у вас не просто
естественно метод Область надо брать от ТабличногоДокумента, как он у вас называется я не знаю, поэтому привел ваш код.
попробуйте так

Лист.Cells(i,НомерКолонки).Value =  ТабличноеПолеТовары.область(НомерСтроки,НомерКолонки).Текст; //или что там у вас вместо ТабличноеПолеТовары?
ответ Понравился? (в смысле пригодился?)

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск