Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
06 Дек 2016, 20:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Объеденение документов в один в 1с 7.7  (Прочитано 310 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Кот Никита

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-21
  • Сайт: 
  • Профессия: Программист 7.7
Здравствуйте!Помогите_Пожалуйста. Задача: в форме документа добавлена кнопка консалидация. при нажатии кнопки отображается журнал с документами данного типа. необходимо:  1. что бы в этом журнале были не все документы, а по заданным параметрам, которые есть в самом документе. 2. Что бы можно было выбрать определенные документы в журнале и при нажатии кнопки консалидировать. данные документы объеденялись в один, а те которые выделены удалились. сложно. не могу разобраться. Помогите пожалуйста!

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн ДенисЧ

  • **
  • Сообщений: 63
  • РЕПУТАЦИЯ: 9
  • КПД: 14%
  • Регистрация: 2016-09-14
  • Сайт: 
Запросом по параматреам отобрать документы, вывести их в ТЗ с пометками.
Потом пробежаться по Тз, объединить отмеченные, записать новый, а старые пометить на удаление.

Оффлайн Кот Никита

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-21
  • Сайт: 
  • Профессия: Программист 7.7
Запросом по параматреам отобрать документы, вывести их в ТЗ с пометками.
Потом пробежаться по Тз, объединить отмеченные, записать новый, а старые пометить на удаление.
Хорошая идея по ТЗ. сразу не подумал. Только необходимо не все доки с одинаковыми параметрами, а пользователь должен выбрать сам. Как произвести выборку в журнале? Спасибо за ответ!
Добавлено: 21 Сен 2016, 13:05

Здравствуйте!Помогите_Пожалуйста. Задача: в форме документа добавлена кнопка консалидация. при нажатии кнопки отображается журнал с документами данного типа. необходимо:  1. что бы в этом журнале были не все документы, а по заданным параметрам, которые есть в самом документе. 2. Что бы можно было выбрать определенные документы в журнале и при нажатии кнопки консалидировать. данные документы объеденялись в один, а те которые выделены удалились. сложно. не могу разобраться. Помогите пожалуйста!
Думаю что через документ который будет выносится на основании этого будет легче сделать.

Последний раз редактировалось: Кот Никита; 21 Сен 2016, 13:05. Причина: Объединение сообщений

Оффлайн ДенисЧ

  • **
  • Сообщений: 63
  • РЕПУТАЦИЯ: 9
  • КПД: 14%
  • Регистрация: 2016-09-14
  • Сайт: 
Цитировать
Как произвести выборку в журнале?

Аналогично. Выгрузить нужные документы в ТЗ и там отмечать

Оффлайн Кот Никита

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-21
  • Сайт: 
  • Профессия: Программист 7.7
Цитировать
Как произвести выборку в журнале?

Аналогично. Выгрузить нужные документы в ТЗ и там отмечать
Сорри. пока не могу понять как. 

Оффлайн ДенисЧ

  • **
  • Сообщений: 63
  • РЕПУТАЦИЯ: 9
  • КПД: 14%
  • Регистрация: 2016-09-14
  • Сайт: 
Что конкретно не понятно?
(с ТЗ я погорячился, может, подойдёт и список значений)

Например:

док = СоздатьОбъект("Документ.Приходная");
сз = СоздатьОбъект("списокЗначений");
док.ВыбратьДокументы('01.01.2016', '31.08.2016');
Пока док.ПолучитьДокумент() = 1 Цикл
  сз.ДобавитьЗначение(док.ТекущийДокумент());
КонецЦикла;
зн = "";
Если сз.ОтметитьЗначения(зн, "Выберите документы") = 1 Тогда
  для сч = 1 по сз.РазмерСпика() Цикл
    если сз.Пометка(сч) Тогда
        док = сз.ПолучитьЗначение(сч);
        Сообщить("отмечен " + док);
    КонецЕсли;
КОнецЕсли;


Это для выбора списка документов. Что ещё не понятно?

Оффлайн Кот Никита

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-21
  • Сайт: 
  • Профессия: Программист 7.7
Что конкретно не понятно?
(с ТЗ я погорячился, может, подойдёт и список значений)

Например:

док = СоздатьОбъект("Документ.Приходная");
сз = СоздатьОбъект("списокЗначений");
док.ВыбратьДокументы('01.01.2016', '31.08.2016');
Пока док.ПолучитьДокумент() = 1 Цикл
  сз.ДобавитьЗначение(док.ТекущийДокумент());
КонецЦикла;
зн = "";
Если сз.ОтметитьЗначения(зн, "Выберите документы") = 1 Тогда
  для сч = 1 по сз.РазмерСпика() Цикл
    если сз.Пометка(сч) Тогда
        док = сз.ПолучитьЗначение(сч);
        Сообщить("отмечен " + док);
    КонецЕсли;
КОнецЕсли;


Это для выбора списка документов. Что ещё не понятно?
спасибо! Завтра попробую. Только мне там ещё надо условие отбора в список значение вставить, с этим справлюсь. И при проводке нужно в текущий документ сложить данные с выделенных. Удалить выделенные.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
77 Сообщений
cska-fanat-kz cska-fanat-kz
67 Сообщений
alex0402
42 Сообщений
Kironten
42 Сообщений
alexandr_ll
34 Сообщений
LexaK
33 Сообщений
Андрей1966
26 Сообщений
djkeysi
24 Сообщений
sertak sertak
22 Сообщений
BuhRust
20 Сообщений

* Кто онлайн

  • Точка Гостей: 260
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal