Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2017, 10:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Рекурсия - ЗаполнитьЗначенияСвойств в ДеревоЗначений - пропадает иерархия  (Прочитано 415 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн метис метис

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-15
  • Сайт: 
1С 8.3 У.ф.: Рекурсией копирую значения свойств (ЗаполнитьЗначенияСвойств) из одного ДеревоЗначений в другое ДеревоЗначений (оба реквизиты формы, колонки реквизитов полностью совпадают) с условием:

Для Каждого СтрокаДерева Из Дерево Цикл
Если СтрокаДерева["Пометка"] = 1 Тогда
СтрокаНовая = ДеревоСПометкой.ПолучитьЭлементы().Добавить();
ЗаполнитьЗначенияСвойств(СтрокаНовая, СтрокаДерева);
КонецЕсли;

КоллекцияЭлементов = СтрокаДерева.ПолучитьЭлементы();

Если КоллекцияЭлементов.Количество() > 0 Тогда
ЗаполнениеНовогоДереваОбходом(КоллекцияЭлементов, ДеревоСПометкой);
КонецЕсли;
КонецЦикла;

Проблема в том, что в новом ДеревоЗначения (ДеревоСПометкой) пропадает иерархия, то есть, если его обходить рекурсией, то оно обходится как ТаблицаЗначений, то есть в коде:

КоллекцияЭлементов = СтрокаДереваCПометкой.ПолучитьЭлементы();
Если КоллекцияЭлементов.Количество() > 0 Тогда

далее КоллекцияЭлементов.Количество() никогда не становится больше нуля.
При этом преверял - все значения нового дерева заполнены, в т. ч. Родитель. Выдаются все элементы, но без иерархии.
Подскажите, пожалуйста, где я допустил ошибку?


Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ****
  • Сообщений: 260
  • РЕПУТАЦИЯ: 45
  • КПД: 17%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Лучше делать это на сервере с настоящим деревом (РеквизитФормыВЗначение и обратно).
Чтобы была иерархия, нужно создавать подчиненные элементы.

ЗаполнениеНовогоДереваОбходом(КоллекцияЭлементов, ДеревоСПометкой);
вместо ДеревоСПометкой поставить СтрокаНовая?

Оффлайн метис метис

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-15
  • Сайт: 
ЗаполнениеНовогоДереваОбходом(КоллекцияЭлементов, ДеревоСПометкой);
вместо ДеревоСПометкой поставить СтрокаНовая?
Оно,(как стыдно-то), большое спасибо!


Теги:
 

Пропадает "Договор Контрагента")

Автор GoodРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2817
Последний ответ 25 Янв 2010, 09:13
от Myti
Состояние("текст сообщения"); - очень быстро пропадает.

Автор snoop82Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1328
Последний ответ 16 Июл 2015, 08:28
от cska-fanat-kz
Проблема - пропадает только что введенный текст в актах поступления товаров

Автор SnakeSolidРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 653
Последний ответ 13 Апр 2015, 23:27
от MuI_I_Ika
После закрытия месяца пропадает на 41 счете сумма продукции

Автор Наталья СергеевнаРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4070
Последний ответ 26 Апр 2013, 17:36
от MuI_I_Ika
Документы покупателей -> Счет покупателю -> пропадает номер договора

Автор Maxim KaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 216
Последний ответ 25 Янв 2017, 03:41
от Геннадий ОбьГЭС

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
95 Сообщений
Dethmontt Dethmontt
67 Сообщений
alex0402
65 Сообщений
wise wise
63 Сообщений
MuI_I_Ika MuI_I_Ika
60 Сообщений
ilyay ilyay
39 Сообщений
Сергей Федоров Сергей Федоров
34 Сообщений
magnifico61
25 Сообщений
ilnur75
22 Сообщений
BuhRust
21 Сообщений

* Кто онлайн

  • Точка Гостей: 825
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal