Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Сен 2017, 16:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Рекурсия - ЗаполнитьЗначенияСвойств в ДеревоЗначений - пропадает иерархия  (Прочитано 592 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн метис метис

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-15
  • Сайт: 
1С 8.3 У.ф.: Рекурсией копирую значения свойств (ЗаполнитьЗначенияСвойств) из одного ДеревоЗначений в другое ДеревоЗначений (оба реквизиты формы, колонки реквизитов полностью совпадают) с условием:

Для Каждого СтрокаДерева Из Дерево Цикл
Если СтрокаДерева["Пометка"] = 1 Тогда
СтрокаНовая = ДеревоСПометкой.ПолучитьЭлементы().Добавить();
ЗаполнитьЗначенияСвойств(СтрокаНовая, СтрокаДерева);
КонецЕсли;

КоллекцияЭлементов = СтрокаДерева.ПолучитьЭлементы();

Если КоллекцияЭлементов.Количество() > 0 Тогда
ЗаполнениеНовогоДереваОбходом(КоллекцияЭлементов, ДеревоСПометкой);
КонецЕсли;
КонецЦикла;

Проблема в том, что в новом ДеревоЗначения (ДеревоСПометкой) пропадает иерархия, то есть, если его обходить рекурсией, то оно обходится как ТаблицаЗначений, то есть в коде:

КоллекцияЭлементов = СтрокаДереваCПометкой.ПолучитьЭлементы();
Если КоллекцияЭлементов.Количество() > 0 Тогда

далее КоллекцияЭлементов.Количество() никогда не становится больше нуля.
При этом преверял - все значения нового дерева заполнены, в т. ч. Родитель. Выдаются все элементы, но без иерархии.
Подскажите, пожалуйста, где я допустил ошибку?


Онлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ****
  • Сообщений: 365
  • РЕПУТАЦИЯ: 69
  • КПД: 19%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Лучше делать это на сервере с настоящим деревом (РеквизитФормыВЗначение и обратно).
Чтобы была иерархия, нужно создавать подчиненные элементы.

ЗаполнениеНовогоДереваОбходом(КоллекцияЭлементов, ДеревоСПометкой);
вместо ДеревоСПометкой поставить СтрокаНовая?

Оффлайн метис метис

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-15
  • Сайт: 
ЗаполнениеНовогоДереваОбходом(КоллекцияЭлементов, ДеревоСПометкой);
вместо ДеревоСПометкой поставить СтрокаНовая?
Оно,(как стыдно-то), большое спасибо!


Теги:
 

Пропадает "Договор Контрагента")

Автор GoodРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2999
Последний ответ 25 Янв 2010, 09:13
от Myti
Состояние("текст сообщения"); - очень быстро пропадает.

Автор snoop82Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1708
Последний ответ 16 Июл 2015, 08:28
от cska-fanat-kz
Проблема - пропадает только что введенный текст в актах поступления товаров

Автор SnakeSolidРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 745
Последний ответ 13 Апр 2015, 23:27
от MuI_I_Ika
После закрытия месяца пропадает на 41 счете сумма продукции

Автор Наталья СергеевнаРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4373
Последний ответ 26 Апр 2013, 17:36
от MuI_I_Ika
Документы покупателей -> Счет покупателю -> пропадает номер договора

Автор Maxim KaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 309
Последний ответ 25 Янв 2017, 03:41
от Геннадий ОбьГЭС

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
176 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
81 Сообщений
alex0402
80 Сообщений
AsadRoman
35 Сообщений
Kironten
34 Сообщений
ilyay ilyay
30 Сообщений
Golickoff Golickoff
29 Сообщений
AIFrame
27 Сообщений
BuhRust
26 Сообщений
Варвар
20 Сообщений

* Кто онлайн

  • Точка Гостей: 858
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal