Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Янв 2017, 00:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Счет-фактура добавить сразу несколько документов-основания  (Прочитано 669 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alexei1800

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-17
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите опять туплю
Докнов=Документсчетфактура.ДокументыОснования.Добавить();
докнов.ДокументОснование=ВыборкаДетальныеЗаписи.ссылкадок;
но нужно добавить не один документ основания, а несколько
нужно добавить 4 документа основания ВыборкаДетальныеЗаписи.ссылкадок
ВыборкаДетальныеЗаписи2.ссылкадок ВыборкаДетальныеЗаписи3.ссылкадок ВыборкаДетальныеЗаписи4.ссылкадок, как их добавить
если делаешь так документыоснования = ВыборкаДетальныеЗаписи.ссылкадок + ВыборкаДетальныеЗаписи2.ссылкадок; то выводит ошибку преобравзование к значению числу не выполнено



Оффлайн alex0402

  • ****
  • Сообщений: 314
  • РЕПУТАЦИЯ: 36
  • КПД: 11%
  • Регистрация: 2010-09-10
  • Сайт: 
Нельзя в реквизит типа Ссылка поместить больше одной ссфлки

Оффлайн alexei1800

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-17
  • Сайт: 
  • Профессия: Ученик 1С
Нельзя в реквизит типа Ссылка поместить больше одной ссфлки
там нет там не реквизит типо ссылка, я имею ввиду табличную часть документоснования, а там документ основание  тип у него состовной и когда вручную делаешь счет-фактуру, можно в документ-основания добавлять несколько документов основания

Оффлайн alex0402

  • ****
  • Сообщений: 314
  • РЕПУТАЦИЯ: 36
  • КПД: 11%
  • Регистрация: 2010-09-10
  • Сайт: 
Докнов=Документсчетфактура.ДокументыОснования.Добавить();
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка1;
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка2;
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка3;
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка4;

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Докнов=Документсчетфактура.ДокументыОснования.Добавить();
докнов.ДокументОснование=ВыборкаДетальныеЗаписи.ссылкадок;
Докнов=Документсчетфактура.ДокументыОснования.Добавить();
докнов.ДокументОснование=ВыборкаДетальныеЗаписи2.ссылкадок;
Докнов=Документсчетфактура.ДокументыОснования.Добавить();
докнов.ДокументОснование=ВыборкаДетальныеЗаписи3.ссылкадок;
Докнов=Документсчетфактура.ДокументыОснования.Добавить();
докнов.ДокументОснование=ВыборкаДетальныеЗаписи4.ссылкадок;
...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн LexaK

  • *****
  • Сообщений: 1084
  • РЕПУТАЦИЯ: 284
  • КПД: 26%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
блин ну что за бред?
Докнов=Документсчетфактура.ДокументыОснования.Добавить();
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка1;
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка2;
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка3;
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка4;

за такое сразу ставят двойку и выгоняют с экзамена! :befhbt:

необходимо запросом получить нужные документы основания и в цикле заполнить ТЧ
вот пример, возможны варианты. (заполнение ТЧ загрузкой)
создаете в документе счет фактура кнопку ПодобратьОснования в ней код

//на сервере
Процедура ПодобратьОснования(Кнопка)

лкЗапрос = Новый Запрос;
лкЗапрос.Текст = "
    |Выбрать
|//здесь формируете запрос который найдет ваши основания
|//по каким-то кретериям Контрагент, Договор и т.д.
| Док.Ссылка как ДокументОснование,
|   ...
|";
лкЗапрос.УстановитьПараметр("Контрагент",Контрагент);
лкЗапрос.УстановитьПараметр("Договор",Договор);

//получаем данные и формируем ТЧ Оснований
лкРезультат = лкЗапрос.Выполнить().Выбрать();
Пока лкРезультат.Следующий() Цикл
лкНов = ДокументыОснования.Добавить();
лкНов.ДокументОснование = лкРезультат.ДокументОснование;
//и другие нужные поля заполняете здесь, их можно в том-же запросе подготовить
КонецЦикла;

КонецПроцедуры

Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн alexei1800

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-17
  • Сайт: 
  • Профессия: Ученик 1С
Докнов=Документсчетфактура.ДокументыОснования.Добавить();
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка1;
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка2;
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка3;
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка4;

Вот это работает, у меня теперь  в счет-фактуре выданной перестало работать
   Документсчетфактура.СуммаДокумента= общая_сумма;
   Документсчетфактура.Сумма= общая_сумма;
не присваивает хоть ты тресни
ДокументСчетФактура.Дата=текущаяДата();
      Документсчетфактура.Контрагент=контрагент;
      Документсчетфактура.ВидСчетаФактуры=Перечисления.ВидСчетаФактурыВыставленного.НаРеализацию;
      сообщить("Общая сумма счет-фактуры="+общая_сумма);
   Документсчетфактура.ДоговорКонтрагента=выборка.ссылка;
   Документсчетфактура.СуммаДокумента= общая_сумма;
   Документсчетфактура.Сумма= общая_сумма;
           Документсчетфактура.организация=выборкаДетальныезаписи.Организация;
            Документсчетфактура.Проведен=Истина;
      Документсчетфактура.Записать();


Сумма везде = 0
Добавлено: 09 Сен 2016, 15:04

блин ну что за бред?
Докнов=Документсчетфактура.ДокументыОснования.Добавить();
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка1;
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка2;
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка3;
НоваяСтрока = ДокНов.ТабличнаяЧасть.Добавить();
НоваяСтрока.ДокументОснование = Ссылка4;

за такое сразу ставят двойку и выгоняют с экзамена! :befhbt:

необходимо запросом получить нужные документы основания и в цикле заполнить ТЧ
вот пример, возможны варианты. (заполнение ТЧ загрузкой)
создаете в документе счет фактура кнопку ПодобратьОснования в ней код

//на сервере
Процедура ПодобратьОснования(Кнопка)

лкЗапрос = Новый Запрос;
лкЗапрос.Текст = "
    |Выбрать
|//здесь формируете запрос который найдет ваши основания
|//по каким-то кретериям Контрагент, Договор и т.д.
| Док.Ссылка как ДокументОснование,
|   ...
|";
лкЗапрос.УстановитьПараметр("Контрагент",Контрагент);
лкЗапрос.УстановитьПараметр("Договор",Договор);

//получаем данные и формируем ТЧ Оснований
лкРезультат = лкЗапрос.Выполнить().Выбрать();
Пока лкРезультат.Следующий() Цикл
лкНов = ДокументыОснования.Добавить();
лкНов.ДокументОснование = лкРезультат.ДокументОснование;
//и другие нужные поля заполняете здесь, их можно в том-же запросе подготовить
КонецЦикла;

КонецПроцедуры

Спасибо большее это я уже сделал
подскажи теперь как сумму счет-фактуры программно вставить, счетфактура.суммадокумента, что не вставляешь пишет 0, до этого работало, я как стал что-то изменять перестало работать

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1095
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
блин ну что за бред?

ну не без этого ;)
просто что было дано, то и исправил )
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 1597
Последний ответ 21 Мар 2015, 20:24
от дфтын
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3597
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
Реквизит "Ссылка" у справочников и документов

Автор leklerkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2276
Последний ответ 29 Май 2013, 16:24
от leklerk
"Дубляж" документов реализации в ВзаиморасчетыКомпанииОстаткиИОбороты

Автор mspuzРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1398
Последний ответ 24 Янв 2014, 13:55
от mspuz
Неясна схема создания документов в "1С: ERP УП 2.1".

Автор РексарычРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 976
Последний ответ 29 Июн 2016, 12:04
от Sandi

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
63 Сообщений
MuI_I_Ika MuI_I_Ika
47 Сообщений
crow1983
35 Сообщений
LexaK
32 Сообщений
alexandr_ll
30 Сообщений
sertak sertak
25 Сообщений
Vzonder
22 Сообщений
дфтын дфтын
17 Сообщений
BuhRust
17 Сообщений

* Кто онлайн

  • Точка Гостей: 218
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal