Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Июл 2017, 05:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Цикл не работает.  (Прочитано 454 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Igor100500

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, подскажите в чем ошибка?
&НаКлиенте
Процедура Выгрузить(Команда)



создаемдбф();


КонецПроцедуры

&НаСервере
Процедура создаемдбф()
   
ИксБейс = Новый XBase;

ИксБейс.Кодировка = КодировкаXBase.OEM;

ИксБейс.поля.Добавить("FAM","S",40);
ИксБейс.поля.Добавить("Name","S",25);
ИксБейс.поля.Добавить("PAT","S",35);


//создаем файл дбф
ИксБейс.СоздатьФайл("E:\Гостиница\Шпоры\1.dbf");



ИксБейс.ОчиститьФайл();
Сообщить("Очищаем файл!");




//выгружаем фамилию имя и отч
Запрос= Новый запрос;
Запрос.Текст=("ВЫБРАТЬ
              | ФизическиеЛица.Фамилия,
              | ФизическиеЛица.Имя,
              | ФизическиеЛица.Отчество
              |ИЗ
              | Справочник.ФизическиеЛица КАК ФизическиеЛица");
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
ИксБейс.Добавить();
ИксБейс.FAM=Выборка.Фамилия;
ИксБейс.NAME=Выборка.имя;
ИксБейс.PAT=Выборка.Отчество;
КонецЦикла;

ИксБейс.Записать();

ИксБейс.ЗакрытьФайл();
КонецПроцедуры
по факту выгружает только 1 человека, почему? должен же всех.


Оффлайн Igor100500

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
Re: Цикл не работает.
« Ответ #1: 09 Сен 2016, 09:56 »
Даже если тупо:
фиовыгр=Справочники.ФизическиеЛица.Выбрать();
Пока фиовыгр.Следующий() Цикл
ИксБейс.Добавить();
ИксБейс.FAM=фиовыгр.Фамилия;
КонецЦикла;

ИксБейс.Записать();
Выгружает 1 запись, что я делаю не так?

Онлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ****
  • Сообщений: 332
  • РЕПУТАЦИЯ: 62
  • КПД: 19%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Re: Цикл не работает.
« Ответ #2: 09 Сен 2016, 10:13 »
Записать() поместить внутрь цикла?

Оффлайн Igor100500

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
Re: Цикл не работает.
« Ответ #3: 09 Сен 2016, 10:15 »
Все спасибо, работает.:D

Онлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ****
  • Сообщений: 332
  • РЕПУТАЦИЯ: 62
  • КПД: 19%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Re: Цикл не работает.
« Ответ #4: 09 Сен 2016, 10:17 »
Есть еще свойство АвтоСохранение, посмотрите в справке.


Теги:
 

Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3886
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
Не работает кнопка "установить интервал дат"

Автор depp_juniorРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3247
Последний ответ 11 Июл 2014, 18:07
от LexaK
не работает отчет "Выработка сотрудника" в ЗУП2.5.35.3

Автор a_a2001Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3460
Последний ответ 20 Июн 2011, 11:14
от Zvezo
Работает ли программа "1С:Управление торговлей 8" на реальных предприятиях?

Автор БоняРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2948
Последний ответ 25 Июл 2008, 15:23
от Мерзлов
Как работает "НайтиПоРеквизиту" при большом количестве элементов с подходящим реквизитом?

Автор Дмитрий КасаткинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 142
Последний ответ 04 Май 2017, 10:21
от ilyay

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
122 Сообщений
alex0402
104 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
73 Сообщений
ilyay ilyay
50 Сообщений
Golickoff Golickoff
49 Сообщений
AIFrame
46 Сообщений
ab30ru
38 Сообщений
wise wise
36 Сообщений
Амал
32 Сообщений
Dethmontt Dethmontt
25 Сообщений

* Кто онлайн

  • Точка Гостей: 224
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal