Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Мар 2017, 04:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Цикл не работает.  (Прочитано 342 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Igor100500

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, подскажите в чем ошибка?
&НаКлиенте
Процедура Выгрузить(Команда)



создаемдбф();


КонецПроцедуры

&НаСервере
Процедура создаемдбф()
   
ИксБейс = Новый XBase;

ИксБейс.Кодировка = КодировкаXBase.OEM;

ИксБейс.поля.Добавить("FAM","S",40);
ИксБейс.поля.Добавить("Name","S",25);
ИксБейс.поля.Добавить("PAT","S",35);


//создаем файл дбф
ИксБейс.СоздатьФайл("E:\Гостиница\Шпоры\1.dbf");



ИксБейс.ОчиститьФайл();
Сообщить("Очищаем файл!");




//выгружаем фамилию имя и отч
Запрос= Новый запрос;
Запрос.Текст=("ВЫБРАТЬ
              | ФизическиеЛица.Фамилия,
              | ФизическиеЛица.Имя,
              | ФизическиеЛица.Отчество
              |ИЗ
              | Справочник.ФизическиеЛица КАК ФизическиеЛица");
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
ИксБейс.Добавить();
ИксБейс.FAM=Выборка.Фамилия;
ИксБейс.NAME=Выборка.имя;
ИксБейс.PAT=Выборка.Отчество;
КонецЦикла;

ИксБейс.Записать();

ИксБейс.ЗакрытьФайл();
КонецПроцедуры
по факту выгружает только 1 человека, почему? должен же всех.


Оффлайн Igor100500

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
Re: Цикл не работает.
« Ответ #1: 09 Сен 2016, 09:56 »
Даже если тупо:
фиовыгр=Справочники.ФизическиеЛица.Выбрать();
Пока фиовыгр.Следующий() Цикл
ИксБейс.Добавить();
ИксБейс.FAM=фиовыгр.Фамилия;
КонецЦикла;

ИксБейс.Записать();
Выгружает 1 запись, что я делаю не так?

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ***
  • Сообщений: 200
  • РЕПУТАЦИЯ: 31
  • КПД: 16%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Re: Цикл не работает.
« Ответ #2: 09 Сен 2016, 10:13 »
Записать() поместить внутрь цикла?

Оффлайн Igor100500

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-11-20
  • Сайт: 
  • Профессия: Ученик 1С
Re: Цикл не работает.
« Ответ #3: 09 Сен 2016, 10:15 »
Все спасибо, работает.:D

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ***
  • Сообщений: 200
  • РЕПУТАЦИЯ: 31
  • КПД: 16%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Re: Цикл не работает.
« Ответ #4: 09 Сен 2016, 10:17 »
Есть еще свойство АвтоСохранение, посмотрите в справке.


Теги:
 

Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3692
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
Не работает кнопка "установить интервал дат"

Автор depp_juniorРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2955
Последний ответ 11 Июл 2014, 18:07
от LexaK
не работает отчет "Выработка сотрудника" в ЗУП2.5.35.3

Автор a_a2001Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3241
Последний ответ 20 Июн 2011, 11:14
от Zvezo
Работает ли программа "1С:Управление торговлей 8" на реальных предприятиях?

Автор БоняРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2789
Последний ответ 25 Июл 2008, 15:23
от Мерзлов
Как продлить рабочую неделю, если сотрудник работает во вредных условиях по результатам спецоценки

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1212
Последний ответ 25 Апр 2014, 11:35
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
144 Сообщений
alex0402
113 Сообщений
Norfolk
51 Сообщений
LexaK
47 Сообщений
MuI_I_Ika MuI_I_Ika
37 Сообщений
друган
21 Сообщений
AsadRoman
20 Сообщений
alexandr_ll
19 Сообщений
Константин5825
18 Сообщений
MrLvovsky MrLvovsky
16 Сообщений

* Кто онлайн

  • Точка Гостей: 196
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal