Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
30 Май 2017, 14:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получение значений реквизитов из справочников конфигурации  (Прочитано 328 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Paulius

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-07
  • Сайт: 
  • Профессия: Программист 8.1
Есть следующая задача.
Есть справочник с именем "Инвентаризация". В этом справочнике имеется форма на которой расположено поле с флажком, значение которого БУЛЕВО и привязано к реквизиту этого же справочника "Списание". Необходимо получить значение этого реквизита, для управления элементами формы.
При установленном флажке на форме должны быть активны только элементы ответственные за активные значения, а при снятом соответственно наоборот.

Процедура СписаниеПриИзменении(Элемент)
   Если    __________________________________________ Что сюда вписать ?
   Тогда
      ЭтаФорма.Элементы.ДатаСписания.Доступность = Истина;
      ЭтаФорма.Элементы.Количество.Доступность = Ложь;
      ЭтаФорма.Элементы.Количество.ЦветТекстаЗаголовка = WebЦвета.Красный;
   Иначе
      ЭтаФорма.Элементы.ДатаСписания.Доступность = Ложь;
           ЭтаФорма.Элементы.Количество.Доступность = Истина;
      ЭтаФорма.Элементы.Количество.ЦветТекстаЗаголовка = WebЦвета.Черный;
   КонецЕсли;
КонецПроцедуры


Оффлайн Paulius

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-07
  • Сайт: 
  • Профессия: Программист 8.1
Самое смешное, что сам и разобрался.
Может кому и пригодится.

Решение очень простое :D

&НаКлиенте
Процедура ПолеСписаниеПриИзменении(Элемент)
   Если    Объект.Списание = Истина
      Тогда
         ЭтаФорма.Элементы.ДатаСписания.Доступность = Истина;
         ЭтаФорма.Элементы.Количество.Доступность = Ложь;
         ЭтаФорма.Элементы.Количество.ЦветТекстаЗаголовка = WebЦвета.Красный;
      Иначе
         ЭтаФорма.Элементы.ДатаСписания.Доступность = Ложь;
         ЭтаФорма.Элементы.Количество.Доступность = Истина;
         ЭтаФорма.Элементы.Количество.ЦветТекстаЗаголовка = WebЦвета.Черный;
   КонецЕсли;
КонецПроцедуры

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ****
  • Сообщений: 267
  • РЕПУТАЦИЯ: 46
  • КПД: 17%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Еще при создании на сервере или при открытии нужно то же самое делать.


 

Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4135
Последний ответ 25 Ноя 2008, 10:43
от DDD
"1С:Предприятие 8. Использование конфигурации "Управление торговлей" Пользовател

Автор raika4Раздел Закрытые темы

Ответов: 0
Просмотров: 3139
Последний ответ 13 Мар 2011, 14:28
от raika4
В разделе "Перейти"панели навигации ВСЕХ управляемых форм (новых, старых, вновь создаваемых) конфигурации появляется одна и та же команда. Как избавиться?

Автор CrazyHorseРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1061
Последний ответ 23 Июн 2015, 16:49
от CrazyHorse
О конфигурации "Комплексная автоматизация"

Автор СтолярРаздел Закрытые темы

Ответов: 9
Просмотров: 6315
Последний ответ 11 Мар 2012, 18:35
от Котова
О конфигурации "Бухгалтерия Предприятия 2.0"

Автор СтолярРаздел Закрытые темы

Ответов: 46
Просмотров: 24590
Последний ответ 11 Мар 2012, 18:36
от Котова

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
95 Сообщений
wise wise
75 Сообщений
MuI_I_Ika MuI_I_Ika
54 Сообщений
alex0402
49 Сообщений
Dethmontt Dethmontt
48 Сообщений
Сергей Федоров Сергей Федоров
29 Сообщений
ilyay ilyay
29 Сообщений
ilnur75
25 Сообщений
Дмитрий Медведков Дмитрий Медведков
19 Сообщений
DmitriyF DmitriyF
17 Сообщений

* Кто онлайн

  • Точка Гостей: 899
  • Точка Скрытых: 0
  • Точка Пользователей: 20
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal