Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Июн 2018, 07:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получение значений реквизитов из справочников конфигурации  (Прочитано 480 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Paulius

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-07
  • Сайт: 
  • Профессия: Программист 8.1
Есть следующая задача.
Есть справочник с именем "Инвентаризация". В этом справочнике имеется форма на которой расположено поле с флажком, значение которого БУЛЕВО и привязано к реквизиту этого же справочника "Списание". Необходимо получить значение этого реквизита, для управления элементами формы.
При установленном флажке на форме должны быть активны только элементы ответственные за активные значения, а при снятом соответственно наоборот.

Процедура СписаниеПриИзменении(Элемент)
   Если    __________________________________________ Что сюда вписать ?
   Тогда
      ЭтаФорма.Элементы.ДатаСписания.Доступность = Истина;
      ЭтаФорма.Элементы.Количество.Доступность = Ложь;
      ЭтаФорма.Элементы.Количество.ЦветТекстаЗаголовка = WebЦвета.Красный;
   Иначе
      ЭтаФорма.Элементы.ДатаСписания.Доступность = Ложь;
           ЭтаФорма.Элементы.Количество.Доступность = Истина;
      ЭтаФорма.Элементы.Количество.ЦветТекстаЗаголовка = WebЦвета.Черный;
   КонецЕсли;
КонецПроцедуры


Оффлайн Paulius

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-07
  • Сайт: 
  • Профессия: Программист 8.1
Самое смешное, что сам и разобрался.
Может кому и пригодится.

Решение очень простое :D

&НаКлиенте
Процедура ПолеСписаниеПриИзменении(Элемент)
   Если    Объект.Списание = Истина
      Тогда
         ЭтаФорма.Элементы.ДатаСписания.Доступность = Истина;
         ЭтаФорма.Элементы.Количество.Доступность = Ложь;
         ЭтаФорма.Элементы.Количество.ЦветТекстаЗаголовка = WebЦвета.Красный;
      Иначе
         ЭтаФорма.Элементы.ДатаСписания.Доступность = Ложь;
         ЭтаФорма.Элементы.Количество.Доступность = Истина;
         ЭтаФорма.Элементы.Количество.ЦветТекстаЗаголовка = WebЦвета.Черный;
   КонецЕсли;
КонецПроцедуры

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • *****
  • Сообщений: 533
  • РЕПУТАЦИЯ: 96
  • КПД: 18%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Еще при создании на сервере или при открытии нужно то же самое делать.


 

Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4720
Последний ответ 25 Ноя 2008, 10:43
от DDD
Обновление конфигурации "Аренда и управление недвижимостью для "1С:Бухгалтерия 8"" с 2.0 на 3.0

Автор Эльвина МуромцеваРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 755
Последний ответ 16 Ноя 2017, 14:26
от Геннадий ОбьГЭС
Обнаружено дублирование ключевых значений в колонке ссылка ["обнаружено дублирование ключевых з

Автор lianinfoРаздел Пользователям "1С - Предприятие 8"

Ответов: 10
Просмотров: 749
Последний ответ 20 Мар 2018, 16:54
от alex0402
"1С:Предприятие 8. Использование конфигурации "Управление торговлей" Пользовател

Автор raika4Раздел Закрытые темы

Ответов: 0
Просмотров: 3568
Последний ответ 13 Мар 2011, 14:28
от raika4
В разделе "Перейти"панели навигации ВСЕХ управляемых форм (новых, старых, вновь создаваемых) конфигурации появляется одна и та же команда. Как избавиться?

Автор CrazyHorseРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1505
Последний ответ 23 Июн 2015, 16:49
от CrazyHorse

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
134 Сообщений
AIFrame AIFrame
124 Сообщений
alexandr_ll
56 Сообщений
alex0402
47 Сообщений
pavl_vs
47 Сообщений
buketov.av buketov.av
43 Сообщений
ilyay ilyay
36 Сообщений
trialex3
24 Сообщений
magnifico61
21 Сообщений
wise wise
15 Сообщений

* Кто онлайн

  • Точка Гостей: 438
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal