Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
17 сен 2021, 19:09

Получение значений реквизитов из справочников конфигурации

Автор Paulius, 06 сен 2016, 21:45

0 Пользователей и 1 гость просматривают эту тему.

Paulius

Есть следующая задача.
Есть справочник с именем "Инвентаризация". В этом справочнике имеется форма на которой расположено поле с флажком, значение которого БУЛЕВО и привязано к реквизиту этого же справочника "Списание". Необходимо получить значение этого реквизита, для управления элементами формы.
При установленном флажке на форме должны быть активны только элементы ответственные за активные значения, а при снятом соответственно наоборот.

Процедура СписаниеПриИзменении(Элемент)
   Если    __________________________________________ Что сюда вписать ?
   Тогда
      ЭтаФорма.Элементы.ДатаСписания.Доступность = Истина;
      ЭтаФорма.Элементы.Количество.Доступность = Ложь;
      ЭтаФорма.Элементы.Количество.ЦветТекстаЗаголовка = WebЦвета.Красный;
   Иначе
      ЭтаФорма.Элементы.ДатаСписания.Доступность = Ложь;
           ЭтаФорма.Элементы.Количество.Доступность = Истина;
      ЭтаФорма.Элементы.Количество.ЦветТекстаЗаголовка = WebЦвета.Черный;
   КонецЕсли;
КонецПроцедуры

Paulius

Самое смешное, что сам и разобрался.
Может кому и пригодится.

Решение очень простое :D

&НаКлиенте
Процедура ПолеСписаниеПриИзменении(Элемент)
   Если    Объект.Списание = Истина
      Тогда
         ЭтаФорма.Элементы.ДатаСписания.Доступность = Истина;
         ЭтаФорма.Элементы.Количество.Доступность = Ложь;
         ЭтаФорма.Элементы.Количество.ЦветТекстаЗаголовка = WebЦвета.Красный;
      Иначе
         ЭтаФорма.Элементы.ДатаСписания.Доступность = Ложь;
         ЭтаФорма.Элементы.Количество.Доступность = Истина;
         ЭтаФорма.Элементы.Количество.ЦветТекстаЗаголовка = WebЦвета.Черный;
   КонецЕсли;
КонецПроцедуры

ilyay

Еще при создании на сервере или при открытии нужно то же самое делать.

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск