Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 сен 2021, 05:31

Создание вручную счет-фактуры

Автор alexei1800, 06 сен 2016, 15:22

0 Пользователей и 1 гость просматривают эту тему.

alexei1800

Прохожу стажеровку, на сегодня такая задача туплю.
Создать вручную или программано счет-фактуру по документу оказания услуги.
Создать обработку, по которой по выбранному контрагенту за выдбранный период по всем документам оказания услуги будут созданы счет-фактуры
Создал код сказали неправильный
Команда1НаСервере(контрагент)
         Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ОказаниеУслугКонтрагенты.Сумма КАК сумма,
      |   ОказаниеУслугКонтрагенты.Цена,
      |   ОказаниеУслугКонтрагенты.Количество,
      |   ОказаниеУслугКонтрагенты.Контрагент КАК контраг,
      |   ОказаниеУслугКонтрагенты.ДоговорКонтрагента КАК дог,
      |   ОказаниеУслугКонтрагенты.Ссылка
      |ИЗ
      |   Документ.ОказаниеУслуг.Контрагенты КАК ОказаниеУслугКонтрагенты
      |ГДЕ
      |   ОказаниеУслугКонтрагенты.Контрагент = &контрагент";
     
       Запрос.УстановитьПараметр("контрагент",контрагент);
Контра=запрос.Выполнить();
   Выборка = Контра.Выбрать();
   пока выборка.Следующий() цикл
     
      документСчетФактура=Документы.СчетФактураВыданный.СоздатьДокумент();
      ДокументСчетФактура.Дата=текущаяДата();
      Документсчетфактура.Контрагент=выборка.контраг;
      Документсчетфактура.ВидСчетаФактуры=Перечисления.ВидСчетаФактурыВыставленного.НаРеализацию;
       Документсчетфактура.ДокументОснование=выборка.ссылка;
     
      Документсчетфактура.Сумма=выборка.сумма;
      сообщить(выборка.сумма);
      Документсчетфактура.Проведен=Истина;
      Документсчетфактура.Записать();
     

      конеццикла
Сказали данный код не учитывает регистры(при создании счет-фактуры, затрагиваются и другие объекты конфигурации, в которых нужно оказывается тоже внести изменения).
А какие регистры используются при создании счет-фактур?
Созданнные счет-фактуры не редактируются

Как вообще не через документ создания услуги(там в закладки есть счет фактура, на основании этого документа можно создать счет-фактуру). А как вот зашел в счет-фактуру и создал новую счет-фактуру.
1С:Предприятие 8.3 (8.3.8.1747). когда создаешь счет-фактуру, невозможно выбрать документ основания, он не  выбирается.

Мне сказали изменить процедуры в модуле объекта документа счет-фактура выданный
Есть ли вообще какие-нибудь книги как разобраться во всей этой структуре 1с бухгалтерии, как взаимосвязаны тут объекты

Oldman06

По-моему, в бухгалтерии все делается гораздо проще. Сделали выборку и Документы.СчетФактураВыданный.СоздатьДокументНаОсновании(Выборка.Ссылка);

alexei1800

Цитата: Oldman06 от 06 сен 2016, 16:02
По-моему, в бухгалтерии все делается гораздо проще. Сделали выборку и Документы.СчетФактураВыданный.СоздатьДокументНаОсновании(Выборка.Ссылка);
попробую так сделать
А где про это почитать можно

в общем если такое пишешь появляется ошибка
{Документ.СчетФактураВыданный.МодульМенеджера(159)}: Ошибка при вызове метода контекста (Записать)
   СчетФактура.Записать(РежимЗаписи);
по причине:
Не удалось провести: "Счет-фактура выданный"!
Добавлено: 06 сен 2016, 17:02


чтобы было понятно, что я поменял
документСчетФактура=Документы.СчетФактураВыданный.СоздатьДокументНаОсновании(Выборка.Ссылка);
Документсчетфактура.Проведен=Истина;
Документсчетфактура.Записать();

cska-fanat-kz

Документсчетфактура.Проведен=Истина;
Документсчетфактура.Записать();
=
Документсчетфактура.Записать(РежимЗаписиДокумента.Проведение);
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

alexei1800

Цитата: cska-fanat-kz от 07 сен 2016, 06:54
Документсчетфактура.Проведен=Истина;
Документсчетфактура.Записать();
=
Документсчетфактура.Записать(РежимЗаписиДокумента.Проведение);
Я вот уже 2 неделю стажировку прохожу и как бы прихожу в отчаяение, само программирование и запросы, с помощью конструкторов запросов делаются достаточно легко. Но вот когда тебе дают конкретное задание по бухгалтерии происходит зависание. Есть ли какие-нибудь курсы или уроки по конкретной конфигурации бухгалтерии, чтобы можно было решать конкретные задачи на уже существующей типовой конфиграции, а не строить свою конфигурацию
Добавлено: 07 сен 2016, 10:05


Цитата: alexei1800 от 07 сен 2016, 09:44
Цитата: cska-fanat-kz от 07 сен 2016, 06:54
Документсчетфактура.Проведен=Истина;
Документсчетфактура.Записать();
=
Документсчетфактура.Записать(РежимЗаписиДокумента.Проведение);
Я вот уже 2 неделю стажировку прохожу и как бы прихожу в отчаяение, само программирование и запросы, с помощью конструкторов запросов делаются достаточно легко. Но вот когда тебе дают конкретное задание по бухгалтерии происходит зависание. Есть ли какие-нибудь курсы или уроки по конкретной конфигурации бухгалтерии, чтобы можно было решать конкретные задачи на уже существующей типовой конфиграции, а не строить свою конфигурацию
Документсчетфактура.Записать(РежимЗаписиДокумента.Проведение);
{Документ.СчетФактураВыданный.МодульМенеджера(159)}: Ошибка при вызове метода контекста (Записать)
   СчетФактура.Записать(РежимЗаписи);
по причине:
Не удалось провести: "Счет-фактура выданный"!
не работает

Анатолий Анпилогов

документСчетФактура=Документы.СчетФактураВыданный.СоздатьДокументНаОсновании(Выборка.Ссылка);
//Описание
    Если Не документСчетФактура.Проведен Тогда
        документСчетФактура.Записать(РежимЗаписиДокумента.Проведение);
    КонецЕсли;

alexei1800

Цитата: Анатолий Анпилогов от 07 сен 2016, 11:16
документСчетФактура=Документы.СчетФактураВыданный.СоздатьДокументНаОсновании(Выборка.Ссылка);
//Описание
    Если Не документСчетФактура.Проведен Тогда
        документСчетФактура.Записать(РежимЗаписиДокумента.Проведение);
    КонецЕсли;

{Документ.СчетФактураВыданный.МодульМенеджера(159)}: Ошибка при вызове метода контекста (Записать)
   СчетФактура.Записать(РежимЗаписи);
по причине:
Не удалось провести: "Счет-фактура выданный"!

что нужно добавить в описании?

cska-fanat-kz

Цитата: alexei1800 от 07 сен 2016, 09:44Я вот уже 2 неделю стажировку прохожу и как бы прихожу в отчаяение, само программирование и запросы, с помощью конструкторов запросов делаются достаточно легко. Но вот когда тебе дают конкретное задание по бухгалтерии происходит зависание. Есть ли какие-нибудь курсы или уроки по конкретной конфигурации бухгалтерии, чтобы можно было решать конкретные задачи на уже существующей типовой конфиграции, а не строить свою конфигурацию

полно. как курсов по программированию в целом, так и конкретно в конфигурации "Бухгалтерия"
http://курсы-по-1с.рф
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Kironten

Цитата: alexei1800 от 07 сен 2016, 11:48
Цитата: Анатолий Анпилогов от 07 сен 2016, 11:16
документСчетФактура=Документы.СчетФактураВыданный.СоздатьДокументНаОсновании(Выборка.Ссылка);
//Описание
    Если Не документСчетФактура.Проведен Тогда
        документСчетФактура.Записать(РежимЗаписиДокумента.Проведение);
    КонецЕсли;

{Документ.СчетФактураВыданный.МодульМенеджера(159)}: Ошибка при вызове метода контекста (Записать)
   СчетФактура.Записать(РежимЗаписи);
по причине:
Не удалось провести: "Счет-фактура выданный"!

что нужно добавить в описании?
Что-то недозаполнено.
Попробуйте провести вручную и посмотрите, на что ругается.

alexei1800

Цитата: cska-fanat-kz от 07 сен 2016, 11:53
Цитата: alexei1800 от 07 сен 2016, 09:44Я вот уже 2 неделю стажировку прохожу и как бы прихожу в отчаяение, само программирование и запросы, с помощью конструкторов запросов делаются достаточно легко. Но вот когда тебе дают конкретное задание по бухгалтерии происходит зависание. Есть ли какие-нибудь курсы или уроки по конкретной конфигурации бухгалтерии, чтобы можно было решать конкретные задачи на уже существующей типовой конфиграции, а не строить свою конфигурацию

полно. как курсов по программированию в целом, так и конкретно в конфигурации "Бухгалтерия"
http://курсы-по-1с.рф
программировать по 1с я за 2 дня более менее понял, также как и запросы создавать, а дальше тупик, вот закрытия счета, какие объекты используются при этом. Или что-нибудь другое. Я вот на прошлой недели звонил по курсам, что идут в нашем городе, пообщался с преподавалителем, ничего нового в ходе общения не узнал, понял, что это пустая трата времени.
привожу пример предудущий пример создание счет-фактуры просто создать счет-фактуру через Документы.СчетФактураВыданный.СоздатьДокумент нельзя потому что используются  и другие документы, в общем это все лирика...

по-моему вопросу, каким образом можно програмно создать счет-фактуру?
Добавлено: 07 сен 2016, 12:46


Цитата: Kironten от 07 сен 2016, 12:41
Цитата: alexei1800 от 07 сен 2016, 11:48
Цитата: Анатолий Анпилогов от 07 сен 2016, 11:16
документСчетФактура=Документы.СчетФактураВыданный.СоздатьДокументНаОсновании(Выборка.Ссылка);
//Описание
    Если Не документСчетФактура.Проведен Тогда
        документСчетФактура.Записать(РежимЗаписиДокумента.Проведение);
    КонецЕсли;

{Документ.СчетФактураВыданный.МодульМенеджера(159)}: Ошибка при вызове метода контекста (Записать)
   СчетФактура.Записать(РежимЗаписи);
по причине:
Не удалось провести: "Счет-фактура выданный"!

что нужно добавить в описании?
Что-то недозаполнено.
Попробуйте провести вручную и посмотрите, на что ругается.
в том-то и дело, вручную не могу создать счет-фактуру, могу создать счет фактуру только когда захожу в документ оказание услуг, и ставлю галочку в счет-фактуре. а В ручную требуется документ основания, жмешь на кнопку выбор, и не находишь документ основания

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск