Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Окт 2017, 02:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание вручную счет-фактуры  (Прочитано 2761 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alexei1800

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-17
  • Сайт: 
  • Профессия: Ученик 1С
Прохожу стажеровку, на сегодня такая задача туплю.
Создать вручную или программано счет-фактуру по документу оказания услуги.
Создать обработку, по которой по выбранному контрагенту за выдбранный период по всем документам оказания услуги будут созданы счет-фактуры
Создал код сказали неправильный
Команда1НаСервере(контрагент)
         Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ОказаниеУслугКонтрагенты.Сумма КАК сумма,
      |   ОказаниеУслугКонтрагенты.Цена,
      |   ОказаниеУслугКонтрагенты.Количество,
      |   ОказаниеУслугКонтрагенты.Контрагент КАК контраг,
      |   ОказаниеУслугКонтрагенты.ДоговорКонтрагента КАК дог,
      |   ОказаниеУслугКонтрагенты.Ссылка
      |ИЗ
      |   Документ.ОказаниеУслуг.Контрагенты КАК ОказаниеУслугКонтрагенты
      |ГДЕ
      |   ОказаниеУслугКонтрагенты.Контрагент = &контрагент";
     
       Запрос.УстановитьПараметр("контрагент",контрагент);
 Контра=запрос.Выполнить();
   Выборка = Контра.Выбрать();
   пока выборка.Следующий() цикл
     
      документСчетФактура=Документы.СчетФактураВыданный.СоздатьДокумент();
      ДокументСчетФактура.Дата=текущаяДата();
      Документсчетфактура.Контрагент=выборка.контраг;
      Документсчетфактура.ВидСчетаФактуры=Перечисления.ВидСчетаФактурыВыставленного.НаРеализацию;
       Документсчетфактура.ДокументОснование=выборка.ссылка;
     
      Документсчетфактура.Сумма=выборка.сумма;
      сообщить(выборка.сумма);
      Документсчетфактура.Проведен=Истина;
      Документсчетфактура.Записать();
     

      конеццикла
Сказали данный код не учитывает регистры(при создании счет-фактуры, затрагиваются и другие объекты конфигурации, в которых нужно оказывается тоже внести изменения).
А какие регистры используются при создании счет-фактур?
Созданнные счет-фактуры не редактируются

Как вообще не через документ создания услуги(там в закладки есть счет фактура, на основании этого документа можно создать счет-фактуру). А как вот зашел в счет-фактуру и создал новую счет-фактуру.
1С:Предприятие 8.3 (8.3.8.1747). когда создаешь счет-фактуру, невозможно выбрать документ основания, он не  выбирается.

Мне сказали изменить процедуры в модуле объекта документа счет-фактура выданный
Есть ли вообще какие-нибудь книги как разобраться во всей этой структуре 1с бухгалтерии, как взаимосвязаны тут объекты


Оффлайн Oldman06

  • **
  • Сообщений: 86
  • РЕПУТАЦИЯ: 9
  • КПД: 10%
  • Регистрация: 2010-10-21
  • Сайт: 
По-моему, в бухгалтерии все делается гораздо проще. Сделали выборку и Документы.СчетФактураВыданный.СоздатьДокументНаОсновании(Выборка.Ссылка);

Оффлайн alexei1800

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-17
  • Сайт: 
  • Профессия: Ученик 1С
По-моему, в бухгалтерии все делается гораздо проще. Сделали выборку и Документы.СчетФактураВыданный.СоздатьДокументНаОсновании(Выборка.Ссылка);
попробую так сделать
А где про это почитать можно

в общем если такое пишешь появляется ошибка
{Документ.СчетФактураВыданный.МодульМенеджера(159)}: Ошибка при вызове метода контекста (Записать)
   СчетФактура.Записать(РежимЗаписи);
по причине:
Не удалось провести: "Счет-фактура выданный"!
Добавлено: 06 Сен 2016, 17:02

чтобы было понятно, что я поменял
документСчетФактура=Документы.СчетФактураВыданный.СоздатьДокументНаОсновании(Выборка.Ссылка);
Документсчетфактура.Проведен=Истина;
Документсчетфактура.Записать();

Последний раз редактировалось: alexei1800; 06 Сен 2016, 17:02. Причина: Объединение сообщений

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1098
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Документсчетфактура.Проведен=Истина;
Документсчетфактура.Записать();
=
Документсчетфактура.Записать(РежимЗаписиДокумента.Проведение);
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн alexei1800

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-17
  • Сайт: 
  • Профессия: Ученик 1С
Документсчетфактура.Проведен=Истина;
Документсчетфактура.Записать();
=
Документсчетфактура.Записать(РежимЗаписиДокумента.Проведение);
Я вот уже 2 неделю стажировку прохожу и как бы прихожу в отчаяение, само программирование и запросы, с помощью конструкторов запросов делаются достаточно легко. Но вот когда тебе дают конкретное задание по бухгалтерии происходит зависание. Есть ли какие-нибудь курсы или уроки по конкретной конфигурации бухгалтерии, чтобы можно было решать конкретные задачи на уже существующей типовой конфиграции, а не строить свою конфигурацию
Добавлено: 07 Сен 2016, 10:05

Документсчетфактура.Проведен=Истина;
Документсчетфактура.Записать();
=
Документсчетфактура.Записать(РежимЗаписиДокумента.Проведение);
Я вот уже 2 неделю стажировку прохожу и как бы прихожу в отчаяение, само программирование и запросы, с помощью конструкторов запросов делаются достаточно легко. Но вот когда тебе дают конкретное задание по бухгалтерии происходит зависание. Есть ли какие-нибудь курсы или уроки по конкретной конфигурации бухгалтерии, чтобы можно было решать конкретные задачи на уже существующей типовой конфиграции, а не строить свою конфигурацию
Документсчетфактура.Записать(РежимЗаписиДокумента.Проведение);
{Документ.СчетФактураВыданный.МодульМенеджера(159)}: Ошибка при вызове метода контекста (Записать)
   СчетФактура.Записать(РежимЗаписи);
по причине:
Не удалось провести: "Счет-фактура выданный"!
не работает

Последний раз редактировалось: alexei1800; 07 Сен 2016, 10:05. Причина: Объединение сообщений

Оффлайн Анатолий Анпилогов

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 3
  • КПД: 6%
  • Регистрация: 2016-01-12
  • Компания: Арида-Софт
  • Профессия: Программист 1С
документСчетФактура=Документы.СчетФактураВыданный.СоздатьДокументНаОсновании(Выборка.Ссылка);
//Описание
    Если Не документСчетФактура.Проведен Тогда
        документСчетФактура.Записать(РежимЗаписиДокумента.Проведение);
    КонецЕсли;

Оффлайн alexei1800

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-17
  • Сайт: 
  • Профессия: Ученик 1С
документСчетФактура=Документы.СчетФактураВыданный.СоздатьДокументНаОсновании(Выборка.Ссылка);
//Описание
    Если Не документСчетФактура.Проведен Тогда
        документСчетФактура.Записать(РежимЗаписиДокумента.Проведение);
    КонецЕсли;
{Документ.СчетФактураВыданный.МодульМенеджера(159)}: Ошибка при вызове метода контекста (Записать)
   СчетФактура.Записать(РежимЗаписи);
по причине:
Не удалось провести: "Счет-фактура выданный"!

что нужно добавить в описании?

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1098
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Я вот уже 2 неделю стажировку прохожу и как бы прихожу в отчаяение, само программирование и запросы, с помощью конструкторов запросов делаются достаточно легко. Но вот когда тебе дают конкретное задание по бухгалтерии происходит зависание. Есть ли какие-нибудь курсы или уроки по конкретной конфигурации бухгалтерии, чтобы можно было решать конкретные задачи на уже существующей типовой конфиграции, а не строить свою конфигурацию

полно. как курсов по программированию в целом, так и конкретно в конфигурации "Бухгалтерия"
http://курсы-по-1с.рф
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Kironten

  • *****
  • Сообщений: 879
  • РЕПУТАЦИЯ: 183
  • КПД: 21%
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
документСчетФактура=Документы.СчетФактураВыданный.СоздатьДокументНаОсновании(Выборка.Ссылка);
//Описание
    Если Не документСчетФактура.Проведен Тогда
        документСчетФактура.Записать(РежимЗаписиДокумента.Проведение);
    КонецЕсли;
{Документ.СчетФактураВыданный.МодульМенеджера(159)}: Ошибка при вызове метода контекста (Записать)
   СчетФактура.Записать(РежимЗаписи);
по причине:
Не удалось провести: "Счет-фактура выданный"!

что нужно добавить в описании?
Что-то недозаполнено.
Попробуйте провести вручную и посмотрите, на что ругается.

Оффлайн alexei1800

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-17
  • Сайт: 
  • Профессия: Ученик 1С
Я вот уже 2 неделю стажировку прохожу и как бы прихожу в отчаяение, само программирование и запросы, с помощью конструкторов запросов делаются достаточно легко. Но вот когда тебе дают конкретное задание по бухгалтерии происходит зависание. Есть ли какие-нибудь курсы или уроки по конкретной конфигурации бухгалтерии, чтобы можно было решать конкретные задачи на уже существующей типовой конфиграции, а не строить свою конфигурацию

полно. как курсов по программированию в целом, так и конкретно в конфигурации "Бухгалтерия"
http://курсы-по-1с.рф
программировать по 1с я за 2 дня более менее понял, также как и запросы создавать, а дальше тупик, вот закрытия счета, какие объекты используются при этом. Или что-нибудь другое. Я вот на прошлой недели звонил по курсам, что идут в нашем городе, пообщался с преподавалителем, ничего нового в ходе общения не узнал, понял, что это пустая трата времени.
привожу пример предудущий пример создание счет-фактуры просто создать счет-фактуру через Документы.СчетФактураВыданный.СоздатьДокумент нельзя потому что используются  и другие документы, в общем это все лирика...

по-моему вопросу, каким образом можно програмно создать счет-фактуру?
Добавлено: 07 Сен 2016, 12:46

документСчетФактура=Документы.СчетФактураВыданный.СоздатьДокументНаОсновании(Выборка.Ссылка);
//Описание
    Если Не документСчетФактура.Проведен Тогда
        документСчетФактура.Записать(РежимЗаписиДокумента.Проведение);
    КонецЕсли;
{Документ.СчетФактураВыданный.МодульМенеджера(159)}: Ошибка при вызове метода контекста (Записать)
   СчетФактура.Записать(РежимЗаписи);
по причине:
Не удалось провести: "Счет-фактура выданный"!

что нужно добавить в описании?
Что-то недозаполнено.
Попробуйте провести вручную и посмотрите, на что ругается.
в том-то и дело, вручную не могу создать счет-фактуру, могу создать счет фактуру только когда захожу в документ оказание услуг, и ставлю галочку в счет-фактуре. а В ручную требуется документ основания, жмешь на кнопку выбор, и не находишь документ основания


 

Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4142
Последний ответ 23 Апр 2015, 08:45
от Golickoff
Не списано 0,0004 кг товара "XXXXX", счет учета 1310, склад Склад материалов

Автор RamirasРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 4732
Последний ответ 30 Июл 2015, 09:21
от Макси
Значение поля "Лицевой счет" содержит недопустимое значение типа лицевого счета

Автор unantedРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3736
Последний ответ 24 Июл 2012, 05:02
от unanted
Автоматическое создание " Заполнение" документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4301
Последний ответ 06 Мар 2014, 14:48
от mashencev_anton
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3777
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

1С HRIS от goldi77
[18 Окт 2017, 11:58]

* Топ 10 авторов за месяц

oleg-x
88 Сообщений
alex0402
50 Сообщений
AIFrame
43 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
37 Сообщений
Oldman06
31 Сообщений
Golickoff Golickoff
30 Сообщений
vitasw
29 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений
DmitriyF DmitriyF
14 Сообщений
pavl_vs
12 Сообщений

* Кто онлайн

  • Точка Гостей: 164
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal