Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Окт 2017, 03:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с хранилищем значения  (Прочитано 692 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Виктор1961

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-04
  • Сайт: 
  • Профессия: Программист 1С
Почему хранилище значений возвращает в данном случае только фразу "ТаблицаЗначений"? как сделать, что оно вернуло результаты запроса, записанные в таблицу значений?
&НаКлиенте
Процедура Выгрузка(Команда)
ФайлТ = Новый ТекстовыйДокумент;
ФайлТ.УстановитьТекст(ЗапросСервер());
ФайлТ.Записать("C:\пример.txt", "windows-1251");

КонецПроцедуры

&НаСервере
Функция ЗапросСервер ()
//сам запрос
ТЗ.Загрузить(Запрос.Выполнить().Выгрузить());
ДанныеТЗ = ПоместитьВоВременноеХранилище(ТЗ.Выгрузить());
Возврат ПолучитьИзВременногоХранилища(ДанныеТЗ);
КонецФункции


Оффлайн Oldman06

  • **
  • Сообщений: 86
  • РЕПУТАЦИЯ: 9
  • КПД: 10%
  • Регистрация: 2010-10-21
  • Сайт: 
Потому что Вы возвращаете из серверного метода таблицу значений. А с сервера на клиент напрямую передать таблицу нельзя. Возвращайте в серверном методе ДанныеТЗ, а ПолучитьИзВременногоХранилища в клиенте.

Оффлайн Виктор1961

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-04
  • Сайт: 
  • Профессия: Программист 1С
При такой реализации в файл также записывается только фраза "ТаблицаЗначений".

&НаКлиенте
...
ФайлТЗ.УстановитьТекст(ПолучитьИзВременногоХранилища(ЗапросНаСервере()));
...

&НаСервере
Функция ЗапросНаСервере ()
...
ДанныеТЗ = ПоместитьВоВременноеХранилище(ТЗ.Выгрузить());
Возврат ДанныеТЗ

Оффлайн Oldman06

  • **
  • Сообщений: 86
  • РЕПУТАЦИЯ: 9
  • КПД: 10%
  • Регистрация: 2010-10-21
  • Сайт: 
Не могу сейчас проверить, но по-моему такое преобразование типов не сработает. Вы в функции ФайлТЗ.УстановитьТекст() фактически приводите тип ТаблицаЗначений к строке. Я сильно сомневаюсь, что в платформе заложена такая возможность.

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • ****
  • Сообщений: 373
  • РЕПУТАЦИЯ: 70
  • КПД: 19%
  • Регистрация: 2011-06-09
  • Сайт: 
  • Профессия: Разработчик 1С
Таблица значений является двоичным объектом. Можно сохранить ее на клиенте несколькими способами:
- поместить ее на сервере во временное хранилище, и вызвав на клиенте ПолучитьФайл(),
- использовать метод ЗначВСтрокуВнутр()
- сериализовать в xml и вернуть на клиент текст xml
- поместить в табличный документ и сохранить табличный документ на клиенте в нужном формате

Если нужен человеко-читаемый вариант, тогда только последние два способа.
Добавлено: 05 Сен 2016, 11:38


&НаСервере
Функция ЗапросСервер ()
//сам запрос
ТЗ.Загрузить(Запрос.Выполнить().Выгрузить());
ДанныеТЗ = ПоместитьВоВременноеХранилище(ТЗ.Выгрузить());
Возврат ПолучитьИзВременногоХранилища(ДанныеТЗ);
КонецФункции

Что такое ТЗ? Таблица значений или данные формы? Даже если это данные формы, не понятно, зачем данные туда-сюда гонять.

Достаточно так:
Возврат ПоместитьВоВременноеХранилище(Запрос.Выполнить().Выгрузить()) - будет адрес таблицы значений, которую сохраняем через ПолучитьФайл()
А если ТЗ - это данные формы, тогда они и так будут доступны на клиенте, не нужно их возвращать. И надо использовать метод ЗначениеВДанныеФормы()


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1085
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4504
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2172
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3209
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3483
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
89 Сообщений
alex0402
53 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
43 Сообщений
AIFrame
40 Сообщений
Oldman06
31 Сообщений
vitasw
29 Сообщений
Golickoff Golickoff
26 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений
BuhRust
14 Сообщений
AsadRoman
13 Сообщений

* Кто онлайн

  • Точка Гостей: 148
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal