Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Июн 2021, 08:38
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Проблема с хранилищем значения  (Прочитано 2097 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Виктор1961

  • *
  • Регистрация: 2016-09-04
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Профессия: Программист 1С
Почему хранилище значений возвращает в данном случае только фразу "ТаблицаЗначений"? как сделать, что оно вернуло результаты запроса, записанные в таблицу значений?
&НаКлиенте
Процедура Выгрузка(Команда)
ФайлТ = Новый ТекстовыйДокумент;
ФайлТ.УстановитьТекст(ЗапросСервер());
ФайлТ.Записать("C:\пример.txt", "windows-1251");

КонецПроцедуры

&НаСервере
Функция ЗапросСервер ()
//сам запрос
ТЗ.Загрузить(Запрос.Выполнить().Выгрузить());
ДанныеТЗ = ПоместитьВоВременноеХранилище(ТЗ.Выгрузить());
Возврат ПолучитьИзВременногоХранилища(ДанныеТЗ);
КонецФункции


Оффлайн Oldman06

  • ***
  • Регистрация: 2010-10-21
  • Сообщений: 104
  • РЕПУТАЦИЯ: 11
  • КПД: 11%
Потому что Вы возвращаете из серверного метода таблицу значений. А с сервера на клиент напрямую передать таблицу нельзя. Возвращайте в серверном методе ДанныеТЗ, а ПолучитьИзВременногоХранилища в клиенте.

Оффлайн Виктор1961

  • *
  • Регистрация: 2016-09-04
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Профессия: Программист 1С
При такой реализации в файл также записывается только фраза "ТаблицаЗначений".

&НаКлиенте
...
ФайлТЗ.УстановитьТекст(ПолучитьИзВременногоХранилища(ЗапросНаСервере()));
...

&НаСервере
Функция ЗапросНаСервере ()
...
ДанныеТЗ = ПоместитьВоВременноеХранилище(ТЗ.Выгрузить());
Возврат ДанныеТЗ

Оффлайн Oldman06

  • ***
  • Регистрация: 2010-10-21
  • Сообщений: 104
  • РЕПУТАЦИЯ: 11
  • КПД: 11%
Не могу сейчас проверить, но по-моему такое преобразование типов не сработает. Вы в функции ФайлТЗ.УстановитьТекст() фактически приводите тип ТаблицаЗначений к строке. Я сильно сомневаюсь, что в платформе заложена такая возможность.

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • *****
  • Регистрация: 2011-06-09
  • Сообщений: 562
  • РЕПУТАЦИЯ: 104
  • КПД: 19%
  • Профессия: Разработчик 1С
Таблица значений является двоичным объектом. Можно сохранить ее на клиенте несколькими способами:
- поместить ее на сервере во временное хранилище, и вызвав на клиенте ПолучитьФайл(),
- использовать метод ЗначВСтрокуВнутр()
- сериализовать в xml и вернуть на клиент текст xml
- поместить в табличный документ и сохранить табличный документ на клиенте в нужном формате

Если нужен человеко-читаемый вариант, тогда только последние два способа.
Добавлено: 05 Сен 2016, 11:38


&НаСервере
Функция ЗапросСервер ()
//сам запрос
ТЗ.Загрузить(Запрос.Выполнить().Выгрузить());
ДанныеТЗ = ПоместитьВоВременноеХранилище(ТЗ.Выгрузить());
Возврат ПолучитьИзВременногоХранилища(ДанныеТЗ);
КонецФункции

Что такое ТЗ? Таблица значений или данные формы? Даже если это данные формы, не понятно, зачем данные туда-сюда гонять.

Достаточно так:
Возврат ПоместитьВоВременноеХранилище(Запрос.Выполнить().Выгрузить()) - будет адрес таблицы значений, которую сохраняем через ПолучитьФайл()
А если ТЗ - это данные формы, тогда они и так будут доступны на клиенте, не нужно их возвращать. И надо использовать метод ЗначениеВДанныеФормы()


Теги:
 

Проблема с параметром в запросе динамического списка

Автор msРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 9676
Последний ответ 26 Апр 2010, 21:39
от BabySG
Нужна Помощь. проблема в програмировании печчатной формы документа.

Автор sani7700Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3086
Последний ответ 28 Дек 2011, 13:13
от Dethmontt
Проблема с отладчиком в 1с 8.2

Автор adminromanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3765
Последний ответ 22 Мар 2012, 14:09
от Vit1501
Проблема с заданием условий при проведении документа

Автор Дмитрий ТатаренкоРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 599
Последний ответ 29 Июл 2019, 11:21
от DmitriyF
1С КА 2.4: Проблема с расчетами в валюте — 999% поступление

Автор 77ProduktРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1188
Последний ответ 23 Янв 2020, 14:27
от Геннадий ОбьГЭС

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

LexaK
69 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
neek666
33 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
25 Сообщений
KATERINA 861
18 Сообщений
Алексей_1985_06
17 Сообщений
SSC
13 Сообщений
alexandr_ll
12 Сообщений
BuhRust
10 Сообщений

* Кто онлайн

  • Точка Гостей: 432
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск