Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 июн 2021, 05:00

Поле объекта не обнаружена (цена)

Автор vigour, 02 сен 2016, 22:58

0 Пользователей и 1 гость просматривают эту тему.

vigour

    Ребята! Сразу скажу что я в этом всем понимаю поверхностно, но ошибку исправлять надо! Прошу помочь! Почему вылетает такая ошибка. Вот код:

Процедура ЗаполнитьТаблицуЦенФормы()

   Если ТипыЦен.Количество() = 0 Тогда // ничего делать не надо
      Возврат;
   КонецЕсли;

   ТаблицаТоваров = Товары.Выгрузить();
   ТаблицаТоваров.Сортировать("ИндексСтрокиТаблицыЦен, Номенклатура, ХарактеристикаНоменклатуры");

   ТекущийИндексСтрокиТаблицыЦен = Неопределено;
   НоваяСтрока = Неопределено;
   Для Каждого СтрокаТаблицыТоваров Из ТаблицаТоваров Цикл
      Если ТекущийИндексСтрокиТаблицыЦен <> СтрокаТаблицыТоваров.ИндексСтрокиТаблицыЦен
       Или НоваяСтрока.Номенклатура <> СтрокаТаблицыТоваров.Номенклатура
       Или НоваяСтрока.ХарактеристикаНоменклатуры <> СтрокаТаблицыТоваров.ХарактеристикаНоменклатуры Тогда
         НоваяСтрока = ТаблицаЦен.Добавить();
         НоваяСтрока.Номенклатура = СтрокаТаблицыТоваров.Номенклатура;
         НоваяСтрока.ХарактеристикаНоменклатуры = СтрокаТаблицыТоваров.ХарактеристикаНоменклатуры;
         ТекущийИндексСтрокиТаблицыЦен = СтрокаТаблицыТоваров.ИндексСтрокиТаблицыЦен;
      КонецЕсли;

      НомерСоответствияТекущейКолонки = мСоответствиеТиповЦен[СтрокаТаблицыТоваров.ТипЦен];

      НоваяСтрока["цена" + НомерСоответствияТекущейКолонки] = СтрокаТаблицыТоваров.Цена;
      НоваяСтрока["СпособРасчета" + НомерСоответствияТекущейКолонки] = СтрокаТаблицыТоваров.СпособРасчетаЦены;
      НоваяСтрока["валюта" + НомерСоответствияТекущейКолонки] = СтрокаТаблицыТоваров.Валюта;
      НоваяСтрока["единица" + НомерСоответствияТекущейКолонки] = СтрокаТаблицыТоваров.ЕдиницаИзмерения;
      НоваяСтрока["процент" + НомерСоответствияТекущейКолонки] = СтрокаТаблицыТоваров.ПроцентСкидкиНаценки;
   КонецЦикла;

КонецПроцедуры // ЗаполнитьТаблицуЦенФормы()

alexandr_ll

Конфигурация и релиз?
Где находится приведенная процедура (в модуле формы документа, во внешней обработке или еще где-нибудь)?

vigour

Цитата: alexandr_ll от 03 сен 2016, 10:03
Конфигурация и релиз?
Где находится приведенная процедура (в модуле формы документа, во внешней обработке или еще где-нибудь)?

Когда я создаю документ установки цен номенклатуры, потом сохраняю и пытаюсь его открыть - здесь все норм. документ открывается.

Но после того, когда я создал документ "Установка цен номенклатуры" и в него пытаюсь импортировать цены через внешнюю обработку. Цены "типа" импортировались, но на самом деле нет и файл после этого при открытии показывает данную ошибку!

1С:Предприятие 8.3 (8.3.5.1383)
"Управление торговлей", редакция 10.3 (10.3.14.3)

alexandr_ll

Для импортирования цен через внешнюю обработку рекомендую использовать вместо документа "Установка цен номенклатуры" документ "Корректировка записей регистра" с непосредственным заполнением записей регистра сведений ЦеныНоменклатуры из внешнего источника

дфтын

alexandr_ll, очень странный совет. Предложите вести весь учет через корректировку регистров
Помог? Нажми - Спасибо :)
skype: Soprov1C

vigour

Цитата: alexandr_ll от 03 сен 2016, 12:04
Для импортирования цен через внешнюю обработку рекомендую использовать вместо документа "Установка цен номенклатуры" документ "Корректировка записей регистра" с непосредственным заполнением записей регистра сведений ЦеныНоменклатуры из внешнего источника

Сделал! И как теперь цены, которые сейчас хранятся в "Корректировках записей регистра" записать в документ "Установка цен номенклатуры"?

alexandr_ll

Цитата: vigour от 04 сен 2016, 15:43
Цитата: alexandr_ll от 03 сен 2016, 12:04
Для импортирования цен через внешнюю обработку рекомендую использовать вместо документа "Установка цен номенклатуры" документ "Корректировка записей регистра" с непосредственным заполнением записей регистра сведений ЦеныНоменклатуры из внешнего источника

Сделал! И как теперь цены, которые сейчас хранятся в "Корректировках записей регистра" записать в документ "Установка цен номенклатуры"?
А зачем? Записи в регистр уже сделаны, в справочнике они отражаются.
Добавлено: 04 сен 2016, 17:45


Цитата: дфтын от 04 сен 2016, 15:41
alexandr_ll, очень странный совет. Предложите вести весь учет через корректировку регистров
А в чем странность-то?
Давайте запретим использование такого документа.
При всех автоматических загрузок из внешних данных используется именно такой документ.

vigour

Цитата: alexandr_ll от 04 сен 2016, 16:56А зачем? Записи в регистр уже сделаны, в справочнике они отражаются.

Абсолютно ничего не показывается!
Добавлено: 04 сен 2016, 18:52



alexandr_ll

Цитата: vigour от 04 сен 2016, 18:51
Цитата: alexandr_ll от 04 сен 2016, 16:56А зачем? Записи в регистр уже сделаны, в справочнике они отражаются.

Абсолютно ничего не показывается!
Добавлено: 04 сен 2016, 18:52


А вы записи регистра создали?
У вас должна быть в обработке конструкция типа:

   Рег = РегистрыСведений.ЦеныНоменклатуры;
   НаборЗаписей = Рег.СоздатьНаборЗаписей();
   Док = НаборЗаписей.Отбор.Регистратор;
   Док.Установить(Докум);
   НаборЗаписей.Прочитать();
   Таб=НаборЗаписей.Выгрузить();
   НаборЗаписей.Загрузить(ТЗ);
   НаборЗаписей.Записать(Истина);

Здесь Докум - это ссылка на документ "Корректировка регистров"
      ТЗ - таблица значений с значениями записи регистра, полученная из внешних данных *см. структуру регистра Цены)

vigour

Жесть! проще президентом стать, чем понять эту 1С.

Теги:
Рейтинг@Mail.ru Rambler's Top100

Поиск