Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2017, 12:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Дата проведения мероприятия не может быть меньше даты документа  (Прочитано 364 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Space_minus

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-03-17
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите пожалуйста, где проверяется это условие? Как его отключить


код модуля формы
&НаКлиенте
Перем АдресСтудентовВХранилище;

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
// Обработчик механизма "ВерсионированиеОбъектов"
ВерсионированиеОбъектов.ПриСозданииНаСервере(ЭтаФорма);
//Заполним реквизиты по умолчанию
Если Объект.Ссылка.Пустая() ТОгда
НастройкиПользователей.ЗаполнитьШапкуДокумента(Объект);
Конецесли;
НастройкиПользователей.СостояниеДокументаПриОткрытии(Объект,СостояниеДокумента,КартинкаСостоянияДокумента,РазрешеноПроведение);
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьДопустимыеПоляМероприятияПоПлану()
Документ = РеквизитФормыВЗначение("Объект");
Документ.Мероприятие = Документ.План.Мероприятие;
Документ.ПериодОбучения = Документ.План.ПериодОбучения;
Документ.ОтветственноеПодразделение = Документ.План.ОтветственноеПодразделение;
Документ.ОтветственныйСотрудник = Документ.План.ОтветственныйСотрудник;
Документ.ДатаПроведения = Документ.План.ПланируемаяДатаПроведения;
ЗначениеВРеквизитФормы(Документ, "Объект");
КонецПроцедуры

&НаКлиенте
Процедура ПланПриИзменении(Элемент)
Если ЗначениеЗаполнено(Объект.План) Тогда
ЗаполнитьДопустимыеПоляМероприятияПоПлану();
Иначе
КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура Подбор(Команда)
АдресСтудентовВХранилище = ПоместитьСтудентовВХранилище();
ПараметрыПодбора = Новый Структура();
ПараметрыПодбора.Вставить("АдресСтудентовВХранилище", АдресСтудентовВХранилище);
ПараметрыПодбора.Вставить("Статус",ПредопределенноеЗначение("Перечисление.СтатусыСтудентов.Студент"));
// Открываем форму с указанием параметров.
ОткрытьФорму("Справочник.Студенты.Форма.ФормаВыбораСтудентовГруппы", ПараметрыПодбора, ЭтаФорма);
КонецПроцедуры
&НаСервере
// Функция помещает список товаров во временное хранилище и возвращает адрес
Функция ПоместитьСтудентовВХранилище()
Возврат ПоместитьВоВременноеХранилище(Объект.Студенты.Выгрузить(,"Студент,УчебнаяГруппа"), УникальныйИдентификатор);
КонецФункции
&НаКлиенте
Процедура ОбработатьПодбор() Экспорт
ПолучитьСтудентовИзХранилища(АдресСтудентовВХранилище); 
КонецПроцедуры
&НаСервере
// Функция восстанавливает список товаров из временного хранилища
Процедура ПолучитьСтудентовИзХранилища(АдресСтудентовВХранилище)
Объект.Студенты.Загрузить(ПолучитьИзВременногоХранилища(АдресСтудентовВХранилище));
КонецПроцедуры

&НаКлиенте
Процедура СтудентыСтудентПриИзменении(Элемент)
Студент=Элементы.Студенты.ТекущиеДанные.Студент;
Элементы.Студенты.ТекущиеДанные.УчебнаяГруппа=УстановитьГруппупоСтуденту(Студент);
КонецПроцедуры

&НаСервере
Функция УстановитьГруппупоСтуденту(Студент)
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ДвижениеКонтингентаСрезПоследних.Группа
|ИЗ
| РегистрСведений.ДвижениеКонтингента.СрезПоследних(
| &ДатаДокумента,
| Статус = &Статус
| И Студент = &Студент) КАК ДвижениеКонтингентаСрезПоследних";

Запрос.УстановитьПараметр("ДатаДокумента", Объект.Дата);
Запрос.УстановитьПараметр("Статус", Перечисления.СтатусыСтудентов.Студент);
Запрос.УстановитьПараметр("Студент", Студент);
Результат = Запрос.Выполнить();
Если НЕ Результат.Пустой() Тогда
Возврат Результат.Выгрузить()[0].Группа;
КонецЕсли;
КонецФункции

&НаКлиенте
Процедура ПослеЗаписи(ПараметрыЗаписи)
НастройкиПользователейКлиент.ОбновитьСостояниеДокумента(Объект, СостояниеДокумента, КартинкаСостоянияДокумента, РазрешеноПроведение);
КонецПроцедуры


Онлайн alex0402

  • *****
  • Сообщений: 692
  • РЕПУТАЦИЯ: 100
  • КПД: 14%
  • Регистрация: 2010-09-10
  • Сайт: 
Нужно смотреть не код формы, а код модуля.
ОбработкаПровекриЗаполнения
ОбработкаПроведения
Подписки на Документ.
Помощь в л/с $10

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1097
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
глобальным поиском ищите текст ошибки - найдете код проверки.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4030
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14175
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3530
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 138
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6997
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
95 Сообщений
Dethmontt Dethmontt
67 Сообщений
alex0402
65 Сообщений
wise wise
63 Сообщений
MuI_I_Ika MuI_I_Ika
60 Сообщений
ilyay ilyay
40 Сообщений
Сергей Федоров Сергей Федоров
34 Сообщений
magnifico61
25 Сообщений
ilnur75
22 Сообщений
BuhRust
21 Сообщений

* Кто онлайн

  • Точка Гостей: 844
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal