Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Июн 2021, 15:41
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Дата проведения мероприятия не может быть меньше даты документа  (Прочитано 968 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Space_minus

  • **
  • Регистрация: 2016-03-17
  • Сообщений: 98
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Подскажите пожалуйста, где проверяется это условие? Как его отключить


код модуля формы
&НаКлиенте
Перем АдресСтудентовВХранилище;

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
// Обработчик механизма "ВерсионированиеОбъектов"
ВерсионированиеОбъектов.ПриСозданииНаСервере(ЭтаФорма);
//Заполним реквизиты по умолчанию
Если Объект.Ссылка.Пустая() ТОгда
НастройкиПользователей.ЗаполнитьШапкуДокумента(Объект);
Конецесли;
НастройкиПользователей.СостояниеДокументаПриОткрытии(Объект,СостояниеДокумента,КартинкаСостоянияДокумента,РазрешеноПроведение);
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьДопустимыеПоляМероприятияПоПлану()
Документ = РеквизитФормыВЗначение("Объект");
Документ.Мероприятие = Документ.План.Мероприятие;
Документ.ПериодОбучения = Документ.План.ПериодОбучения;
Документ.ОтветственноеПодразделение = Документ.План.ОтветственноеПодразделение;
Документ.ОтветственныйСотрудник = Документ.План.ОтветственныйСотрудник;
Документ.ДатаПроведения = Документ.План.ПланируемаяДатаПроведения;
ЗначениеВРеквизитФормы(Документ, "Объект");
КонецПроцедуры

&НаКлиенте
Процедура ПланПриИзменении(Элемент)
Если ЗначениеЗаполнено(Объект.План) Тогда
ЗаполнитьДопустимыеПоляМероприятияПоПлану();
Иначе
КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура Подбор(Команда)
АдресСтудентовВХранилище = ПоместитьСтудентовВХранилище();
ПараметрыПодбора = Новый Структура();
ПараметрыПодбора.Вставить("АдресСтудентовВХранилище", АдресСтудентовВХранилище);
ПараметрыПодбора.Вставить("Статус",ПредопределенноеЗначение("Перечисление.СтатусыСтудентов.Студент"));
// Открываем форму с указанием параметров.
ОткрытьФорму("Справочник.Студенты.Форма.ФормаВыбораСтудентовГруппы", ПараметрыПодбора, ЭтаФорма);
КонецПроцедуры
&НаСервере
// Функция помещает список товаров во временное хранилище и возвращает адрес
Функция ПоместитьСтудентовВХранилище()
Возврат ПоместитьВоВременноеХранилище(Объект.Студенты.Выгрузить(,"Студент,УчебнаяГруппа"), УникальныйИдентификатор);
КонецФункции
&НаКлиенте
Процедура ОбработатьПодбор() Экспорт
ПолучитьСтудентовИзХранилища(АдресСтудентовВХранилище); 
КонецПроцедуры
&НаСервере
// Функция восстанавливает список товаров из временного хранилища
Процедура ПолучитьСтудентовИзХранилища(АдресСтудентовВХранилище)
Объект.Студенты.Загрузить(ПолучитьИзВременногоХранилища(АдресСтудентовВХранилище));
КонецПроцедуры

&НаКлиенте
Процедура СтудентыСтудентПриИзменении(Элемент)
Студент=Элементы.Студенты.ТекущиеДанные.Студент;
Элементы.Студенты.ТекущиеДанные.УчебнаяГруппа=УстановитьГруппупоСтуденту(Студент);
КонецПроцедуры

&НаСервере
Функция УстановитьГруппупоСтуденту(Студент)
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ДвижениеКонтингентаСрезПоследних.Группа
|ИЗ
| РегистрСведений.ДвижениеКонтингента.СрезПоследних(
| &ДатаДокумента,
| Статус = &Статус
| И Студент = &Студент) КАК ДвижениеКонтингентаСрезПоследних";

Запрос.УстановитьПараметр("ДатаДокумента", Объект.Дата);
Запрос.УстановитьПараметр("Статус", Перечисления.СтатусыСтудентов.Студент);
Запрос.УстановитьПараметр("Студент", Студент);
Результат = Запрос.Выполнить();
Если НЕ Результат.Пустой() Тогда
Возврат Результат.Выгрузить()[0].Группа;
КонецЕсли;
КонецФункции

&НаКлиенте
Процедура ПослеЗаписи(ПараметрыЗаписи)
НастройкиПользователейКлиент.ОбновитьСостояниеДокумента(Объект, СостояниеДокумента, КартинкаСостоянияДокумента, РазрешеноПроведение);
КонецПроцедуры


Оффлайн alex0402

  • *****
  • Регистрация: 2010-09-10
  • Сообщений: 2000
  • РЕПУТАЦИЯ: 358
  • КПД: 18%
  • Профессия: Программист 1С
Нужно смотреть не код формы, а код модуля.
ОбработкаПровекриЗаполнения
ОбработкаПроведения
Подписки на Документ.
Спасибо за Сказать спасибо

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • *****
  • Регистрация: 2010-11-06
  • Сообщений: 5748
  • РЕПУТАЦИЯ: 1105
  • КПД: 19%
  • Красная армия всех сильней!
    • Skype: cska-fanat-kz81
  • Профессия: Разработчик 1С
глобальным поиском ищите текст ошибки - найдете код проверки.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Формирование документа розничная продажа

Автор SwiniРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 325
Последний ответ 25 Апр 2020, 13:56
от Swini
Формирование документа Реализации товар и услуг в УТ 11

Автор Дмитрий ДжейРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 398
Последний ответ 08 Сен 2020, 09:29
от Дмитрий Джей
Как вывести во внешнюю печатную форму сумму с проводки документа

Автор EvgenyRusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 398
Последний ответ 28 Мая 2019, 12:44
от EvgenyRus
Как сохранить макет печати документа для переноса и использования на другом компьютере?

Автор zork265Раздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 497
Последний ответ 04 Сен 2019, 14:00
от zork265
Создание документа из внешней обработки.

Автор Q37Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1130
Последний ответ 09 Авг 2018, 13:32
от alex0402

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
69 Сообщений
LexaK
67 Сообщений
antoneus antoneus
32 Сообщений
Ивашка
27 Сообщений
neek666
25 Сообщений
KATERINA 861
19 Сообщений
SSC
15 Сообщений
alexandr_ll
13 Сообщений
Алексей_1985_06
12 Сообщений
BuhRust
8 Сообщений

* Кто онлайн

  • Точка Гостей: 706
  • Точка Скрытых: 1
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск