Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2017, 20:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выборка запроса  (Прочитано 340 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Анатолий Анпилогов

  • *
  • Сообщений: 40
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2016-01-12
  • Компания: Арида-Софт
  • Профессия: Программист 1С
Запрос = Новый Запрос();
Запрос.УстановитьПараметр("Организация",Организация);
ТекстЗапроса = "ВЫБРАТЬ
               | КнигиУчетДоступныхОстатки.КоличествоОстаток,
               | КнигиУчетДоступныхОстатки.Номенклатура,
               | КнигиУчетДоступныхОстатки.Организация
               |ИЗ
               | РегистрНакопления.КнигиУчетДоступных.Остатки КАК КнигиУчетДоступныхОстатки";
Если ЗначениеЗаполнено(Организация) Тогда
ТекстЗапроса = ТекстЗапроса + "
               |ГДЕ
               | КнигиУчетДоступныхОстатки.Организация = &Организация";
КонецЕсли;
Запрос.Текст = ТекстЗапроса;
Выборка = Запрос.Выполнить().Выбрать();

КнигиОстатки = Новый ТаблицаЗначений;
КнигиОстатки.Колонки.Добавить("Номенклатура");
КнигиОстатки.Колонки.Добавить("Остаток");
Пока Выборка.Следующий() Цикл
Нов = КнигиОстатки.Добавить();
Нов.Номенклатура = Выборка.Номенклатура;
Нов.Остаток = Выборка.КоличествоОстаток;
КонецЦикла;

СпрКниги = Справочники.Номенклатура.Выбрать();
Пока СпрКниги.Следующий() Цикл
Для Каждого СтрокаТЗ Из КнигиОстатки Цикл
Если СпрКниги.Ссылка = СтрокаТЗ.Номенклатура Тогда
Область.Параметры.СвободныйОстаток = СтрокаТЗ.Остаток;
Область.Параметры.НазваниеКниги = СпрКниги.Наименование;
ТабДок.Вывести(Область);
КонецЕсли;
КонецЦикла;

//Область.Параметры.НазваниеКниги = СпрКниги.Наименование;
//ТабДок.Вывести(Область);
КонецЦикла;

Постановка: Для каждого элемента из СпрКниги Найти соответствие в КнигиОстатки, и получить количество, заранее спасибо


Оффлайн SGIRG

  • **
  • Сообщений: 82
  • РЕПУТАЦИЯ: 26
  • КПД: 32%
  • Регистрация: 2014-03-26
  • Сайт: 
  • Профессия: Программист 8.1
Re: Выборка запроса
« Ответ #1: 29 Авг 2016, 14:02 »
Все в один запрос!
Выборка из справочника Номенклатура и левое соединение с регистром накопления по Номенклатуре.
по поводу условия
|ГДЕ
 |    КнигиУчетДоступныхОстатки.Организация = &Организация";
во первых скорее всего лучше это условие запихать в параметры виртуальной таблицы (пользуйтесь конструктором)
и чтобы не ломать читабельность кода вклиниванием условий типа "Если" в середине текста запроса, желательно писать код следующим образом:
ГДЕ
    ВЫБОР
        КОГДА &Организация = То значение, которое принимает пустая переменная Организация
            ТОГДА ИСТИНА
        ИНАЧЕ КнигиУчетДоступныхОстатки.Организация = &Организация
    КОНЕЦ
Нажимайте "Спасибо", так приятнее))

Оффлайн Лариса198888

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2016-05-18
  • Сайт: 
  • Профессия: Бухгалтер
Re: Выборка запроса
« Ответ #2: 30 Авг 2016, 14:44 »
поимею ввиду


Теги:
 

Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 7761
Последний ответ 14 Июн 2012, 17:44
от Alex1111
"ПОДОБНО" в условие связи запроса

Автор Станиславъ ЗверевъРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 1318
Последний ответ 11 Май 2016, 15:29
от LexaK
Ошибка при выполнении запроса - "неоднозначное поле"

Автор Marta_LiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9981
Последний ответ 21 Апр 2011, 16:00
от Marta_Li
"Зависание" запроса после обращения к регистру бухгалтерии

Автор ShkerinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3494
Последний ответ 03 Ноя 2011, 14:06
от Shkerin
Результат простого запроса "Ошибка чтения значения"

Автор 2CaspРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 7955
Последний ответ 28 Май 2014, 10:41
от 2Casp

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
63 Сообщений
MuI_I_Ika MuI_I_Ika
46 Сообщений
crow1983
35 Сообщений
alexandr_ll
32 Сообщений
LexaK
32 Сообщений
sertak sertak
27 Сообщений
Vzonder
22 Сообщений
BuhRust
19 Сообщений
дфтын дфтын
17 Сообщений

* Кто онлайн

  • Точка Гостей: 242
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 

Dellos Catering - выездной ресторан кейтеринг по всему Миру
SimplePortal 2.3.5 © 2008-2012, SimplePortal