Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Июл 2017, 07:40
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выборка запроса  (Прочитано 771 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Анатолий Анпилогов

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 3
  • КПД: 6%
  • Регистрация: 2016-01-12
  • Компания: Арида-Софт
  • Профессия: Программист 1С
Запрос = Новый Запрос();
Запрос.УстановитьПараметр("Организация",Организация);
ТекстЗапроса = "ВЫБРАТЬ
               | КнигиУчетДоступныхОстатки.КоличествоОстаток,
               | КнигиУчетДоступныхОстатки.Номенклатура,
               | КнигиУчетДоступныхОстатки.Организация
               |ИЗ
               | РегистрНакопления.КнигиУчетДоступных.Остатки КАК КнигиУчетДоступныхОстатки";
Если ЗначениеЗаполнено(Организация) Тогда
ТекстЗапроса = ТекстЗапроса + "
               |ГДЕ
               | КнигиУчетДоступныхОстатки.Организация = &Организация";
КонецЕсли;
Запрос.Текст = ТекстЗапроса;
Выборка = Запрос.Выполнить().Выбрать();

КнигиОстатки = Новый ТаблицаЗначений;
КнигиОстатки.Колонки.Добавить("Номенклатура");
КнигиОстатки.Колонки.Добавить("Остаток");
Пока Выборка.Следующий() Цикл
Нов = КнигиОстатки.Добавить();
Нов.Номенклатура = Выборка.Номенклатура;
Нов.Остаток = Выборка.КоличествоОстаток;
КонецЦикла;

СпрКниги = Справочники.Номенклатура.Выбрать();
Пока СпрКниги.Следующий() Цикл
Для Каждого СтрокаТЗ Из КнигиОстатки Цикл
Если СпрКниги.Ссылка = СтрокаТЗ.Номенклатура Тогда
Область.Параметры.СвободныйОстаток = СтрокаТЗ.Остаток;
Область.Параметры.НазваниеКниги = СпрКниги.Наименование;
ТабДок.Вывести(Область);
КонецЕсли;
КонецЦикла;

//Область.Параметры.НазваниеКниги = СпрКниги.Наименование;
//ТабДок.Вывести(Область);
КонецЦикла;

Постановка: Для каждого элемента из СпрКниги Найти соответствие в КнигиОстатки, и получить количество, заранее спасибо


Оффлайн SGIRG

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: 27
  • КПД: 32%
  • Регистрация: 2014-03-26
  • Сайт: 
  • Профессия: Программист 8.1
Re: Выборка запроса
« Ответ #1: 29 Авг 2016, 14:02 »
Все в один запрос!
Выборка из справочника Номенклатура и левое соединение с регистром накопления по Номенклатуре.
по поводу условия
|ГДЕ
 |    КнигиУчетДоступныхОстатки.Организация = &Организация";
во первых скорее всего лучше это условие запихать в параметры виртуальной таблицы (пользуйтесь конструктором)
и чтобы не ломать читабельность кода вклиниванием условий типа "Если" в середине текста запроса, желательно писать код следующим образом:
ГДЕ
    ВЫБОР
        КОГДА &Организация = То значение, которое принимает пустая переменная Организация
            ТОГДА ИСТИНА
        ИНАЧЕ КнигиУчетДоступныхОстатки.Организация = &Организация
    КОНЕЦ
Нажимайте "Спасибо", так приятнее))

Оффлайн Лариса198888

  • *
  • Сообщений: 16
  • РЕПУТАЦИЯ: -2
  • Регистрация: 2016-05-18
  • Сайт: 
  • Профессия: Бухгалтер
Re: Выборка запроса
« Ответ #2: 30 Авг 2016, 14:44 »
поимею ввиду


Теги:
 

Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 10661
Последний ответ 14 Июн 2012, 17:44
от Alex1111
"ПОДОБНО" в условие связи запроса

Автор Станиславъ ЗверевъРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 2206
Последний ответ 11 Май 2016, 15:29
от LexaK
"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 282
Последний ответ 15 Июн 2017, 07:53
от mvk843
Возможно ли языком запросов без конкатенации текста запроса и без СКД преобразовать строки таблицы в столбцы (колонки) выходной таблицы?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 205
Последний ответ 29 Май 2017, 15:29
от alex0402
Ошибка при выполнении запроса - "неоднозначное поле"

Автор Marta_LiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 11029
Последний ответ 21 Апр 2011, 16:00
от Marta_Li

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alex0402
93 Сообщений
oleg-x
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
64 Сообщений
Golickoff Golickoff
50 Сообщений
ilyay ilyay
44 Сообщений
AIFrame
41 Сообщений
wise wise
31 Сообщений
Амал
30 Сообщений
ab30ru
24 Сообщений
lansy
22 Сообщений

* Кто онлайн

  • Точка Гостей: 352
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal