Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Июл 2017, 21:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: проверка капчи в post запросе  (Прочитано 349 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн zic991

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-27
  • Сайт: 
Подскажите Пожалуйста как проверить капчу, получить "validCaptcha":true

код программы:

&НаСервере
Процедура ПроверкаНаСервере( )

Сервер = "dkbm-web.autoins.ru";
Путь = "/dkbm-web-1.0/osagovehicle.htm";

Попытка
Соединение = Новый HTTPСоединение(Сервер);
//соединение.ПолучитьЗаголовки(
Исключение
Server.ОбработатьИсключение("Не удалось установить соединение с сервером:" +Сервер
+ Символы.ПС + ИнформацияОбОшибке().Описание);
//Возврат Ложь;
КонецПопытки;

Попытка
Ответ = Соединение.GET(Новый HTTPЗапрос("dkbm-web-1.0/osagovehicle.htm"));
Исключение
Server.ОбработатьИсключение(ОписаниеОшибки());
//Возврат Ложь;
КонецПопытки;

JSESSIONID =лев( WebServer.json_encode(Ответ.Заголовки ["Set-Cookie"]),44);

Заголовки = Новый Соответствие();   
Заголовки.Вставить("Accept","image/webp,image/*,*/*;q=0.8");
Заголовки.Вставить("Content-Type","application/x-www-form-urlencoded; charset=UTF-8");
Заголовки.Вставить("Cookie","JSESSIONID="+JSESSIONID);
Заголовки.Вставить("Host","dkbm-web.autoins.ru");
Заголовки.Вставить("Referer","http://dkbm-web.autoins.ru/dkbm-web-1.0/osagovehicle.htm");

Попытка
Ответ1 = Соединение.GET(Новый HTTPЗапрос("dkbm-web-1.0/simpleCaptcha.png",Заголовки));
Исключение
Server.ОбработатьИсключение(ОписаниеОшибки());
КонецПопытки;
КартинкаКапчи = Ответ1.ПолучитьТелоКакДвоичныеДанные();
Капча = ПоместитьВоВременноеХранилище(КартинкаКапчи, УникальныйИдентификатор);



КонецПроцедуры

&НаКлиенте
Процедура Проверить(Команда)
Заголовки1 = Новый Соответствие();   

Заголовки1.Вставить("Accept","application/json");
Заголовки1.Вставить("Content-Type","application/x-www-form-urlencoded; charset=UTF-8");
Заголовки1.Вставить("Cookie","JSESSIONID="+JSESSIONID);
Заголовки1.Вставить("Connection","keep-alive");
Заголовки1.Вставить("Host","dkbm-web.autoins.ru");
Заголовки1.Вставить("Referer","http://dkbm-web.autoins.ru/dkbm-web-1.0/osagovehicle.htm");

ПараметрыЗапроса = Новый Структура();
ПараметрыЗапроса.Вставить("serialOsago",СерияПолиса);
ПараметрыЗапроса.Вставить("numberOsago",НомерПолиса);
ПараметрыЗапроса.Вставить("dateRequest",ДатаПроверки);
ПараметрыЗапроса.Вставить("answer",ТекстКапчи);

СодержимоеЗапроса = Новый HTTPЗапрос("/dkbm-web-1.0/osagovehicle.htm", Заголовки1);
СодержимоеЗапроса.УстановитьТелоИзСтроки("serialOsago="+СерияПолиса+"&numberOsago="+НомерПолиса+"&dat­eRequest="+ДатаПроверки+"&answer="+ТекстКапчи);


Соединение = Новый HTTPСоединение("dkbm-web.autoins.ru");

Попытка
Ответ2 = Соединение.POST(СодержимоеЗапроса);

Исключение
Server.ОбработатьИсключение(ОписаниеОшибки());
//Возврат Ложь;
КонецПопытки;

Результат = Ответ2.ПолучитьТелоКакСтроку()+ Ответ2.КодСостояния;

КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии()

ПроверкаНаСервере( );
КонецПроцедуры


 

Получить номер недели в месяце в запросе [номер недели]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 3384
Последний ответ 15 Июл 2015, 18:24
от MuI_I_Ika
РС "СостояниеОСОрганизаций" в запросе

Автор ILLUMIРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 973
Последний ответ 07 Янв 2015, 05:33
от ILLUMI
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1724
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Поле не найдено" в запросе, но оно есть.

Автор ferrari314Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2061
Последний ответ 27 Окт 2015, 10:29
от vitasw
Временная таблица во вложенном запросе+Группировка VS Таблица значений + Свернуть

Автор TsaigerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 179
Последний ответ 14 Июл 2017, 23:10
от Tsaiger

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
105 Сообщений
alex0402
93 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
65 Сообщений
ilyay ilyay
49 Сообщений
Golickoff Golickoff
49 Сообщений
AIFrame
47 Сообщений
ab30ru
38 Сообщений
wise wise
34 Сообщений
Амал
30 Сообщений
LexaK
22 Сообщений

* Кто онлайн

  • Точка Гостей: 230
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal