Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Сен 2017, 10:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Добавление кнопки "Подбор" в табличную часть  (Прочитано 2604 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн r-try

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-11
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день. Понадобилась база для ведения не большого учета оборудования. Решил написать сам на 1с, заодно разобрать что к чему. Возникла проблема при добавлении кнопки "Подбор" в табличной части документа. Не работает, форма выбора открывается, но строка с номенклатурой не добавляется. Понятно что где-то накосячил, что с наскока нельзя делать, но вот так получилось :)
код
// отрабатываем подбор
&НаКлиенте
 Процедура Подбор(Команда)
ПараметрыФормы = Новый Структура ("ЗакрыватьПриВыборе", Истина);
ОткрытьФорму("Справочник.Номенклатура.ФормаВыбора", ПараметрыФормы, Элементы.СписокОборудования);
 КонецПроцедуры
 // отрабатываем подбор
&НаКлиенте
 Процедура СписокОборудованияОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
Сч =  проверкаНаличия(ВыбранноеЗначение);

Если Сч = 0 Тогда
Элементы.СписокОборудования.ДобавитьСтроку();
Элементы.СписокОборудования.ТекущиеДанные.Номенклатура = ВыбранноеЗначение;
КонецЕсли
 КонецПроцедуры
         // отрабатываем подбор
 &НаСервере
Функция проверкаНаличия(ВыбранноеЗначение)
Сч = 0;
Для каждого Строч Из Объект.СписокОборудования Цикл
Если Строч.Номенклатура = ВыбранноеЗначение тогда
Строч.Количество = Строч.Количество + 1;// Если товар уже есть - то просто приплюсуем его;
Сч = 1;
КонецЕсли;
КонецЦикла;
Возврат Сч;
КонецФункции


Оффлайн vitasw

  • *****
  • Сообщений: 2546
  • РЕПУТАЦИЯ: 309
  • КПД: 12%
  • Регистрация: 2015-02-10
  • Сайт: 
  • Профессия: Программист 1С
Так а что форма подбора возвращает?

Оффлайн Artjomrgv

  • ***
  • Сообщений: 131
  • РЕПУТАЦИЯ: 12
  • КПД: 9%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Добрый день. Понадобилась база для ведения не большого учета оборудования. Решил написать сам на 1с, заодно разобрать что к чему. Возникла проблема при добавлении кнопки "Подбор" в табличной части документа. Не работает, форма выбора открывается, но строка с номенклатурой не добавляется.
[/code]

Я конечно "сварщик не настоящий". Тебе здесь опытные программисты напишут вариант лучше. Но на всякий случай попробуй вот. У меня работает.
//
&НаКлиенте
Процедура Подбор(Команда)
ОткрытьФорму("Справочник.Номенклатура.ФормаВыбора",,Элементы.Номен)
КонецПроцедуры

&НаКлиенте
Процедура НоменОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
   
Для Каждого Элемен из Объект.Номен Цикл

Если Элемен.Номенклатура=ВыбранноеЗначение Тогда
Элемен.Количество=Элемен.Количество+1  Иначе
КонецЕсли
КонецЦикла;
Элемент=0;    
Для Каждого Элемен из Объект.Номен Цикл
    Если Элемен.Номенклатура = ВыбранноеЗначение Тогда Элемент=Элемент+1
КонецЕсли
    КонецЦикла;
   Если Элемент=0  Тогда
    Элементы.Номен.ДобавитьСтроку();
    Элементы.Номен.ТекущиеДанные.Номенклатура=ВыбранноеЗначение;
КонецЕсли
КонецПроцедуры
[/quote]

Оффлайн r-try

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-11
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день. Понадобилась база для ведения не большого учета оборудования. Решил написать сам на 1с, заодно разобрать что к чему. Возникла проблема при добавлении кнопки "Подбор" в табличной части документа. Не работает, форма выбора открывается, но строка с номенклатурой не добавляется.
[/code]

Я конечно "сварщик не настоящий". Тебе здесь опытные программисты напишут вариант лучше. Но на всякий случай попробуй вот. У меня работает.
//
&НаКлиенте
Процедура Подбор(Команда)
ОткрытьФорму("Справочник.Номенклатура.ФормаВыбора",,Элементы.Номен)
КонецПроцедуры

&НаКлиенте
Процедура НоменОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
   
Для Каждого Элемен из Объект.Номен Цикл

Если Элемен.Номенклатура=ВыбранноеЗначение Тогда
Элемен.Количество=Элемен.Количество+1  Иначе
КонецЕсли
КонецЦикла;
Элемент=0;    
Для Каждого Элемен из Объект.Номен Цикл
    Если Элемен.Номенклатура = ВыбранноеЗначение Тогда Элемент=Элемент+1
КонецЕсли
    КонецЦикла;
   Если Элемент=0  Тогда
    Элементы.Номен.ДобавитьСтроку();
    Элементы.Номен.ТекущиеДанные.Номенклатура=ВыбранноеЗначение;
КонецЕсли
КонецПроцедуры
[/quote]

Все также :( Форма выбора открывается, тыкаю номенклатуру, форма закрывается, в табличной части документа пусто. не добавляется.

Оффлайн Artjomrgv

  • ***
  • Сообщений: 131
  • РЕПУТАЦИЯ: 12
  • КПД: 9%
  • Регистрация: 2014-02-25
  • Сайт: 
  • Профессия: Консультант 1С
А в событиях формы процедура указана.

Оффлайн r-try

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-11
  • Сайт: 
  • Профессия: Ученик 1С
А в событиях формы процедура указана.

Эврика, код переписывал несколько раз, там и пропало указание процедуры. СПС!


 

Часть четвертая: переход на «1С» версии «3.0». Где в программе находятся «Параметры учета»? Алгоритм настройки кадрового учета в новой версии программы «1С»

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 3636
Последний ответ 20 Мар 2015, 12:58
от 1cwiki
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 99
Последний ответ 25 Сен 2017, 09:00
от Св Ч
часть уплаченного НДФЛ не попадает в справку 2-ндфл

Автор КаринаСРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1558
Последний ответ 30 Янв 2015, 02:08
от MuI_I_Ika
Уменьшение закупочной цены-уменьшение прибыли на часть товара

Автор AinaРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3367
Последний ответ 13 Дек 2012, 18:46
от Aina
Часть вторая: основные отличия старой версии «2.5» от новой «3.0». Какие новинки в «1С ЗУП» версии «3.0»?

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 3934
Последний ответ 23 Мар 2015, 15:42
от 1cwiki

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
135 Сообщений
alex0402
81 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
76 Сообщений
BuhRust
24 Сообщений
Golickoff Golickoff
23 Сообщений
AIFrame
21 Сообщений
ilyay ilyay
21 Сообщений
Kironten
20 Сообщений
Варвар
20 Сообщений
Римма
18 Сообщений

* Кто онлайн

  • Точка Гостей: 1022
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal