Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Окт 2017, 20:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Изменение точки подключения  (Прочитано 833 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Greiv

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-09
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, пытаюсь поменять точку подключения при создании WSСсылки и не чего не получается, меняю, потому что та точка подключения которая видимо загрузилась вместе с wsdl ссылкой, не подходит.
Вот код создания прокси:
Прокси = WSСсылки.WS_Common.СоздатьWSПрокси(ПространствоИмёнXDTO, СервисРаботы, ПортСервиса,,,,ТочкаПодключенияКотораяНужна);
Такой способ не даёт результата, точка подключения не меняется, может есть другой способ поменять, просто не смог найти синтаксиса или это может можно сделать в самой WSСсылке?


Оффлайн Greiv

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-07-09
  • Сайт: 
  • Профессия: Ученик 1С
Указанной выше разобрался, но появилась другая, суть вот в чём:
При отправке вот таким методом
&НаСервере
Процедура Окай2()
СоапЗапрос =  "<soapenv:Envelope xmlns:soapenv=""http://schemas.xmlsoap.org/soap/envelope/"" xmlns:ns=""http://dom.gosuslugi.ru/schema/integration/10.0.0.6/"" xmlns:nsi=""http://dom.gosuslugi.ru/schema/integration/10.0.0.6/nsi-common/"" xmlns:xd=""http://www.w3.org/2000/09/xmldsig#"">
   |<soapenv:Header>
   |   <ns:ISRequestHeader>
    |     <ns:Date>2016-08-22T11:22:28</ns:Date>
    |     <ns:MessageGUID>5ae0a87d-b604-4e4b-a8f8-ec83f6414ab2</ns:MessageGUID>
    |  </ns:ISRequestHeader>
   |</soapenv:Header>
   |<soapenv:Body>
   |   <nsi:exportNsiListRequest>
   |   </nsi:exportNsiListRequest>
   |</soapenv:Body>
|</soapenv:Envelope>";
oXMLHTTP = Новый COMОбъект("MSXML2.XMLHTTP");

стрURL="http://localHost:8080/ext-bus-nsi-common-service/services/NsiCommon";

oXMLHTTP.open("POST", стрURL, 0, Логин, Пароль);

oXMLHTTP.setRequestHeader("Content-Type", "text/xml; charset=utf-8");

oXMLHTTP.setRequestHeader("SOAPAction", "urn:exportNsiList");
oXMLHTTP.send(СоапЗапрос);

Если oXMLHTTP.Status=200 тогда
ндок = Новый ТекстовыйДокумент;
нхмл = ПолучитьИмяВременногоФайла("XML");
ндок.ДобавитьСтроку(oXMLHTTP.responseText);
ндок.Записать(нхмл);
ХМЛ= Новый COMОбъект("MSXML2.DOMDocument");
ХМЛ.load(нхмл);
Корешок=ХМЛ.DocumentElement;

Родитель = Корешок.SelectNodes("//ns4:NsiItemInfo");
СписокНомеровСправ = корешок.SelectNodes("//ns4:RegistryNumber");
СписокНазванийСправочников = корешок.SelectNodes("//ns4:Name");
списокДатИзмененияСправочников = корешок.SelectNodes("//ns4:Modified");
Для чКК=0 По СписокНомеровСправ.Length Цикл
Попытка
НомерСправочника = СписокНомеровСправ.Item(чКК).nodeTypedValue;
НазваниеСправочника = СписокНазванийСправочников.Item(чКК).nodeTypedValue;
ДатаПоследнегоИзменения = списокДатИзмененияСправочников.Item(чКК).nodeTypedValue;
тт = Табд.Добавить();
тт.НомерСправочника = НомерСправочника;
тт.НазваниеСправочника = НазваниеСправочника;
тт.ДатаПоследнегоИзменения = ДатаПоследнегоИзменения;
Исключение
Прервать;
КонецПопытки;
КонецЦикла;
УдалитьФайлы(нхмл);
КонецЕсли;
КонецПроцедуры
Всё получается, но с этим способом есть проблема, он использует внешнюю компоненту которая допустим на 2012 сервере не работает уже.
Ко всему этому делу есть ws-ссылки с помощью которых можно сформировать запрос и вот пример запроса:
&НаСервере
Процедура Окай2()
Прокси = WSСсылки.WS_Common.СоздатьWSПрокси("http://dom.gosuslugi.ru/schema/integration/10.0.0.6/nsi-common-service/", "NsiService", "NsiPort");
Прокси.Пользователь         = Логин;
Прокси.Пароль = Пароль;
ДанныеЗаголовка = Прокси.ФабрикаXDTO.Пакеты[2].КорневыеСвойства[47].Тип;
тДанныеЗаголовка = Прокси.ФабрикаXDTO.Создать(ДанныеЗаголовка);
тДанныеЗаголовка.Date         = ТекущаяДата();
тДанныеЗаголовка.MessageGUID                 = Строка(Новый УникальныйИдентификатор);
ТипWSПараметра = Прокси.ФабрикаXDTO.Пакеты.Получить("http://dom.gosuslugi.ru/schema/integration/10.0.0.6/nsi-common/").Получить("exportNsiListRequest");
WSПараметр     = Прокси.ФабрикаXDTO.Создать(ТипWSПараметра);
СписокСправочника = Прокси.exportNsiList(WSПараметр);
ф=22;
КонецПроцедуры
И при отправке у меня должен получиться запрос указанный выше, но получается вот этот бред
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body> <exportNsiListRequest xmlns="http://dom.gosuslugi.ru/schema/integration/10.0.0.6/nsi-common/"
xmlns:xs="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"/></soap:Body>
</soap:Envelope>
Как видно элемент Header вообще отсутствует, а он обязательный и вот собственно как его заполнить я то и не пойму, также в запросе обязательно должно быть замыкающее свойство <ns:ISRequestHeader> до которого я тоже не могу не как достучаться. У кого нибудь есть мысли по этому поводу?
Кстати для примера вот самый адекватный рабочий вид данного запроса сформированный в SoapUI:
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns="http://dom.gosuslugi.ru/schema/integration/10.0.0.6/" xmlns:nsi="http://dom.gosuslugi.ru/schema/integration/10.0.0.6/nsi-common/" xmlns:xd="http://www.w3.org/2000/09/xmldsig#">
   <soapenv:Header>
      <ns:ISRequestHeader>
         <ns:Date>2016-08-22T11:22:28</ns:Date>
         <ns:MessageGUID>5ae0a87d-b604-4e4b-a8f8-ec83f6414ab2</ns:MessageGUID>
      </ns:ISRequestHeader>
   </soapenv:Header>
   <soapenv:Body>
      <nsi:exportNsiListRequest>
      </nsi:exportNsiListRequest>
   </soapenv:Body>
</soapenv:Envelope>


Теги:
 

Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 144
Последний ответ 12 Окт 2017, 14:02
от wise
Как запретить пользователям с интерфейсом "Ввод табеля" изменение графы профессия у подобранного сотрудника в сдельном наряде и табеле учета рабочего времени

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 975
Последний ответ 15 Сен 2016, 02:46
от ksander-fars
Изменение вида "выпадающего списка"

Автор JohnDoe144Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1131
Последний ответ 20 Май 2016, 13:26
от LexaK
Запрет на изменение "справочники - предприятие"

Автор maskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 862
Последний ответ 25 Июл 2016, 09:09
от SGIRG
Изменение стандартной функции клавиши "Del" в документе

Автор APMEH19Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2558
Последний ответ 24 Янв 2011, 16:13
от Klyacksa

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
93 Сообщений
alex0402
54 Сообщений
AIFrame
43 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
38 Сообщений
Oldman06
31 Сообщений
Golickoff Golickoff
30 Сообщений
vitasw
29 Сообщений
MuI_I_Ika MuI_I_Ika
19 Сообщений
DmitriyF DmitriyF
14 Сообщений
BuhRust
13 Сообщений

* Кто онлайн

  • Точка Гостей: 286
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal