Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 22:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Группировка в отчёте  (Прочитано 9646 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sinsinmin

  • ***
  • Сообщений: 116
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-08-11
  • Сайт: 
Как в отчёте сделанным в ручную, на макете слева сделать группировку по дате. Нажал на плюсик и раскрылись записа с датой. На минус и они закрылись.


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Ключевые слова: "НачатьАвтогруппировкуСтрок" и "ЗакончитьАвтогруппировкуСтрок".

Оффлайн Sinsinmin

  • ***
  • Сообщений: 116
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-08-11
  • Сайт: 
не понял. Делается запрос, потом после определённых процедур он выводится в макет. Куда писать эти ключевые слова?

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Про эти ключевые слова надо читать в мануале.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Если не разберетесь - запостите код отчета.

Оффлайн Sinsinmin

  • ***
  • Сообщений: 116
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-08-11
  • Сайт: 
НачальнаяДатаЦикла = НачальнаяДата;
   ЧислоСтрокой = "00";
    Для N = 0 По 99 Цикл
        ЧислоСтрокой = ЧислоСтрокой + Формат(N,"ЧЦ=2; ЧВН=");
   КонецЦикла;
   Фильтр = "";
   Если Отливка <> Справочники.Отливки.ПустаяСсылка() тогда
      Фильтр = "Отливка = &Отливка И";
   КонецЕсли;
   ЗапросПоБраку = Новый Запрос;
   ЗапросПоБраку.текст = "ВЫБРАТЬ
                         |   БракСрезПоследних.Отливка,
                         |   СУММА(БракСрезПоследних.Количество) КАК Количество,
                         |   БракСрезПоследних.Регистратор.Дата,
                         |   ПОДСТРОКА(&ЧислоСтрокой, ДЕНЬ(БракСрезПоследних.Регистратор.Дата) * 2 + 1, 2) + ""."" + ПОДСТРОКА(&ЧислоСтрокой, МЕСЯЦ(БракСрезПоследних.Регистратор.Дата) * 2 + 1, 2) + ""."" + ВЫБОР
                         |      КОГДА ГОД(БракСрезПоследних.Регистратор.Дата) > 2000
                         |         ТОГДА ""20"" + ПОДСТРОКА(&ЧислоСтрокой, (ГОД(БракСрезПоследних.Регистратор.Дата) - 2000) * 2 + 1, 2)
                         |      ИНАЧЕ ""19"" + ПОДСТРОКА(&ЧислоСтрокой, (ГОД(БракСрезПоследних.Регистратор.Дата) - 1900) * 2 + 1, 2)
                         |   КОНЕЦ КАК ДатаБракаМакет,
                         |   БракСрезПоследних.Невыход КАК Невыход
                         |ИЗ
                         |   РегистрСведений.Брак.СрезПоследних(
                         |         , "+Фильтр+" Регистратор.ЦехИзготовитель= &ЦехИзготовитель И
                         |         Регистратор.Дата МЕЖДУ &НачальнаяДата И &КонечнаяДата
                         |            И (НЕ ВидБрака В ИЕРАРХИИ (&ИБК))) КАК БракСрезПоследних
                         |
                         |СГРУППИРОВАТЬ ПО
                         |   БракСрезПоследних.Отливка,
                         |   БракСрезПоследних.Регистратор.Дата,
                         |   БракСрезПоследних.Невыход
                         |
                         |УПОРЯДОЧИТЬ ПО
                         |   Невыход";
                   
   ЗапросПоБраку.УстановитьПараметр("ИБК", Справочники.Брак.НайтиПоНаименованию("ИБК"));
   ЗапросПоБраку.УстановитьПараметр("Отливка", Отливка);
   ЗапросПоБраку.УстановитьПараметр("НачальнаяДата", НачальнаяДата);
   ЗапросПоБраку.УстановитьПараметр("КонечнаяДата", КонечнаяДата+60*60*24);
   ЗапросПоБраку.УстановитьПараметр("ЧислоСтрокой", ЧислоСтрокой);
   ЗапросПоБраку.УстановитьПараметр("ЦехИзготовитель", ЦехИзготовитель);
   МассивПоБраку = ЗапросПоБраку.Выполнить().Выгрузить();
   //МассивПоБраку.Свернуть("РегистраторДата, Отливка, Невыход, ДатаБракаМакет", "Количество");
   //МассивПоБраку.Свернуть("РегистраторДата, Отливка, Количество, ДатаБракаМакет", "Невыход");
   МассивПоБраку.Свернуть("Отливка, Невыход, ДатаБракаМакет,РегистраторДата", "Количество");
   МассивПоБраку.Сортировать("Отливка,ДатаБракаМакет,Невыход");
   Макет = ЭтотОбъект.ПолучитьМакет("Макет");
   Шапка = Макет.ПолучитьОбласть("Шапка");
   ЭлементыФормы.ТабДок.Очистить();
   ЭлементыФормы.ТабДок.Вывести(Шапка);
   Область = Макет.ПолучитьОбласть("Область");
   

   КоличествоДней = (КонечнаяДата - НачальнаяДата)/86400;
   Пока КоличествоДней > 0 цикл

      КоличествоБрака = 0;
      КоличествоНевыхода = 0;
      КоличествоДней = КоличествоДней - 1;      
      Для каждого СтрокаБрака из МассивПоБраку цикл
         ДатаСтроки =Дата_(СтрокаБрака.ДатаБракаМакет);
         Если ДатаСтроки >= НачальнаяДатаЦикла и ДатаСтроки <  НачальнаяДатаЦикла + 86400 тогда
            Если СтрокаБрака.Невыход <> 0 тогда
               КоличествоБрака = СтрокаБрака.Количество;
               //Отливка = СтрокаБрака.отливка;
               ПроцентНевыхода = СтрокаБрака.Невыход;
               Область.Параметры.КоличествоНевыхода = КоличествоБрака;
               Область.Параметры.ПроцентНевыхода = ПроцентНевыхода;
               Область.Параметры.Дата = СтрокаБрака.ДатаБракаМакет;
               Область.Параметры.Отливка = СтрокаБрака.Отливка;
               ЭлементыФормы.ТабДок.Вывести(Область);
             КонецЕсли;
         КонецЕсли;   
       КонецЦикла;
   НачальнаяДатаЦикла = НачальнаяДатаЦикла + 86400;


   КонецЦикла;   
   
КонецПроцедуры

Процедура ПриОткрытии()
   // Вставить содержимое обработчика.
   НачальнаяДата = НачалоМесяца(ТекущаяДата());
   КонечнаяДата = ТекущаяДата()+60*60*24;
   ЦехИзготовитель = Справочники.Подразделения.НайтиПоКоду("62");
КонецПроцедуры

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Вы что, даже не потрудились ничего почитать???
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн leonlegion

  • *
  • Сообщений: 38
  • РЕПУТАЦИЯ: 3
  • КПД: 8%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Бухгалтер
Все просто, заходишь в настройки отчета перед его выведением и во вкладке группировка - делаешь по дате, по крайней мере в УТ 10.3 работает очень просто

Оффлайн Sinsinmin

  • ***
  • Сообщений: 116
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-08-11
  • Сайт: 
Отчёт сделан вручную. Не через конструктор отчёта

Оффлайн Sinsinmin

  • ***
  • Сообщений: 116
  • РЕПУТАЦИЯ: 9
  • КПД: 8%
  • Регистрация: 2010-08-11
  • Сайт: 
Почитать то я потрудился, только вот там какие то уровни, а где их брать не понятно. Так я без уровней написал в начале и конце группировку и она не работает


Теги:
 

"Зебра" во внешнем отчете"

Автор AK11Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 364
Последний ответ 23 Дек 2016, 22:01
от AK11
как в отчете "Главная книга" отображать для счетов столбцы не только "С кредита", но и "На дебет"

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1130
Последний ответ 13 Мар 2016, 00:55
от дфтын
Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 473
Последний ответ 18 Янв 2017, 11:42
от VladimirMelnychenko
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7354
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
в отчете показывает остатки в файловой базе, в sql не показывает

Автор StanforevaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1166
Последний ответ 12 Апр 2016, 12:18
от Stanforeva

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 218
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal