Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 июн 2021, 04:09

Итого (Сумма) в макете документа

Автор ox2net, 21 авг 2016, 20:03

0 Пользователей и 1 гость просматривают эту тему.

ox2net

Добрый вечер уважаемые программисты!
Являюсь начинающим программистом 1с, столкнулся по ходу с тривиальной задачей, но не могу найти решения.
1с 8.3, самописная конфигурация, пытаюсь самостоятельно в счет-фактуру вывести все данные. Все данные вывел,
а вот общий итог по всем строкам с суммами ну хоть убей не могу понять как, вот код:


Процедура СФ(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(СФ)
Макет = Документы.Расходная.ПолучитьМакет("СФ");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Расходная.Дата,
| Расходная.Контрагент,
| Расходная.Номер,
| Расходная.Товары.(
| Номенклатура,
| Цена,
| Количество,
| Сумма,
| ЕдИзм,
| ЕдИзм.ОКЕИ КАК ОКЕИ
| ),
| Расходная.Контрагент.Адрес КАК Адрес,
| Расходная.Контрагент.ИНН КАК ИНН,
| Расходная.Контрагент.КПП КАК КПП
|ИЗ
| Документ.Расходная КАК Расходная
|ГДЕ
| Расходная.Ссылка В(&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();

ОбластьЗаголовок         = Макет.ПолучитьОбласть("Заголовок");
Шапка                    = Макет.ПолучитьОбласть("Шапка");
ОбластьТоварыШапка       = Макет.ПолучитьОбласть("ТоварыШапка");
ОбластьТовары            = Макет.ПолучитьОбласть("Товары");
Итого                    = Макет.ПолучитьОбласть("Итого");
Подвал                   = Макет.ПолучитьОбласть("Подвал");

ТабДок.Очистить();

ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

ТабДок.Вывести(ОбластьЗаголовок);

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

ТабДок.Вывести(ОбластьТоварыШапка);
ВыборкаТовары = Выборка.Товары.Выбрать();
Пока ВыборкаТовары.Следующий() Цикл
ОбластьТовары.Параметры.Заполнить(ВыборкаТовары);
ТабДок.Вывести(ОбластьТовары, ВыборкаТовары.Уровень());
КонецЦикла;

Итого.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Итого);

Подвал.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Подвал);

ВставлятьРазделительСтраниц = Истина;
КонецЦикла;
//}}

КонецПроцедуры


LexaK

у табличной части документа есть метод Итог

вставьте куда ни будь в ваш код, такую команду

ОбщаяСумма = Ссылка.Товары.Итог("Сумма");
и выведите ОбщаяСумма в ваш макет (табличный документ).
Помогло? - Нажми СПАСИБО (под аватаром) !!!
                       :)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск