Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2017, 17:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Итого (Сумма) в макете документа  (Прочитано 371 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ox2net

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-21
  • Сайт: 
  • Профессия: Ученик 1С
Добрый вечер уважаемые программисты!
Являюсь начинающим программистом 1с, столкнулся по ходу с тривиальной задачей, но не могу найти решения.
1с 8.3, самописная конфигурация, пытаюсь самостоятельно в счет-фактуру вывести все данные. Все данные вывел,
а вот общий итог по всем строкам с суммами ну хоть убей не могу понять как, вот код:

Процедура СФ(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(СФ)
Макет = Документы.Расходная.ПолучитьМакет("СФ");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Расходная.Дата,
| Расходная.Контрагент,
| Расходная.Номер,
| Расходная.Товары.(
| Номенклатура,
| Цена,
| Количество,
| Сумма,
| ЕдИзм,
| ЕдИзм.ОКЕИ КАК ОКЕИ
| ),
| Расходная.Контрагент.Адрес КАК Адрес,
| Расходная.Контрагент.ИНН КАК ИНН,
| Расходная.Контрагент.КПП КАК КПП
|ИЗ
| Документ.Расходная КАК Расходная
|ГДЕ
| Расходная.Ссылка В(&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();

ОбластьЗаголовок         = Макет.ПолучитьОбласть("Заголовок");
Шапка                    = Макет.ПолучитьОбласть("Шапка");
ОбластьТоварыШапка       = Макет.ПолучитьОбласть("ТоварыШапка");
ОбластьТовары            = Макет.ПолучитьОбласть("Товары");
Итого                    = Макет.ПолучитьОбласть("Итого");
Подвал                   = Макет.ПолучитьОбласть("Подвал");

ТабДок.Очистить();

ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

ТабДок.Вывести(ОбластьЗаголовок);

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

ТабДок.Вывести(ОбластьТоварыШапка);
ВыборкаТовары = Выборка.Товары.Выбрать();
Пока ВыборкаТовары.Следующий() Цикл
ОбластьТовары.Параметры.Заполнить(ВыборкаТовары);
ТабДок.Вывести(ОбластьТовары, ВыборкаТовары.Уровень());
КонецЦикла;

Итого.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Итого);

Подвал.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Подвал);

ВставлятьРазделительСтраниц = Истина;
КонецЦикла;
//}}

КонецПроцедуры


Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>


Оффлайн LexaK

  • *****
  • Сообщений: 1214
  • РЕПУТАЦИЯ: 333
  • КПД: 27%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
у табличной части документа есть метод Итог

вставьте куда ни будь в ваш код, такую команду

ОбщаяСумма = Ссылка.Товары.Итог("Сумма");
и выведите ОбщаяСумма в ваш макет (табличный документ).
Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4039
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14195
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3539
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 147
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7002
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
85 Сообщений
wise wise
63 Сообщений
Dethmontt Dethmontt
60 Сообщений
MuI_I_Ika MuI_I_Ika
52 Сообщений
alex0402
49 Сообщений
ilyay ilyay
32 Сообщений
Сергей Федоров Сергей Федоров
32 Сообщений
ilnur75
23 Сообщений
Дмитрий Медведков
19 Сообщений
magnifico61
18 Сообщений

* Кто онлайн

  • Точка Гостей: 365
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal